error importing photos in ptp mode

Bug #74279 reported by jouzeau on 2006-12-03
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
f-spot (Debian)
Fix Released
Unknown
f-spot (Ubuntu)
Medium
Unassigned

Bug Description

With a Nikon D200 camera, f-spot recognizes the camera but issues an undefined error when trying to retrieve the photos in ptp mode. In USB mass storage mode, everything goes fine.

The error messages are the following:

Error GeneraError: LibGPhoto2.GPhotoException: Erreur indéfinie
  at LibGPhoto2.CameraFilesystem.ListFiles (System.String folder, LibGPhoto2.Context context) [0x00000]
  at GPhotoCamera.GetFileList (System.String dir) [0x00000]
  at GPhotoCamera.GetFileList (System.String dir) [0x00000]
  at GPhotoCamera.GetFileList () [0x00000]
  at GPhotoCamera.InitializeCamera () [0x00000]
  at MainWindow.ImportCamera (System.String camera_device) [0x00000]

Nota: gphoto2 -P command works fine in PTP mode

Andrew Mitchell (ajmitch) wrote :

What version of f-spot & libgphoto2-2 are you using?

Andrew Mitchell a écrit :
> What version of f-spot & libgphoto2-2 are you using?
>
>
f-spot 0.2.1
libgphoto2.2.1-2

Jürgen Kreileder (jk) wrote :

Still happens with

ii f-spot 0.3.5-0ubuntu1 personal photo management application
ii libgphoto2-2 2.3.0-0ubuntu3 gphoto2 digital camera library

Changed in f-spot:
status: Unconfirmed → Confirmed
fish (discordianfish) wrote :

We have the same problem here:

cleanup context
item ImportCommand+SourceItem
Ubuntu 7.10 ppc - gnome-dev-cdrom - Mountpoint file:///media/cdrom0 True True Cdrom
Cdrom
item ImportCommand+SourceItem
Testing gphoto path = usb:
PortInfo Universal Serial Bus, usb:
cleanup context
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.OverflowException: Number overflow.
  at LibGPhoto2.CameraFile.GetDataAndSize () [0x00000]
  at GPhotoCamera.GetPreviewPixbuf (.GPhotoCameraFile camfile) [0x00000]
  at FSpot.CameraFileSelectionDialog.GetPreviews () [0x00000]
  at FSpot.CameraFileSelectionDialog.CreateInterface () [0x00000]
  at FSpot.CameraFileSelectionDialog.Run () [0x00000]
  at MainWindow.ImportCamera (System.String camera_device) [0x00000]
  at ImportCommand.set_Source (.SourceItem value) [0x00000]
  at ImportCommand+SourceMenu.HandleActivated (System.Object sender, System.EventArgs args) [0x00000]
  at (wrapper delegate-invoke) System.MulticastDelegate:invoke_void_object_EventArgs (object,System.EventArgs)
  at GLib.Signal.voidObjectCallback (IntPtr handle, IntPtr gch) [0x00000]

   at GLib.Signal.voidObjectCallback ()
   at Gtk.Dialog.gtk_dialog_run ()
   at Gtk.Dialog.gtk_dialog_run ()
   at Gtk.Dialog.Run ()
   at ImportCommand.ImportFromFile ()
   at MainWindow.HandleImportCommand ()
   at System.MulticastDelegate.invoke_void_object_EventArgs ()
   at GLib.Signal.voidObjectCallback ()
   at GLib.Signal.voidObjectCallback ()
   at Gtk.Application.gtk_main ()
   at Gtk.Application.gtk_main ()
   at Gtk.Application.Run ()
   at Gnome.Program.Run ()
   at FSpot.Driver.Main ()
cleanup context

Here gphoto2 -P works well too. Its just generating a warning about setting file attributes (which is the same on all systems i use to download photos from that camera):

*** Fehler ***
canon_usb_set_file_attributes: canon_usb_dialogue failed
Speichere Datei als IMG_5377.JPG
Downloading 'IMG_5378.JPG' from folder '/DCIM/153CANON'...

System specs:
Camera is a Canon EOS 350D (aka. Rebell XT)

iBook G4:
sophie@maia:~$ cat /proc/cpuinfo
processor : 0
cpu : 7447A, altivec supported
clock : 666.666000MHz
revision : 0.1 (pvr 8003 0101)
bogomips : 36.73
timebase : 18432000
platform : PowerMac
machine : PowerBook6,5
motherboard : PowerBook6,5 MacRISC3 Power Macintosh
detected as : 287 (iBook G4)
pmac flags : 0000001b
L2 cache : 512K unified
pmac-generation : NewWorld

Ubuntu 7.10, installed with alternative CD. Everything up to date (apt-get upgrade).
libgphoto2-2: Version: 2.4.0-2ubuntu2
f-spot: Version: 0.4.0-0ubuntu3

Maybe important: The import worked without problems on a x86 Notebook (Thinkpad R51) with the same Ubuntu version and the same camera!

fish (discordianfish) wrote :

Oops, i was confused about the french error message. I guess thats the wrong place for my bug report. Can someone move this comment to a new bug? or delete it and i'll fill a new bug report.

fish (discordianfish) wrote :

There is a debian bugreport which seams to be exacly my problem: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=439816

Maia Everett (linneris) on 2008-01-05
Changed in f-spot:
importance: Undecided → Medium
status: Confirmed → Triaged
status: New → Unknown
Changed in f-spot:
status: Unknown → Confirmed

This is still happening in Hardy with Nikon D50.
I have f-spot 0.4.2, libgphoto2.4.0-8ubuntu5.

gThumb works fine with the PTP mode.

culmore (culmore) wrote :

I get exactly this problem with a Canon D400, on the latest fully patched version of Hardy Herron (7.04).

F-spot version 4.3.1
libgphoto2-2

PS This version of Ubuntu is the best yet for me. Almost everything just worked out of the box!

Oleksij Rempel (olerem) wrote :

Seem like this is old tradition, begine new ubuntu relase with this bug. I have this issu on ubuntu 9.04 jaunty amd64.

f-spot version 0.5.0.3-0ubuntu5

Debug log:
Testing gphoto path = usb:001,006
PortInfo Universal Serial Bus, usb:001,006
Error GeneraError: LibGPhoto2.GPhotoException: Unspecified error
  at LibGPhoto2.Error.CheckError (ErrorCode error) [0x00000]
  at LibGPhoto2.Camera.Init (LibGPhoto2.Context context) [0x00000]
  at GPhotoCamera.InitializeCamera () [0x00000]
  at MainWindow.ImportCamera (System.String camera_device) [0x00000]

installed libraries:
aptitude search gphoto
i gphoto2 - The gphoto2 digital camera command-line client
i gphotofs - filesystem to mount digital cameras
i libgphoto2-2 - gphoto2 digital camera library
p libgphoto2-2-dev - gphoto2 digital camera library (development files)
v libgphoto2-dev -
i libgphoto2-port0 - gphoto2 digital camera port library
v libgphoto2port -
v libgphoto2port-dev

I'm getting a crash in f-spot when trying to download the first thumbnail. Looks very similar to what fish reported on 2007-12-16 but I'm running Ubuntu 8.04.1 fully updated. iBook G4 with Canon PowerShot G5. This used to work like a charm before I upgraded from 7.04 Feisty Fawn. Let me know if additional information would be beneficial.

An unhandled exception was thrown: Number overflow.

  at LibGPhoto2.CameraFile.GetDataAndSize () [0x00000]
  at GPhotoCamera.GetPreviewPixbuf (.GPhotoCameraFile camfile) [0x00000]
  at FSpot.CameraFileSelectionDialog.GetPreviews () [0x00000]
  at FSpot.CameraFileSelectionDialog.CreateInterface () [0x00000]
  at FSpot.CameraFileSelectionDialog.Run () [0x00000]
  at MainWindow.ImportCamera (System.String camera_device) [0x00000]
  at FSpot.Core+ImportCommand.Execute () [0x00000]
  at FSpot.Core.Import (System.String path) [0x00000]
  at FSpot.Driver.Main (System.String[] args) [0x00000]
.NET Version: 2.0.50727.42

Assembly Version Information:

libgphoto2-sharp (1.0.3058.27752)
FlickrExport (0.0.0.0)
PicasaWebExport (0.0.0.0)
FolderExport (0.0.0.0)
CDExport (0.0.0.0)
SmugMugExport (0.0.0.0)
GalleryExport (0.0.0.0)
pango-sharp (2.12.0.0)
FSpot.Query (0.0.0.0)
SemWeb (0.7.1.0)
glade-sharp (2.12.0.0)
gtkhtml-sharp (3.16.0.0)
System.Transactions (2.0.0.0)
System.Data (2.0.0.0)
Mono.Data.SqliteClient (2.0.0.0)
System.Configuration (2.0.0.0)
System.Xml (2.0.0.0)
NDesk.DBus.Proxies (0.0.0.0)
gconf-sharp (2.20.0.0)
FSpot.Utils (0.0.0.0)
gdk-sharp (2.12.0.0)
gnome-vfs-sharp (2.20.0.0)
Mono.Addins (0.3.0.0)
NDesk.DBus.GLib (1.0.0.0)
NDesk.DBus (1.0.0.0)
System (2.0.0.0)
Mono.Posix (2.0.0.0)
Cms (0.0.0.0)
FSpot.Core (0.0.0.0)
atk-sharp (2.12.0.0)
gtk-sharp (2.12.0.0)
Mono.Addins.Setup (0.3.0.0)
gnome-sharp (2.20.0.0)
glib-sharp (2.12.0.0)
f-spot (0.4.3.1)
mscorlib (2.0.0.0)

Platform Information: Linux 2.6.24-23-powerpc ppc unknown GNU/Linux

Distribution Information:

[/etc/debian_version]
lenny/sid

[/etc/lsb-release]
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04.1"

I tried f-spot under an updated Ubuntu 8.10 Intrepid Ibex install with same laptop (iBook G4) and same camera (Canon PowerShot G5) and it works just fine! I'm not using 8.10 for everyday because it has issues resuming from "Suspend"--pretty important for a travelling laptop. So,
f-spot v0.5.0.3 works
f-spot v0.4.3.1 fails

As 8.04 (Hardy Heron) is a Long-Term Support version and f-spot is the default application when I plug in my camera, I think this fix would be a useful one to backport. (gThumb works like a charm in both releases.)

By the way, how do I set gThumb to be the default application to handle a USB camera? Neither "Preferred Applications" nor "Multimedia Systems Selector" offer to configure this option, and neither gThumb nor f-spot have a preferences setting to become the default USB camera application.

Paul Crawford (psc-sat) wrote :

Same problem of PTP "unspecified error" on a new Nikon D300s camera with 8.10 and 9.04 Ubuntu. Some other cameras (Olympus compact) just work, but not this one or, it seems from the above, quite a few SLR models :( Why has this bug not been fixed for 3 years now!?

Paul Crawford (psc-sat) wrote :

Recently my D300s "just worked" with F-spot. Maybe due to some kernel patch, anyone else seen an improvement in the last month or two?

Paul Crawford (psc-sat) wrote :

No this is STILL BROKEN with 10.04!

Connect a D300s with single CF card and no auto-launch, manually launch F-spot and the camera is listed from the import options, but you get "Unspecified error" dialogue box if you try.
Connect a D300s with both CF and SD cards and it auto-launched F-spot, and you can read the files in, but in the background there is a dialogue box with "Error initialising camera: -60: Could not lock device".

Come on folks, this has been a problems reported for THREE AND A HALF years now and no one has fixed it in any proper sense! I mean, WTF, can't anyone do something about this?

Paul Crawford (psc-sat) wrote :

It looks like this is not a F-spot error, but a libgphoto2 one. I tried installing gthumb and it can't read the D300s camera either. It reports "An error occurred in the io-library ('Unspecified error'): No error description available".
What is also interesting is that the trick of having both CF and SD cards installed in the D300s is not a real fix - it allows you to load F-spot when it auto-detects the camera (though you get an error message), but if you don't launch F-spot initially, you can't access the camera by gthumb or by trying F-spot later.

Paul Crawford (psc-sat) wrote :

From this bug report:
https://sourceforge.net/tracker/?func=detail&atid=108874&aid=3004614&group_id=8874
It appears the problem I am seeing is a basic compatibility issue between applications using libgphoto2 for camera access (such as F-spot), and the gvfs-gphoto2-volume-monitor daemon. See also the comments here:
http://mail.gnome.org/archives/gvfs-list/2009-May/msg00001.html

Urban Anjar (urban-anjar) wrote :

I'm running 10.10 with a Nokon D300s and there are similar problems in Shotwell. I saw some stuff on the kernel-list (wich I didn't fully understand) and dmesg says:

[169600.833043] usb 1-6: new high speed USB device using ehci_hcd and address 15
[169601.120040] usb 5-2: new full speed USB device using uhci_hcd and address 48
[169601.240035] usb 5-2: device descriptor read/64, error -71
[169601.464030] usb 5-2: device descriptor read/64, error -71
[169601.680051] usb 5-2: new full speed USB device using uhci_hcd and address 49
[169601.805036] usb 5-2: device descriptor read/64, error -71
[169602.088037] usb 5-2: device descriptor read/64, error -71
[169602.304041] usb 5-2: new full speed USB device using uhci_hcd and address 50
[169602.716054] usb 5-2: device not accepting address 50, error -71
[169602.828061] usb 5-2: new full speed USB device using uhci_hcd and address 51
[169603.244033] usb 5-2: device not accepting address 51, error -71
[169603.244052] hub 5-0:1.0: unable to enumerate USB device on port 2
urban@koala:~$

lsusb says:

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 04e8:326c Samsung Electronics Co., Ltd ML-2010P Mono Laser Printer
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 046d:c03d Logitech, Inc. M-BT96a Pilot Optical Mouse
Bus 002 Device 002: ID 04d9:1603 Holtek Semiconductor, Inc.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 015: ID 04b0:0425 Nikon Corp. D300S
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I think we have to search för the solution on a lower level than the applications.

Changed in f-spot (Debian):
status: Confirmed → Fix Released
John Koval (jkoval-biostats) wrote :

same problems with Nikon DS Coolpix L19 and ubuntu 10.04
(but works perfectly under unbunu 8.01)

got rid of these error messages
[169601.240035] usb 5-2: device descriptor read/64, error -71
[169601.464030] usb 5-2: device descriptor read/64, error -71
[169601.680051] usb 5-2: new full speed USB device using uhci_hcd and address 49
[169601.805036] usb 5-2: device descriptor read/64, error -71
[169602.088037] usb 5-2: device descriptor read/64, error -71
[169602.304041] usb 5-2: new full speed USB device using uhci_hcd and address 50
by configuring Rhythmbox not to use MTP plugin
Ubuntu bug #557551

but still getting unspecified error from F-spot and gthunb
I can't use gphoto2 because I can't define the folder where the photos exist

John Koval (jkoval-biostats) wrote :

A correction to the proceeding:
If I click on the NIKON icon in the file browser or within gthumb I get the "unspecified" error,
but if I merely switch on the camera, eventually F-spot comes up with the pictures on the camera.

However, in order to make this work, first I had to configure Rhythmbox not to use the MTP plugin.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.