f-spot crashes on attempting to print

Bug #609713 reported by shane on 2010-07-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Critical
f-spot (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: f-spot

f-spot:
  Installed: 0.7.1-1
  Candidate: 0.7.1-1
  Version table:
 *** 0.7.1-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ maverick/main Packages
        100 /var/lib/dpkg/status

Description: Ubuntu maverick (development branch)
Release: 10.10

Steps to reproduce:
1. Select a photo, either in browse or edit views.
2. Click on the Menu > File > Print

F-spot instantly closes without warning or any kind of error message.

Output when running in a terminal:

(f-spot:2851): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.EntryPointNotFoundException: f_pixbuf_from_cairo_surface
  at (wrapper managed-to-native) FSpot.PrintOperation:f_pixbuf_from_cairo_surface (intptr)
  at FSpot.PrintOperation.CreatePixbuf (Cairo.Surface s) [0x00000] in <filename unknown>:0
  at FSpot.PrintOperation.OnCustomWidgetChanged (Gtk.Widget widget) [0x00000] in <filename unknown>:0
  at FSpot.PrintOperation.OnCreateCustomWidget () [0x00000] in <filename unknown>:0
  at Gtk.PrintOperation.createcustomwidget_cb (IntPtr operation) [0x00000] in <filename unknown>:0
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.PrintOperation.createcustomwidget_cb(IntPtr operation)
   at Gtk.PrintOperation.gtk_print_operation_run(IntPtr , Int32 , IntPtr , IntPtr ByRef )
   at Gtk.PrintOperation.Run(PrintOperationAction action, Gtk.Window parent)
   at FSpot.MainWindow.HandlePrintCommand(System.Object sender, System.EventArgs e)
   at System.Reflection.MonoMethod.InternalInvoke(System.Object , System.Object[] , System.Exception ByRef )
   at System.Reflection.MonoMethod.Invoke(System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
   at System.Reflection.MethodBase.Invoke(System.Object obj, System.Object[] parameters)
   at System.Delegate.DynamicInvokeImpl(System.Object[] args)
   at System.MulticastDelegate.DynamicInvokeImpl(System.Object[] args)
   at System.Delegate.DynamicInvoke(System.Object[] args)
   at GLib.Signal.ClosureInvokedCB(System.Object o, GLib.ClosureInvokedArgs args)
   at GLib.SignalClosure.Invoke(GLib.ClosureInvokedArgs args)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at FSpot.Driver.Startup()
   at Hyena.Gui.CleanRoomStartup.Startup(Hyena.Gui.StartupInvocationHandler startup)
   at FSpot.Driver.Main(System.String[] args)

Printing is working normally in every other application tried, this is strictly confined to f-spot.

Changed in f-spot:
status: Unknown → New
Changed in f-spot:
status: New → Fix Released
Changed in f-spot:
importance: Unknown → Critical
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in f-spot (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.