[edgy] f-spot crash on launching

Bug #58804 reported by Matthew McGowan on 2006-09-04
20
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: f-spot

Well f-spot is crashing on opening, with this output:

An unhandled exception was thrown: The handler for the event ButtonPressEvent should take '(System.Object,Gtk.ButtonPressEventArgs)', but the signature of the provided handler ('HandleZoomOut') is '(System.Object,System.EventArgs)'

at SignalConnector.ConnectFunc (intptr,intptr,intptr,intptr,intptr,int,intptr) <0x0033f>
at (wrapper native-to-managed) SignalConnector.ConnectFunc (intptr,intptr,intptr,intptr,intptr,int,intptr) <0x00040>
in (unmanaged) 0xb5fad915
at (wrapper managed-to-native) SignalConnector.glade_xml_signal_autoconnect_full (intptr,Glade.XML/SignalConnector/RawXMLConnectFunc,intptr) <0x00004>
at SignalConnector.Autoconnect () <0x00059>
at Glade.XML.Autoconnect (object) <0x00042>
at MainWindow..ctor (Db) <0x0006c>
at FSpot.Core.get_MainWindow () <0x0002a>
at FSpot.Core.Organize () <0x0000f>
at FSpot.Driver.Main (string[]) <0x00547>

.NET Version: 1.1.4322.2032

Assembly Version Information:

gconf-sharp (2.16.0.0)
pango-sharp (2.10.0.0)
SemWeb (0.5.0.2)
glade-sharp (2.10.0.0)
gtkhtml-sharp (2.16.0.0)
System.Data (1.0.5000.0)
Mono.Data.SqliteClient (1.0.5000.0)
Mono.Posix (1.0.5000.0)
gdk-sharp (2.10.0.0)
gnome-vfs-sharp (2.16.0.0)
dbus-sharp (0.60.0.0)
System (1.0.5000.0)
atk-sharp (2.10.0.0)
gtk-sharp (2.10.0.0)
glib-sharp (2.10.0.0)
gnome-sharp (2.16.0.0)
f-spot (0.0.0.0)
mscorlib (1.0.5000.0)

Platform Information: Linux 2.6.17-6-k7 i686 unknown GNU/Linux

Disribution Information:

[/etc/debian_version]
testing/unstable

[/etc/lsb-release]
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=6.10
DISTRIB_CODENAME=edgy
DISTRIB_DESCRIPTION="Ubuntu edgy (development branch)"

I hope this is the right place to report edgy bugs.

Andrew Mitchell (ajmitch) wrote :

This is apparantly due to Glade# being stricter in what it accepts - fixed in 0.2.0 will can hopefully go in soon

Changed in f-spot:
importance: Untriaged → High
status: Unconfirmed → Confirmed
Andrew Mitchell (ajmitch) wrote :

Uploaded 0.2.0-1ubuntu1 to edgy

Changed in f-spot:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers