NULL Reference exception in F-Spot

Bug #561874 reported by Tobin Davis on 2010-04-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: f-spot

On armel platforms (dove, imx51), f-spot crashes when editing a picture and the user attempts to select a different option from the edit drop down list on the left side-bar tools. See added text below.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: f-spot 0.6.1.5-2ubuntu5
ProcVersionSignature: User Name 2.6.31-607.12-imx51
Uname: Linux 2.6.31-607-imx51 armv7l
Architecture: armel
Date: Mon Apr 12 14:33:06 2010
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta armel+imx51 (20100406)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: f-spot

(f-spot:1265): GLib-GObject-CRITICAL **: g_value_get_float: assertion `G_VALUE_HOLDS_FLOAT (value)' failed

(f-spot:1265): GLib-GObject-CRITICAL **: g_value_get_float: assertion `G_VALUE_HOLDS_FLOAT (value)' failed
error checking orientation

(f-spot:1265): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
error checking orientation
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
at (wrapper native-to-managed) GtkSharp.MenuPositionFuncWrapper.NativeCallback (intptr,int&,int&,byte,intptr) <0x00060>
at Gtk.Menu.Popup (Gtk.Widget,Gtk.Widget,Gtk.MenuPositionFunc,uint,uint) <0x000d0>
at FSpot.Widgets.MenuButton.OnPressed () <0x000af>
at Gtk.Button.pressed_cb (intptr) <0x00083>

   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Button.pressed_cb(IntPtr button)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at FSpot.Driver.Main(System.String[] args)

Tobin Davis (gruemaster) wrote :
description: updated
Tobin Davis (gruemaster) wrote :

Unable to reproduce this on x86 hardware. Appears to be arm only.

tags: added: iso-testing
Alexander Sack (asac) wrote :

mono still isnt in good shape on armel. 2.6 branch is supposed to be the answer, which we will hopefully get in maverick.

Steve Langasek (vorlon) on 2011-02-15
tags: added: arm-porting-queue
Steve Langasek (vorlon) wrote :

I cannot reproduce this with f-spot in natty on a beagleboard xM. Remote display to my x86 desktop; imported a single picture, click on crop, select an area, go back to the edit menu, click on red-eye reduction, desaturate... nothing causes a crash here. Can we get a step-by-step reproducer, preferably with associated sample data?

Here's the console output for me; no crash:

** No session dbus found. Starting one **
[Info 09:45:16.496] Initializing Mono.Addins

(f-spot:7713): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
[Warn 09:45:34.711] Caught an exception - Hyena.Data.Sqlite.SqliteException: Sqlite error 1: no such table: tags (SQL: SELECT id FROM tags WHERE name = 'Hidden') (in `Hyena.Data.Sqlite')
  at Hyena.Data.Sqlite.Connection.CheckError (Int32 errorCode, System.String sql) [0x00000] in <filename unknown>:0
  at Hyena.Data.Sqlite.Statement.CheckError (Int32 code) [0x00000] in <filename unknown>:0
  at Hyena.Data.Sqlite.Statement..ctor (Hyena.Data.Sqlite.Connection connection, System.String sql) [0x00000] in <filename unknown>:0
  at Hyena.Data.Sqlite.Connection.Query[Object] (System.String sql) [0x00000] in <filename unknown>:0
  at Hyena.Data.Sqlite.HyenaSqliteCommand.Execute (Hyena.Data.Sqlite.HyenaSqliteConnection hconnection, Hyena.Data.Sqlite.Connection connection) [0x00000] in <filename unknown>:0

(f-spot:7713): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.

(f-spot:7713): GLib-GObject-CRITICAL **: g_value_get_float: assertion `G_VALUE_HOLDS_FLOAT (value)' failed

(f-spot:7713): GLib-GObject-CRITICAL **: g_value_get_float: assertion `G_VALUE_HOLDS_FLOAT (value)' failed

(f-spot:7713): GLib-GObject-CRITICAL **: g_value_get_float: assertion `G_VALUE_HOLDS_FLOAT (value)' failed

(f-spot:7713): GLib-GObject-CRITICAL **: g_value_get_float: assertion `G_VALUE_HOLDS_FLOAT (value)' failed

Changed in f-spot (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

For the avoidance of doubt, my tests were with f-spot 0.8.2-1 and mono 2.6.7-5.

Tobin Davis (gruemaster) wrote :

I was able to reproduce this in Lucid with f-spot 0.6.1.5-2ubuntu7 (lucid updates) on a babbage 3.0 board. I was not able to reproduce this in Maverick with f-spot version 0.8.0-1 or in Natty with f-spot 0.8.2-1. Not sure what update may have fixed this issue. Since it was not targeted for a specific release, I am marking it as Fix-Released as it works in Maverick+.

Changed in f-spot (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers