opens for a few seconds then closes.

Bug #520186 reported by Lisa on 2010-02-11
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

Ubuntu 9.10

~$ f-spot

(/usr/lib/f-spot/f-spot.exe:2003): GLib-WARNING **: g_set_prgname() called multiple times
[Info 10:07:42.892] Initializing DBus
[Info 10:07:43.229] Initializing Mono.Addins
[Info 10:07:43.720] Starting new FSpot server (f-spot 0.6.1.5)

** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Info 10:07:45.903] Starting BeagleService
[Info 10:07:45.963] Hack for gnome-settings-daemon engaged

(/usr/lib/f-spot/f-spot.exe:2003): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program '/usr/lib/f-spot/f-spot.exe' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 2938 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Pedro Villavicencio (pedro) wrote :

Thanks for the report, could you run f-spot in gdb as:

gdb f-spot
break gdk_x_error
run --sync
(reproduce the crash and:)
thread apply all bt

then attach that resulting backtrace to the report, thanks.

Changed in f-spot (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
JamesH (jnahughes) wrote :

I also am getting an error similar to this. Originally the problem was fixed by not using the new Wave theme'. However, after a recent system update via the update manager the fault returned - all the themes tried have produced the same result - a crash after a few seconds of runnning. I have also posted a report on bug 411941.

Using KK 9.10, 2.6.31.-19
Nvidia drivers
Gnome 2.28.1

I have tried with desktop effects on and off.

Machine is an Acer Revo with Atom 230 processor, 3GB RAM.

Error as follows :

(/usr/lib/f-spot/f-spot.exe:2013): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
The program '/usr/lib/f-spot/f-spot.exe' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 4021 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I have not been able to run in gdb as yet - if i get the chance I wil post the results.

Sebastien Bacher (seb128) wrote :

could you try changing the theme you are using? do you use new wave there?

JamesH (jnahughes) wrote :

I perhaps wasn't clear enough in my posting. I first got this problem when using New Wave, so after finding various bug reports related to themes I changed to New Look (I think) and the bug went away.

However, I then did a update via the updater and the problem returned. I am not sure what was updated but it was, I think, done on the 15th Feb. I cannot confirm specifically that the update caused the issue, but its the only thing I can think off that changed at the time the fault re-occurred.

I have tried various themes and the problem still occurs.

Download full text (3.4 KiB)

Sorry, I'm unable to run f-spot in gdb. I also tried uninstalling and reinstalling f-spot using the Synaptic Package Manager, but no change.

lisa@zareason-terra:/$ gdb f-spot
GNU gdb (GDB) 7.0-ubuntu
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
"/usr/bin/f-spot": not in executable format: File format not recognized
(gdb) quit

-----Original Message-----
>From: Pedro Villavicencio <email address hidden>
>Sent: Feb 12, 2010 8:50 AM
>To: <email address hidden>
>Subject: [Bug 520186] Re: opens for a few seconds then closes.
>
>Thanks for the report, could you run f-spot in gdb as:
>
>gdb f-spot
>break gdk_x_error
>run --sync
>(reproduce the crash and:)
>thread apply all bt
>
>then attach that resulting backtrace to the report, thanks.
>
>** Changed in: f-spot (Ubuntu)
> Importance: Undecided => Medium
>
>** Changed in: f-spot (Ubuntu)
> Status: New => Incomplete
>
>** Changed in: f-spot (Ubuntu)
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
>
>--
>opens for a few seconds then closes.
>https://bugs.launchpad.net/bugs/520186
>You received this bug notification because you are a direct subscriber
>of the bug.
>
>Status in “f-spot” package in Ubuntu: Incomplete
>
>Bug description:
>Binary package hint: f-spot
>
>Ubuntu 9.10
>
>~$ f-spot
>
>(/usr/lib/f-spot/f-spot.exe:2003): GLib-WARNING **: g_set_prgname() called multiple times
>[Info 10:07:42.892] Initializing DBus
>[Info 10:07:43.229] Initializing Mono.Addins
>[Info 10:07:43.720] Starting new FSpot server (f-spot 0.6.1.5)
>
>** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
>
>** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
>
>** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
>
>** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
>
>** (/usr/lib/f-spot/f-spot.exe:2003): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
>[Info 10:07:45.903] Starting BeagleService
>[Info 10:07:45.963] Hack for gnome-settings-daemon engaged
>
>(/usr/lib/f-spot/f-spot.exe:2003): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
>The program '/usr/lib/f-spot/f-spot.exe' received an X Window System error.
>This probably reflects a bug in the program.
>The error was 'BadAlloc (insufficient resources for operation)'.
> (Details: serial 2938 error_code 11 request_code 53 minor_code 0)
> (Note to programmers: normally, X errors are reported asynchronously;
> that is, you will receive the error a while after causing it.
> To debu...

Read more...

J Majere (jmajere) wrote :

i ran the command differently in order to get it to work right, here is the paste bin of the results
http://paste.ubuntu.com/384933/

J Majere (jmajere) wrote :

this was mentioned to me in a conversation about this bug.
(After testing, this seems to be a problem with gtk+-2.0 pixmap engine. Any theme using the pixmap engine crashes with fspot in the same manner.)

a workaround for now was changing themes, that let me get f-stop working.
check out comment 10 from the forums

http://ubuntuforums.org/showthread.php?p=8841324

JamesH (jnahughes) wrote :

I have run gdb and get exactly the same result as posted in comment#6.

Following the link in #7, I ran gconf-editor and deleted the theme key in apps/f-spot/ui. This has fixed the problem - it was set to new wave.

Thanks J Majere!!

Lisa (basalt) wrote :

I changed the theme in System - Preferences - Appearance from New Wave (default) to Clearlooks and f-spot runs fine now.

Sebastien Bacher (seb128) wrote :

the new wave issue is bug #411941 and fixed in lucid

Changed in f-spot (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers