f-spot printing "missing image" icon instead of actual image

Bug #496134 reported by ricardisimo on 2009-12-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Medium
f-spot (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

Although bug #450456 looks like it might be similar, I couldn't tell from the description.

If I try to print (or view print preview) instead of the image I have selected, I get the "image missing" icon instead (it looks like it's probably the one from the Oxygen theme set, under "status"), the red circle with the diagonal red bar, a lá "Ghostbusters". I tried altering various printer settings to see if for some bizarre reason it was CUPS or HPLIP instead of F-Spot, but no.

I'm on Ubuntu Koala, fully updated to the best of my knowledge; F-Spot version 0.6.1.5. My printer is an HP Photosmart C5180 All-in-One, which used to print everything just fine. Not a great printer by any stretch of the imagination, but it certainly worked OK.

Thank you for your attention to this.

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Could you take a screenshot showing the issue?

 This will help us to find and resolve the problem.

Changed in f-spot (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
ricardisimo (ricardisimo) wrote :

It's easily reproducible by me, at least...

- Launch F-Spot
- select photo I wish to print (in this case, dscn0128.jpg in folder /home/ricardo/Photos/2009/12/11)
- select "Photo" >> "Print" >> and make sure settings are correct (paper source, printout mode, resolution, etc.)
- and then either print or print preview.

Please see attached screenshot from print preview. Printed image is the same.

I should also mention that today f-spot is crashing repeatedly. Apport is not detecting it for some reason. Yesterday there was no problem with crashing.

Sebastien Bacher (seb128) wrote :

Do you get any error on the command line if you run f-spot there?

ricardisimo (ricardisimo) wrote :
Download full text (8.2 KiB)

It looks like I get several, some maybe involving my desktop theme, or something of the sort. The following is what happened when I first printed an photo, and then while waiting for the printing to finish, tried "Print Preview". Shortly after that F-Spot crashed.

:~$ f-spot
[Info 19:40:40.171] Initializing DBus
[Info 19:40:40.572] Initializing Mono.Addins
[Info 19:40:41.276] Starting new FSpot server (f-spot 0.6.1.5)

** (f-spot:8549): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:8549): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:8549): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:8549): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (f-spot:8549): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[Info 19:40:47.555] Starting BeagleService
[Info 19:40:47.667] Hack for gnome-settings-daemon engaged

(f-spot:8549): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
[Warn 19:41:28.659] Unable to load image file:///home/ricardo/Photos/2009/12/11/dscn0128 (Modified).jpg
 - Object reference not set to an instance of an object (in `Cms')
  at Cms.Transform..ctor (Cms.Profile[] profiles, Format input_format, Format output_format, Intent intent, UInt32 flags) [0x00000]
  at FSpot.ColorManagement.ApplyProfile (Gdk.Pixbuf pixbuf, Cms.Profile image_profile, Cms.Profile destination_profile) [0x00000]
  at FSpot.PrintOperation.OnDrawPage (Gtk.PrintContext context, Int32 page_nr) [0x00000]
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Stacktrace:

  at (wrapper managed-to-native) Cms.NativeMethods.CmsDeleteTransform (System.Runtime.InteropServices.HandleRef) <0x00004>
  at (wrapper managed-to-native) Cms.NativeMethods.CmsDeleteTransform (System.Runtime.InteropServices.HandleRef) <0xffffffff>
  at Cms.Transform.Cleanup () <0x00030>
  at Cms.Transform.Finalize () <0x00016>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

 f-spot [0x80c8824]
 f-spot [0x80f4693]
 [0x630410]
 /usr/lib/liblcms.so.1(cmsDeleteTransform+0x14) [0x24ff744]
 [0x72d12c1]
 [0x72d1277]
 [0x5fbc48]
 f-spot [0x812ba39]
 f-spot [0x81d3751]
 f-spot [0x812bc24]
 f-spot [0x814f96c]
 f-spot [0x81bf9f2]
 f-spot [0x81de055]
 /lib/tls/i686/cmov/libpthread.so.0 [0xe8a80e]
 /lib/tls/i686/cmov/libc.so.6(clone+0x5e) [0x4a87ee]

Debug info from gdb:

[Warn 19:41:51.741] Unable to load image file:///home/ricardo/Photos/2009/12/11/dscn0128 (Modified).jpg
 - Object reference not set to an instance of an object (in `Cms')
  at Cms.Transform..ctor (Cms.Profile[] profiles, Format input_format, Format output_format, Intent intent, UInt32 flags) [0x00000]
  at FSpot.ColorManagement.ApplyProfile (Gdk.Pixbuf pixbuf, Cms.Profile image_profile, Cms.Profile destination_profile) [0x00000]
  at FSpot.PrintOperation.OnDrawPage (Gtk.PrintContext context, Int32 page_nr) [0x00000]
[Thread debugging usi...

Read more...

Sebastien Bacher (seb128) wrote :

the issue seems to be "[Warn 19:41:51.741] Unable to load image file:///home/ricardo/Photos/2009/12/11/dscn0128 (Modified).jpg"

Do you have the image listed there on disk?

ricardisimo (ricardisimo) wrote :

Yes, and I just checked the permissions of each folder leading to it from home. I own it and all of the folders, and others have access to it. Furthermore, other apps (gthumb, GQView, gimp, etc.) can print it OK, although they don't seem to crop to photo paper properly, adding appallingly large margins as one would find on a document, rather than a photo... that's a separate issue, obviously.

The long and the short of it is that I enjoy F-Spot, and would like for it to work properly. Thanks for your hard work.

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Not confirming the bug there it seems config specific in some way

ricardisimo (ricardisimo) wrote :

It is resolved: https://bugzilla.gnome.org/process_bug.cgi

For some reason, sRGB was enabled in both display and print, although I don't even fully understand what either setting means. Thank you very much for your help.

Sebastien Bacher (seb128) wrote :

could you give the upstream bug number for reference? the url you copied doesn't have it...

ricardisimo (ricardisimo) wrote :
Changed in f-spot (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.6.1.5-2ubuntu1

---------------
f-spot (0.6.1.5-2ubuntu1) lucid; urgency=low

  * debian/patches/git_copy_attribute_normal.patch:
    - git change to set the copy attributes to normal, fix a write permission
      issue (lp: #483268)
  * debian/patches/git_no_urlencode.patch:
    - git change to not urlencode the mail subjects (lp: #454972)
  * debian/patches/git_correct_description.patch:
    - git change to fix the profiles description displayed (lp: #502744)
  * debian/patches/git_color_profile_printing_breakage.patch:
    - git change to fix printing when a color profile is selected (lp: #496134)
  * debian/patches/git_key_conflict.patch:
    - git change to fix a shortcut conflict (lp: #516801)
  * debian/patches/git_set_default_resize_value.patch:
    - git change to set a correct default resize value (lp: #513864)
  * debian/patches/ubuntu_edit_tag.patch:
    - change the edit tag label to be consistent with other entries
      (lp: #513452)
  * debian/patches/ubuntu_transition_timing.patch:
    - change by Alex Launi to make the transition effect between modes take 1s
      (lp: #513045)
  * debian/patches/ubuntu_slider_animation_tweaking.patch:
    - change by Alex Launi to reduce the slider animation timing (lp: #513004)
  * debian/patches/ubuntu_check_duplicate.patch:
    - change by Matt Perry to use a better label for the duplicates checking
      (lp: #511767)
 -- Sebastien Bacher <email address hidden> Mon, 01 Mar 2010 16:06:41 +0100

Changed in f-spot (Ubuntu):
status: Fix Committed → Fix Released
Changed in f-spot:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.