Fspot import lacks ability to delete pictures from camera, easily choose save to destination and does not offer to exit when done

Bug #489620 reported by Martin G Miller on 2009-11-28
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Wishlist
One Hundred Papercuts
Undecided
Unassigned
f-spot (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

On importing pictures from a camera via USB, Fspot does not have the ability to delete the pictures from the camera when the import is done. It also does not allow you to select where the pictures are being saved to. It also launches into the full Fspot program when finished, which is usually not needed.

This forces me to manually delete the pictures from the camera one at a time, which is time consuming.

Gthumb, by contrast offers to delete the pictures after import and makes it easy to choose where the pictures are being saved to. For a new user, the gthumb interface is not confusing to simply view the pictures that are just imported, whereas the Fspot interface is very confusing and intimidating.

I have set up many Ubuntu systems for new users coming from Windows and they are looking for a "Windows picture import wizard" experience where at the end, the wizard offers to exit, leaving the pictures where ever you just saved them to.

Once I install Gthumb and set the preferences, they are very happy. They can explore Fspot later. For now, they just want a simple way to view the pictures they just imported.

In my office I use digital pictures a lot, but Fspot is very unstable and time consuming to use, often, locking up x and requiring an alt/sysreq/k to recover because even ctrl/alt/backspace doesn't work. I am running Ubuntu 8.04.3 in my office and all 6 of my workstations behave the same way with Fspot. I use gthumb to quickly import and delete from camera and I'm done.

This carries over to my home use where my 4 Ubuntu machines are running 9.10, but I still don't use Fspot to import because of the lack of the delete and save to feature.

Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

Vish (vish) wrote :

Once submitted upstream , do report back with the upstream bug number here.

Martin G Miller (mgmiller) wrote :

Bug 603254 has been added upstream.

Vish (vish) on 2009-11-28
Changed in f-spot:
importance: Undecided → Unknown
status: New → Unknown
Sebastien Bacher (seb128) wrote :

the issue doesn't seem a trivial change, it's open for years upstream not really an hundredpapercut task, rather a new feature request

Changed in f-spot (Ubuntu):
importance: Undecided → Wishlist
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
Vish (vish) on 2009-11-30
Changed in hundredpapercuts:
status: New → Invalid
Martin G Miller (mgmiller) wrote :

Gnome bugzilla Bug 321596 has been open for over 4 years now. It is a show stopper for using f-spot. With the intention of increased reliance on f-spot now that gimp is being removed, this becomes a serious issue. I have been using gthumb to import and picasa to manage pictures for years because f-spot just had too many glitches. Is there any way upstream can be nudged along on this issue?

Since the default applications are being tweaked, maybe it's time to consider changing the default photo management application. Could digikam be modified to look like a gnome application and be used instead? I know it will work, but kde apps look "wrong" in a gnome environment.

Development in f-spot is stagnant, digikam seems to offer more features through plugins frequently. Rather then reinventing the wheel or trying to get the uncooperative f-spot maintainers to do something, perhaps having a gnome port of digikam would be the best solution.

.cobnet (mattias-campe) wrote :

F-spot import still seems to lack the ability to delete pictures from camera on Ubuntu 10.04, with F-Spot 0.6.1.5. Like others already said: this is an important feature for users who don't know how to format their camera. I still install gthumb for those users, but that program lacks some other possibilities.

Changed in f-spot:
status: Unknown → Confirmed
Changed in f-spot:
status: Confirmed → Fix Released
Changed in f-spot:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.