Error when importing a file without write permission

Bug #483268 reported by Yann Leprince on 2009-11-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
High
f-spot (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

Steps to reproduce:
1) create an empty directory, put in the same image file twice with two different names
2) make the two files read-only
3) try to import the directory in f-spot

What happens:
Import error

Expected result:
Image imported

ProblemType: Bug
Architecture: amd64
Date: Sun Nov 15 22:00:21 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: f-spot 0.6.1.5-0ubuntu1
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: f-spot
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:17220): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:17220): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:17336): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:17327): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Related branches

Yann Leprince (sciyann) wrote :
Steve McGrath (smcgrath23) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

This may be already reported in F-Spot at https://bugzilla.gnome.org/show_bug.cgi?id=435242, but that bug was closed due to lack of information.

Pedro Villavicencio (pedro) wrote :

please provide the asked info to the upstream report, thanks.

Changed in f-spot (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Yann Leprince (sciyann) wrote :

I have already provided the information to upstream, but they have not responded to the reopening request yet.
Here is a (trivial) patch that solves the issue. It sets the permissions of all imported files to 'Normal', which may not be the best solution, but as C# is a windows-centric language I cannot think of a better solution (by the way, I am not a C# programmer).
I am also submitting this patch upstream.

Changed in f-spot (Ubuntu):
status: Incomplete → Triaged
Yann Leprince (sciyann) wrote :

The patch has been applied upstream (see log below). I am not sure what the status of the ubuntu bug report should be set to, can someone more experimented please change it as needed. Thanks!

commit 8679939c0b4a030e76290e9c52506aba1a56f07e
Author: Yann Leprince <email address hidden>
Date: Sun Dec 20 13:42:44 2009 +0100

    Set the attributes of copied files to Normal

    fixes bgo#435242

Changed in f-spot (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.6.1.5-2ubuntu1

---------------
f-spot (0.6.1.5-2ubuntu1) lucid; urgency=low

  * debian/patches/git_copy_attribute_normal.patch:
    - git change to set the copy attributes to normal, fix a write permission
      issue (lp: #483268)
  * debian/patches/git_no_urlencode.patch:
    - git change to not urlencode the mail subjects (lp: #454972)
  * debian/patches/git_correct_description.patch:
    - git change to fix the profiles description displayed (lp: #502744)
  * debian/patches/git_color_profile_printing_breakage.patch:
    - git change to fix printing when a color profile is selected (lp: #496134)
  * debian/patches/git_key_conflict.patch:
    - git change to fix a shortcut conflict (lp: #516801)
  * debian/patches/git_set_default_resize_value.patch:
    - git change to set a correct default resize value (lp: #513864)
  * debian/patches/ubuntu_edit_tag.patch:
    - change the edit tag label to be consistent with other entries
      (lp: #513452)
  * debian/patches/ubuntu_transition_timing.patch:
    - change by Alex Launi to make the transition effect between modes take 1s
      (lp: #513045)
  * debian/patches/ubuntu_slider_animation_tweaking.patch:
    - change by Alex Launi to reduce the slider animation timing (lp: #513004)
  * debian/patches/ubuntu_check_duplicate.patch:
    - change by Matt Perry to use a better label for the duplicates checking
      (lp: #511767)
 -- Sebastien Bacher <email address hidden> Mon, 01 Mar 2010 16:06:41 +0100

Changed in f-spot (Ubuntu):
status: Fix Committed → Fix Released
Changed in f-spot:
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.