[amd64] F-Spot does not correctly generate thumbnails when generating a web gallery

Bug #46205 reported by Danilo Raineri on 2006-05-23
8
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
Medium
Kees Cook

Bug Description

When exporting the selected photos to a local web gallery (Export to Folder, Create standalone web gallery), F-Spot creates the correct folder structure and html files, but it fails to generate thumbnails. Instead of thumbnails, in the directory "thumbs" I get empty files with the correct name.

If launching the application from a shell, I get the following output:

(f-spot:10805): GdkPixbuf-WARNING **: Bad option name 'P\xc1l' passed to JPEG saver

(f-spot:10805): GdkPixbuf-CRITICAL **: gdk_pixbuf_savev: assertion `error == NULL || *error != NULL' failed

for each failed thumbnail.

The photos are in their original folder, I added them to the collection without copying to f-spot's folder. The path and the file names do not contain spaces nor other "problematic" characters :-)

I am running on the latest Dapper, AMD64.

Andrew Mitchell (ajmitch) wrote :

If you are running edgy now, would you be able to test out 0.2.0-1ubuntu1? It has a number of fixes for exporting images.

Changed in f-spot:
status: Unconfirmed → Needs Info

Andrew Mitchell wrote:
> If you are running edgy now, would you be able to test out
> 0.2.0-1ubuntu1? It has a number of fixes for exporting images.
Unfortunately, I am sticking to dapper at the moment... If I switch to
edgy, I will test the new package and report as soon as possible :-)

--
Danilo Raineri, <email address hidden>

Tested 0.2.0-1ubuntu1 on edgy: unfortunately, the problem is still there :-)

Same shell output, same failure to generate thumbnails (although there are empty files with the correct name in the correct directory, as I wrote before).

Andrew Mitchell (ajmitch) wrote :

Thanks, would you be able to attach or send me a sample image that fail to export?

Danilo Raineri (danirain) wrote :

Unfortunately, I switched to the i386 architecture and am no longer able to provide further information on this bug (as it doesn't affect the i386 architecture, from my simple tests).

However, before switching - for other reasons not related to this bug, obviously - I tested the gallery export with a lot of photos from my personal collection, and none of them was exported correctly to a html gallery (due to the failing thumbnail generation). I am attaching one for reference.

Thank you :-)

Andrew Mitchell (ajmitch) wrote :

Thanks, I've got an AMD64 box to test on, I'll check it out.

Kees Cook (kees) wrote :

I see this on feisty amd64 too. :(

Changed in f-spot:
status: Needs Info → Confirmed
Kees Cook (kees) wrote :

Since ajmitch asked on irc, here's what I see for every image that f-spot attempts to export:

open uri = file:///photos/2007-01-15--12.56.11/IMG_0766.JPG
open uri = file:///photos/2007-01-15--12.56.11/IMG_0766.JPG
value = f-spot version 0.3.2 len = 20
value = 2007:02:07 14:36:32 len = 19
Saved 7818 bytes
open uri = file:///photos/2007-01-15--12.56.11/IMG_0766.JPG

(f-spot:24378): GdkPixbuf-WARNING **: Bad option name '\x90\u0013\x9b' passed to JPEG saver

(f-spot:24378): GdkPixbuf-CRITICAL **: gdk_pixbuf_savev: assertion `error == NULL || *error != NULL' failed
open uri = file:///photos/2007-01-15--12.56.11/IMG_0766.JPG

(f-spot:24378): GdkPixbuf-WARNING **: Bad option name '@\xf2\xa3' passed to JPEG saver

(f-spot:24378): GdkPixbuf-CRITICAL **: gdk_pixbuf_savev: assertion `error == NULL || *error != NULL' failed

Only the "Bad option name" garbage changes. Of note, the string @\xf2\xa3 does exist in this file. Seems like bad math somewhere...

Kees Cook (kees) wrote :
Changed in f-spot:
assignee: nobody → keescook
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers