sidebars pictures are not clickable

Bug #448162 reported by Matthew Woerly on 2009-10-10
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Medium
f-spot (Ubuntu)
Low
Ubuntu Desktop Bugs
Karmic
Low
Iain Lane

Bug Description

TESTCASE:

* run f-spot --view *.jpg in a directory with some jpg images
* try click on the leftpane
* it doesn't work before the fix and work after the change

Binary package hint: f-spot

In the sidebar for F-Spot View as well as the picture list in the Facebook uploader (and maybe other places, too), there is a vertical list of one column of pictures. You can Alt+Tab to it, and use the arrow keys to move through it, but you can't click on the list.

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 10 12:41:48 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: wl
Package: f-spot 0.6.1.3-2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.43-generic
SourcePackage: f-spot
Uname: Linux 2.6.31-13-generic x86_64

Matthew Woerly (nattgew) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Changed in f-spot (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Matthew Woerly (nattgew) wrote :

Scenario 1:
Open multiple pictures with F-Spot View.
Enable the sidebar on the left that shows the pictures you have open.
Try to click on the sidebar.
Expected behavior:
Allow clicking and changing pictures in the sidebar.
Actual behavior:
Will not respond to clicks. Tabbing to the list and using arrow keys works, though.

Scenario 2:
Select one or more photos.
Export them with the Facebook plugin (enable if needed).
A list of the selected photos appears at the bottom left of the export window.
Expected:
Allow clicking the pictures to select them and enter comments, tags, etc. (which it looks like it should do).
Actual:
Clicking does nothing. I haven't tried tabbing to the list, it may work like the other scenario.

I'm pretty sure this used to work.

Sebastien Bacher (seb128) wrote :

Confirmed, it's due to the client side gtk changes, bug sent on https://bugzilla.gnome.org/show_bug.cgi?id=600032 too now

summary: - Picture sidebars aren't clickable
+ sidebars pictures are not clickable
Changed in f-spot (Ubuntu):
status: Incomplete → Triaged
Steve McGrath (smcgrath23) wrote :

This bug is fixed in F-Spot 0.6.1.5, released today. Here's the message I got on the F-Spot list:

f-spot 0.6.1.5 - Nov 4 2009 - What Next ?
-----------------------------------------
- bugfix release for 0.6.x branch
 - make IconView responsive to mouseclicks on gdk 2.18 (bgo #600032)
 - do not ignore .rw2 files (bgo #593474)
 - avoid an Array.OORE on empty dbs (bgo #566977) (Mike Gemuende)

Changed in f-spot (Ubuntu):
status: Triaged → Fix Committed
Iain Lane (laney) wrote :

Hi there,

Here's a diff for the SRU. Upstream has kindly rolled a new release which fixes this and two other bugs we should have in Karmic.

Changes:
 f-spot (0.6.1.5-0ubuntu1) karmic-proposed; urgency=low
 .
   * Fakesync to Karmic from Debian unstable
   * New upstream release 0.6.1.5
    - make IconView responsive to mouseclicks on gdk 2.18 (LP: #448162)
    - do not ignore .rw2 files
    - avoid an Array.OORE on empty dbs (Mike Gemuende)

The chance of regressions is low, we can always revert specific changes if they cause a problem.

Iain Lane (laney) wrote :
Iain Lane (laney) wrote :
Iain Lane (laney) wrote :

(we will get this to Lucid via a sync from unstable after the usual delays)

Changed in f-spot (Ubuntu Karmic):
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Iain Lane (laney)
importance: Low → Undecided
description: updated
Changed in f-spot (Ubuntu Karmic):
importance: Undecided → Low
description: updated

Accepted f-spot into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Edward (edward-coffey) wrote :

Just got the new package from karmic-proposed - looks good to me, sidebar functionality has been restored.

Martin Pitt (pitti) on 2009-11-06
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.6.1.5-0ubuntu1

---------------
f-spot (0.6.1.5-0ubuntu1) karmic-proposed; urgency=low

  * Fakesync to Karmic from Debian unstable
  * New upstream release 0.6.1.5
   - make IconView responsive to mouseclicks on gdk 2.18 (LP: #448162)
   - do not ignore .rw2 files
   - avoid an Array.OORE on empty dbs (Mike Gemuende)
 -- Iain Lane <email address hidden> Thu, 05 Nov 2009 17:17:47 +0000

Changed in f-spot (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied karmic-proposed to lucid.

Changed in f-spot (Ubuntu):
status: Fix Committed → Fix Released
Changed in f-spot (Ubuntu Karmic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.6.1.5-0ubuntu1

---------------
f-spot (0.6.1.5-0ubuntu1) karmic-proposed; urgency=low

  * Fakesync to Karmic from Debian unstable
  * New upstream release 0.6.1.5
   - make IconView responsive to mouseclicks on gdk 2.18 (LP: #448162)
   - do not ignore .rw2 files
   - avoid an Array.OORE on empty dbs (Mike Gemuende)
 -- Iain Lane <email address hidden> Thu, 05 Nov 2009 17:17:47 +0000

Changed in f-spot (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in f-spot:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.