The program 'f-spot' received an X Window System error

Bug #374667 reported by Jesse N. Richardson on 2009-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

When I goto anything with F-Spot, it crashes. So I ran it in the terminal and I got this:
jesse@jesse-desktop:~$ f-spot

(f-spot:28722): Gtk-WARNING **: Unable to locate theme engine in module_path: "ubuntulooks",
[Info 19:34:41.618] Initializing DBus
[Info 19:34:41.898] Initializing Mono.Addins
[Info 19:34:42.371] Starting new FSpot server
[Info 19:34:44.680] Starting BeagleService
[Info 19:34:44.681] Hack for gnome-settings-daemon engaged
The program 'f-spot' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 3980 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in f-spot (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete

I can confirm this bug with f-spot version 0.5.0.3 on Jaunty.

Sebastien Bacher (seb128) wrote :

Do you still get the issue? What theme do you use?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers