f-spot should have better gnome-volume-manager integration.

Bug #36347 reported by Jorge Castro on 2006-03-24
22
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Low
f-spot (Ubuntu)
Medium
Andrew Mitchell

Bug Description

It would be nice if f-spot offered total "drop in" replacement for gthumb.

As it stands, if I install f-spot, run it, and plug in my camera. g-v-m launches the import dialog, which is tied into gthumb. I have to hit cancel, then go to f-spot's menu and then do a manual import. If I accept the dialog, it imports the photos into gthumb, which is what I don't want.

In g-v-m, under the camera tab, there is an option of what to run when a camera is plugged in, the option is currently:

gnome-volume-manager-gthumb %h

I think that when f-spot is installed, that "f-spot-import" should be added to the dropdown in g-v-m, so that I can totally skip the gthumb cancel madness and have f-spot handle all my photo needs.

Jorge Castro (jorge) wrote :

Forgot to add, I was unsure if this should be filed under f-spot or gnome-volume-manager, so I added it here.

Andrew Mitchell (ajmitch) wrote :

I think this can be handled by some gconf voodoo, but I'm not sure if it'll need to be a per-user setting or if I just drop it in via postinst. WIll check this out with Seb

Andrew Mitchell (ajmitch) wrote :

Looks like gconf just stores a single string for that option, in /desktop/gnome/volume_manager/autophoto_command

Changed in f-spot:
status: Unconfirmed → Confirmed
Changed in f-spot:
assignee: nobody → ajmitch
Changed in f-spot:
status: Unknown → Unconfirmed
Changed in f-spot:
importance: Wishlist → Medium
Jeff Fortin Tam (kiddo) wrote :

Taken from http://bugzilla.gnome.org/show_bug.cgi?id=324399

Now, I think this bug was simply forgotten, because f-spot is now the default photo management application for Edgy Eft. The problem is that this setting is still set to gthumb. Could this be worked around for edgy final? Or at least provide instructions on how to change "gnome-volume-manager-gthumb %h" to something using f-spot, or add it as a second option in the dropdown widget in the gnome volume manager user interface.

Mary Gardiner (puzzlement) wrote :

http://ubuntuforums.org/showthread.php?t=257576 is useful for those who would like to set this up themselves.

Tim Retout (diocles) wrote :

I have filed a bug upstream on g-v-m about the possibility of a .desktop standard to support this:
http://bugzilla.gnome.org/show_bug.cgi?id=506169

Jorge Castro (jorge) wrote :

f-spot in hardy has had this fixed for some time, it now defaults to f-spot-import

Changed in f-spot:
status: Confirmed → Fix Released
Changed in f-spot:
status: New → Fix Released
Changed in f-spot:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.