Impossible to launch apps/login on disk full, no feedback

Bug #34075 reported by Fabián Rodríguez on 2006-03-08
14
Affects Status Importance Assigned to Milestone
Baltix
Medium
Mantas Kriaučiūnas
f-spot (Ubuntu)
Medium
Unassigned
gnome-volume-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Using Dapper, updated from lates March 5 nightly on i386

(this is not f-spot specific but rather distribution-wide, as opposed to another specific bug for f-spot I posted before - pls. re-assign to correct package).

After filling up a hard disk by copying large amounts of data to a standard home directory, the desktop reponds slowly and no applications can be started. Logout is OK, but user can't login back, GDM simply restarts.

This was reproduced several times with f-spot while importing a large library of images. The default option for importing in f-spot copies the pics files to local disk. This has been reported as a bug in f-spot too which should check for available fisk space before importing data (see linked bug).

Work around:
1) Use CTRL-ALT-F1 to gain access to console or boot in "recovery mode", login
2) "rm -rf ~/Photos" to erase all pictures imported and make room on the HD
3) reboot / relogin with GUI

description: updated
Andrew Mitchell (ajmitch) wrote :

Not an f-spot bug, please refile/reassign against an appropriate package

Changed in f-spot:
status: Unconfirmed → Rejected
Mantas Kriaučiūnas (mantas) wrote :

User should get a warning message, when volume, where user's home is located is on low disk space.
AFAIK *gnome-volume-manager* can monitor free space in the volume, so, maybe it can display a warning message, when volume, where user's home is located is on low disk space ?

Martin Pitt (pitti) wrote :

g-v-m warns the user about low disk space since Dapper.

Changed in gnome-volume-manager:
status: Unconfirmed → Fix Released
188236 (christian-bernstein) wrote :

I had the same problem after installing several files. Problem: For new or unexperienced user it is impossible to solve the problem, because they have no chance to access their computer (Who knows that CTRL-ALT-F1 reachs the terminal?).
There should be a warning, if disk space is running low, BEFORE one installs software on the system. If there exists already such a tool (??) it should be standard extension in the packet managers...

Especially for end users this is a really deadly bug, because they dont know how to fix it.

I also miss a standard tool to check disc-space and one to clean up the system automatically on low disc-space (like there is one in windows...)

Przemek K. (azrael) on 2009-11-20
Changed in baltix:
status: New → Invalid
Mantas Kriaučiūnas (mantas) wrote :

Przemysław Kulczycki, please don't change the status of the bugs in Baltix distribution until you aren't Baltix developer or an active user
(see http://launchpad.net/~baltix). At least don't mark bugs, assigned to Baltix by main Baltix GNU/Linux developer (Mantas Kriaučiūnas), as invalid. If you wanna become Baltix developer please write me a letter.

Changed in baltix:
assignee: nobody → Mantas Kriaučiūnas (mantas)
importance: Undecided → Medium
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers