F-spot CDExport dialog exceed 600 pixel height when the screen is small

Bug #320817 reported by Ying-Chun Liu on 2009-01-24
10
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Medium
f-spot (Ubuntu)
High
Ubuntu Desktop Bugs
Jaunty
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

In the process of developing the Ubuntu Netbook Remix, with the smaller screens of netbooks in mind, I wrote a patch to make f-spot work with less pixels.

The problem is when exporting an image to CD, the dialog will exceed 600 pixel height.
It can be easily reproduced by
1. Xephyr -ac -screen 1024x600 :2
2. env DISPLAY=:2 metacity &
3. env DISPLAY=:2 f-spot
4. Select an image in f-spot and export it to CD

How interested are you in making such a resolution-dependent change?
Thanks.

Related branches

Ying-Chun Liu (paulliu) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=569183

Changed in f-spot:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in f-spot:
status: Unknown → New
Anmar Oueja (anmar) wrote :

Sebastian/mpt: Guys we need your guidance on this. Do you think it is a good resolution to the problem and would upstream accept it?

Michael Terry (mterry) wrote :

Paul and I suggested a possible alternative to adjusting two different size requests based on screen size: always requesting 70% of screen size. Might be slightly more elegant.

Ying-Chun Liu (paulliu) wrote :

Updated patch.

Sebastien Bacher (seb128) wrote :

wouldn't it be better to just use 0.7 as value rather than letting it do the maths every time? it doesn't make a lot of difference but still

Ying-Chun Liu (paulliu) wrote :

Sorry, do you mean assign 0.7 as an argument?
Or Height*0.7??
According to
http://www.go-mono.com/docs/index.aspx?link=T%3aGtk.Window%2f*

The Resize member function reads two int.
I'm not sure if there's two float version of Resize.
If there is, Resize(1.0,0.7) is better.

But if we have to use Resize(int,int), it means we have to convert Height to float and *0.7 and convert it back to int which may not faster than two int operation *7 /10.

I'm not familiar at C# and Mono so I'm not sure which one is real faster. But usually two int op is faster than one float op, right?

David Mandala (davidm) wrote :

This is very important for Notebook Remix, so I've increased the priority and asked stevenk to assist where possible to make sure it does not stall.

Changed in f-spot:
importance: Low → High
David Mandala (davidm) wrote :

Needs to be fixed for Alpha 6

Changed in f-spot:
milestone: none → jaunty-alpha-6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.5.0.3-1ubuntu3

---------------
f-spot (0.5.0.3-1ubuntu3) jaunty; urgency=low

  * debian/control:
    - don't recommends sqlite, sqlite3 since the migration was done before
      hardy and those are not required nowadays
  * debian/patches/ubuntu_1024x600_CDExport.cs.dpatch:
    - change by Ying-Chun Liu for small screen compatibility (lp: #320817)
  * debian/patches/ubuntu_fix_export_crash_FlickrRemote.cs.dpatch:
    - change by Ying-Chun Liu to not crash when exporting to flickr and having
      internet connectivity issues (lp: #320602)

 -- Sebastien Bacher <email address hidden> Fri, 06 Mar 2009 18:42:22 +0100

Changed in f-spot:
status: Triaged → Fix Released
Changed in f-spot:
status: New → Fix Released
Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
Changed in f-spot:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.