F-spot crash when export to flickr and the network has problem

Bug #320602 reported by Ying-Chun Liu on 2009-01-23
8
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Critical
f-spot (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

F-spot crash when the network is not available.

stack trace:
(f-spot:31251): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Net.WebException: Error: NameResolutionFailure
  at System.Net.HttpWebRequest.EndGetRequestStream (IAsyncResult asyncResult) [0x00000]
  at System.Net.HttpWebRequest.GetRequestStream () [0x00000]
  at FlickrNet.Flickr.DoGetResponse (System.String url, System.String variables) [0x00000]
  at FlickrNet.Flickr.GetResponse (System.Collections.Hashtable parameters, TimeSpan cacheTimeout) [0x00000]
  at FlickrNet.Flickr.GetResponseNoCache (System.Collections.Hashtable parameters) [0x00000]
  at FlickrNet.Flickr.AuthGetFrob () [0x00000]
  at FlickrRemote.TryWebLogin () [0x00000]
  at FSpotFlickrExport.FlickrExport.Login () [0x00000]
  at FSpotFlickrExport.FlickrExport.HandleClicked (System.Object sender, System.EventArgs args) [0x00000]
  at GLib.Signal.voidObjectCallback (IntPtr handle, IntPtr data) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.Signal.voidObjectCallback(IntPtr handle, IntPtr data)
   at GLib.Signal.voidObjectCallback(IntPtr , IntPtr )
   at Gtk.Application.gtk_main()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at FSpot.Driver.Main(System.String[] args)

It can be simulated by
1. iptables -A OUTPUT -o eth0 -p tcp -d www.flickr.com -j DROP
2. run f-spot.
3. select any image and export to flickr
4. click authorized button

or
1. iptables -D OUTPUT -p udp --dport 53 -j DROP
2. run f-spot.
3. select any image and export to flickr
4. click authorized button

I've made a patch to fix the problem.

Related branches

Pedro Villavicencio (pedro) wrote :

Thanks for the report and work, the bug was known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=553518 I've also posted your patch there, please subscribe to the report in case the upstream developers have some questions or comments about your patch, thanks in advance.

Changed in f-spot:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in f-spot:
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for the patch, wouldn't it be better do something in the exception case rather than just catching it as you do now?

Ying-Chun Liu (paulliu) wrote :

Dear Sebastien,

I've updated the patch to show an error dialog.

Thanks.

Sebastien Bacher (seb128) wrote :

did you check that the error is listed in the translatable strings?

David Mandala (davidm) wrote :

I've raised this to high as it's important to the Netbook Remix release. I've also asked stevenk to watch and make sure nothing blocks it.

Changed in f-spot:
importance: Medium → High
Ying-Chun Liu (paulliu) wrote :

Hi,

This new patch uses strings from other Exporters, so we don't need to re-translate it.

David Mandala (davidm) wrote :

Needs to be fixed for Alpha 6

Changed in f-spot:
milestone: none → jaunty-alpha-6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.5.0.3-1ubuntu3

---------------
f-spot (0.5.0.3-1ubuntu3) jaunty; urgency=low

  * debian/control:
    - don't recommends sqlite, sqlite3 since the migration was done before
      hardy and those are not required nowadays
  * debian/patches/ubuntu_1024x600_CDExport.cs.dpatch:
    - change by Ying-Chun Liu for small screen compatibility (lp: #320817)
  * debian/patches/ubuntu_fix_export_crash_FlickrRemote.cs.dpatch:
    - change by Ying-Chun Liu to not crash when exporting to flickr and having
      internet connectivity issues (lp: #320602)

 -- Sebastien Bacher <email address hidden> Fri, 06 Mar 2009 18:42:22 +0100

Changed in f-spot:
status: Triaged → Fix Released
Changed in f-spot:
status: Confirmed → Fix Released
Changed in f-spot:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.