F-Spot: 'Send by Mail' creates email but fails to attach image in Mozilla Thunderbird

Bug #298814 reported by swulf on 2008-11-16
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
F-Spot
Won't Fix
Medium
f-spot (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

The 'Send by Mail' feature of F-Spot (f-spot 0.5.0.3) under Ubuntu 8.10 running on a Dell Dimension 4600 does not perform as expected. I am using Mozilla Thunderbird (version 2.0.0.17 (20080925)) as my default email client.

Example:

a) Select a photo in F-Spot (highlight it with a left-click),
b) From the Photo menu, select 'Send by Mail',
c) Leave the defaults as set (Size: Medium),
d) Hit 'Create Mail' button,
e) F-Spot shows an 'exporting' dialog for a short while,
f) Thunderbird opens a new Compose window with the title 'my+photos', but there is no attachment.

Here is the system release info:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu 8.10"

$ uname -a
Linux roke 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux

Pedro Villavicencio (pedro) wrote :

could you open a bug upstream at bugzilla.gnome.org? it looks very similar to bug 158880 but that one was fixed almost at the being of this year. For forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; thanks in advance.

Changed in f-spot:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

great, thanks you for sent it there.

Changed in f-spot:
status: Incomplete → Triaged
swulf (swulf) wrote :

The fix in the upstream report works - hence this report can be also be closed.

Thanks!

Pedro Villavicencio (pedro) wrote :

upstream report wasn't fixed it was marked as a duplicate of another bug, when the bug is fixed upstream the status is "RESOLVED" and the resolution "FIXED" you can take bug http://bugzilla.gnome.org/show_bug.cgi?id=559105 as an example of what i'm talking ; thanks you.

Changed in f-spot:
status: Unknown → New
swulf (swulf) wrote :

Seems to work now; under Ubuntu 9.04 and F-Spot version 0.5.0.3.

swulf (swulf) wrote :

Just tried to attach photos to an email in FSpot (f-spot 0.5.0.3) under Jaunty - on sending the email I get an error dialog from Mozilla Thunderbird, which I attach an image of.

This feature of FSpot remains unusable...

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

ricardisimo (ricardisimo) wrote :

For whatever it's worth, it's doing the same thing with evolution: creating an empty email with no photos attached.

I'm on Koala, using F-Spot 0.6.1.5.

ricardisimo (ricardisimo) wrote :

Hmmm... I switched to Thunderbird in my preferred apps, and it seems to be working just fine now. I'll try switching back and forth and see what happens with regards to Evolution.

ricardisimo (ricardisimo) wrote :

OK, sorry for all of this. It would appear that the problem may have been that Evolution was NOT actually selected within Preferred Applications. Instead "Custom" was selected, and Evolution was the default. Now that Evolution is actually selected, it works just fine sending pictures. Well, that's as much as my sleep-deprived brain can deduce.

swulf (swulf) wrote :

Problem is *still happening* under Ubuntu Lucid (10.04) and F-Spot 0.6.1.5 on a Lenovo W500. The email is created but with no image attachment and no error reported.

swulf (swulf) wrote :

More info:

a) Changing from a 'Custom' setting (pointing to Thunderbird) under Preferred Applications allowed me to send an email message with a single attached image,

b) Attaching multiple images (19 in total) failed with the message: 'Sending of message failed.
Unable to open the temporary file /tmp/tmp9264968.tmp/P1070377.JPG. Check your 'Temporary Directory' setting.'

So it sort-of works, but not well enough. *sigh*

Changed in f-spot:
importance: Unknown → Medium
Changed in f-spot:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.