export to flickr always exports original version

Bug #298148 reported by Alex Lubberts on 2008-11-14
2
Affects Status Importance Assigned to Milestone
F-Spot
Won't Fix
Medium
f-spot (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

Hi,

I'm using Ubuntu 8.10 and f-spot version 0.5.0.3-0ubuntu4.

In f-spot I have a lot of raw (.crw) images. These images have extra versions that I converted to tiff. If I select a couple of images and choose 'export to flickr' then I see in the preview pane the edited (tiff) versions like I expected. But if I then click the export button, not the tiff versions are uploaded as I would expect, but the original raw version. (Of course, this fails...)

Regards,
Alex

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: f-spot 0.5.0.3-0ubuntu4
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=nl_NL.UTF-8
 LC_MESSAGES=C
 SHELL=/bin/bash
SourcePackage: f-spot
Uname: Linux 2.6.27-7-generic x86_64

Alex Lubberts (delub) wrote :
Changed in f-spot:
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

I cannot reproduce this, does this happens only with crw files? may you get an f-spot debug log with f-spot --debug &> f-spot-debug.txt perform the operation and submit the file to the report? thanks in advance.

Changed in f-spot:
assignee: nobody → desktop-bugs
status: New → Incomplete
Alex Lubberts (delub) wrote :

Here's the log file. The error is Filesize is zero. I get the same error when I'm trying to upload a .crw file directly to flickr. Uploading a tif file (if the original file was a tif) works fine. Is there a problem with two different file types for two versions of the same photo?

Alex Lubberts (delub) wrote :

Could it be that I was jumping to conclusions? Yesterday I read that the free Flickr account does not allow uploading of a file that is larger than 10 MB. It could be that uploading a crw file and uploading a too large file results in the same error by the Flickr plugin. If so, should this report be closed or may be changed to a wish for a more understandable error message?

Pedro Villavicencio (pedro) wrote :

looks pretty similar, linking the report, thanks.

Changed in f-spot:
status: Incomplete → Triaged
drberg1000 (drberg1000) wrote :

I am experiencing a similar problem except I'm working with jpegs. I have an jpeg image that I cropped and want to export the cropped version to flickr but F-Spot doesn't seem to give me the option of selecting anything but the original.

This is on Intreped AMD64

dberg@dberg-desktop:~$ uname -a
Linux dberg-desktop 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux
dberg@dberg-desktop:~$ f-spot --version
GNOME f-spot 0.5.0.3

drberg1000 (drberg1000) wrote :

Looking closer the active version does get uploaded but the original thumbnail is displayed regardless of which version gets uploaded.

Looks like my problem is unrelated. Sorry about that.

Changed in f-spot:
status: Unknown → New
Changed in f-spot:
importance: Unknown → Medium
Changed in f-spot:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.