f-spot slideshow shows strange effetcs on the first photo

Bug #260950 reported by marco.pallotta on 2008-08-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
F-Spot
Won't Fix
Low
f-spot (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

When I press slide-show button in f-spot I see often strange effects on the first photo showed: the photo appears and disappears 3 or 4 times and then I only see a bright screen. After this happens then slide show runs ok for the remaining photoes.

F-spot is version 0.4.3.1-0ubuntu1

.xsession-errors shows the messages below when the issue happens

"
item changed
max texture size 2048 scaling to 1
Disposing 1 IsTexture 1
Done Disposing 1
UnInhibit screensaver
"

marco.pallotta (marco-pallotta) wrote :

I forgot to say that what I have reported happens in Hardy Heron x86-64.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Intrepid Ibex. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in f-spot:
assignee: nobody → desktop-bugs
status: New → Incomplete
marco.pallotta (marco-pallotta) wrote :

Pedro, I hope it will be fixed in Hardy Heron too.

Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in f-spot:
status: Incomplete → Invalid
marco.pallotta (marco-pallotta) wrote :

@Pedro, I tested the issue in Intrepid Ibex as you asked to me and the problem is also present in the f-spot version installed in Intrepid.

marco.pallotta (marco-pallotta) wrote :

Provided asked information

Changed in f-spot:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

could you take an screenshot of the issue or make an screencast ? i dont see such behavior on my installation, thanks.

Changed in f-spot:
importance: Undecided → Low
status: New → Incomplete
marco.pallotta (marco-pallotta) wrote :

@Pedro, I have made a video capture of the issue.

Pedro Villavicencio (pedro) wrote :

alright, you may want to send this upstream to bugzilla.gnome.org since you're having the issue i don't see such behavior in my installation, for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; thanks.

Changed in f-spot:
status: Unknown → New
digger vermont (digver) wrote :

Some of it may be due to compiz. If I'm using compiz I initially see some flashing blocks and a white screen during the first transition. From there it seems okay.

If I turn off compiz the flashing blocks disappear but I still have the white screen during the first transition.

Pedro Villavicencio (pedro) wrote :

thanks for sent it to GNOME.

Changed in f-spot:
status: Incomplete → Triaged
costa (costayao) wrote :

for me. on ubuntu 8.10, 3d desktop is enabled. If there is a window on the screen, when I press the slideshow botton, there will a white block on every slice. and i find the white block is that window.

costa (costayao) wrote :

and i find if i run f-spot first and then enable 3D desktop, press slideshow is ok.

svaens (svaens) wrote :

Hi all,

I am running Jaunty. And as of 8 Aug 2009, with all updates, fspot displays similar behaviour to what is described here.

I start the slideshow.
First picture is shown
at the transition for the 2nd picture, first the screen flashes brilliant white
Then the next picture transitions in.

This does not happen for subsequent pictures.

I tried the issue on Jaunty with compiz effects disabled (due to blacklisted vga device) and I saw not strange effects of first photo during slideshow.
I too suspected something related to compiz but in this bug discussion there are people that have the issue either with compiz effects enabled or with compiz effects not enabled.

However I will try to enable compiz effects to see if on Jaunty, with compiz disabled, the issue happens to me.
svaens, you noticed the issue on Jaunty with compiz effects enabled or not?

I tested the issue with Jaunty with compiz enabled and I can confirm the strange effects on the first photo during slideshow.
With compiz disabled I correct myself: no strange effects, as I sayd in my previous post, but only a white screen for a while before first photo.
For me the bug is always present (either with compiz enabled or not) but with compiz enabled it's more evident (strange effects) while with compiz disabled it's less evident (a simple white screen).

svaens, are you sure that you saw the issue at the transition for the 2nd picture and not for the first?

Hi,
I remember having the same bug for ages. However, I just downloaded version 0.6.1.0 from getdeb.net and this is the first time that _i noticed_ that the transition from first to second slide doesn't flash white. Not so sure which bugfix resolved this but it appears that this behavior was fixed. Hopefully the next ubuntu release will also have this bugfix.
Running 9.10 (Jaunty) 32bit, no compiz enabled (and I did have this bug before without compiz as well).

Changed in f-spot:
importance: Unknown → Low
Changed in f-spot:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.