Ubuntu

f-spot crashes when I plug my camera in

Reported by mattismyname on 2008-07-20
2
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

I plug in my camera, click import in the dialog that pops up, F-spot launches and then crashes:

Starting new FSpot server
Xlib: extension "GLX" missing on display ":0.0".
Error initializing the OpenGL context:
 GdkGlx.GlxException: Unable to find matching visual
  at GdkGlx.Context..ctor (Gdk.Screen screen, GdkGlx.Context share_list, System.Int32[] attr) [0x00000]
  at GdkGlx.Context..ctor (Gdk.Screen screen, System.Int32[] attr) [0x00000]
  at FSpot.PhotoImageView.HandleRealized (System.Object sender, System.EventArgs args) [0x00000]
Reloading
item changed
*** glibc detected *** f-spot: free(): invalid pointer: 0xb2e7c00c ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb7cf2394]
/lib/tls/i686/cmov/libc.so.6(cfree+0x96)[0xb7cf43f6]
/usr/lib/libglib-2.0.so.0(g_free+0x36)[0xb7e658d6]
[0xb771bace]
[0xb311e93a]
[0xb311e8b1]
[0xb311e6a0]
[0xb311d9d5]
[0xb311d7f3]
[0xb311d780]
[0xb311d6de]
f-spot(mono_runtime_invoke_array+0x3d3)[0x809e8b3]
f-spot[0x80a6943]
[0xb6ac3eed]
[0xb6ac3b63]
[0xb6ac3813]
[0xb311cc88]
[0xb311c8b3]
[0xb6ac8d74]
[0xb33616fc]
[0xb33616c0]
[0x8c28ee4]
/usr/lib/libglib-2.0.so.0[0xb7e944bd]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8)[0xb7e5d5e8]
/usr/lib/libglib-2.0.so.0[0xb7e60c93]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1d2)[0xb7e611b2]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb9)[0xb66d1219]
[0xb3361676]
[0xb3361640]
[0xb3361628]
[0xb771b4f2]
[0xb771a1c4]
f-spot(mono_runtime_exec_main+0xf7)[0x809cb97]
f-spot(mono_runtime_run_main+0x16b)[0x809d17b]
f-spot(mono_main+0x60e)[0x805aebe]
f-spot[0x805a3c2]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb7c99685]
f-spot[0x805a301]
======= Memory map: ========
00010000-00248000 rwxp 00010000 00:00 0
08048000-0821f000 r-xp 00000000 08:15 38044 /usr/bin/mono
0821f000-08220000 r-xp 001d6000 08:15 38044 /usr/bin/mono
08220000-08221000 rwxp 001d7000 08:15 38044 /usr/bin/mono
08221000-08231000 rwxp 08221000 00:00 0
089b0000-093d4000 rwxp 089b0000 00:00 0 [heap]
b2a00000-b2a21000 rwxp b2a00000 00:00 0
b2a21000-b2b00000 ---p b2a21000 00:00 0
b2b45000-b2b51000 r-xp 00000000 08:15 123083 /lib/libgcc_s.so.1
b2b51000-b2b52000 r-xp 0000b000 08:15 123083 /lib/libgcc_s.so.1
b2b52000-b2b53000 rwxp 0000c000 08:15 123083 /lib/libgcc_s.so.1
b2b53000-b2d96000 rwxp b2e1f000 00:00 0
b2e7c000-b307d000 rwxp b2e7c000 00:00 0
b307d000-b3083000 r-xp 00000000 08:15 38956 /usr/lib/libltdl.so.3.1.6
b3083000-b3084000 rwxp 00005000 08:15 38956 /usr/lib/libltdl.so.3.1.6
b3084000-b308b000 r-xp 00000000 08:15 38958 /usr/lib/libgphoto2_port.so.0.8.0
b308b000-b308c000 r-xp 00006000 08:15 38958 /usr/lib/libgphoto2_port.so.0.8.0
b308c000-b308d000 rwxp 00007000 08:15 38958 /usr/lib/libgphoto2_port.so.0.8.0
b308d000-b30a7000 r-xp 00000000 08:15 38960 /usr/lib/libgphoto2.so.2.3.0
b30a7000-b30a8000 r-xp 00019000 08:15 38960 /usr/lib/libgphoto2.so.2.3.0
b30a8000-b30a9000 rwxp 0001a000 08:15 38960 /usr/lib/libgphoto2.so.2.3.0
b30a9000-b3109000 rwxp b30a9000 00:00 0
b3118000-b3128000 rwxp b3118000 00:00 0
b3128000-b3188000 rwxs 00000000 00:09 16416787 /SYSV00000000 (deleted)
b3188000-b328c000 rwxp b3188000 00:00 0
b328c000-b3315000 r-xp 00000000 08:15 58851 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
b3315000-b3366000 rwxp b3315000 00:00 0
b3366000-b3367000 r-xp 00000000 08:15 46927 /usr/lib/tls/libnvidia-tls.so.177.13
b3367000-b3368000 rwxp 00000000 08:15 46927 /usr/lib/tls/libnvidia-tls.so.177.13
b3368000-b3f03000 r-xp 00000000 08:15 37815 /usr/lib/libGLcore.so.177.13
b3f03000-b4096000 rwxp 00b9b000 08:15 37815 /usr/lib/libGLcore.so.177.13
b4096000-b40a1000 rwxp b4096000 00:00 0
b40a1000-b4128000 r-xp 00000000 08:15 37814 /usr/lib/libGL.so.177.13
b4128000-b4143000 rwxp 00086000 08:15 37814 /usr/lib/libGL.so.177.13
b4143000-b4144000 rwxp b4143000 00:00 0
b4144000-b4163000 r-xp 00000000 08:15 36683 /usr/lib/libjpeg.so.62.0.0
b4163000-b4164000 rwxp 0001e000 08:15 36683 /usr/lib/libjpeg.so.62.0.0
b4164000-b417d000 r-xp 00000000 08:15 196810 /usr/lib/f-spot/libfspoteog.so.0.0.0
b417d000-b417e000 rwxp 00019000 08:15 196810 /usr/lib/f-spot/libfspoteog.so.0.0.0
b417e000-b4183000 r-xp 00000000 08:15 196811 /usr/lib/f-spot/libfspotjpegtran.so.0.0.0
b4183000-b4184000 rwxp 00005000 08:15 196811 /usr/lib/f-spot/libfspotjpegtran.so.0.0.0
b4184000-b41a4000 r-xp 00000000 08:15 38836 /usr/lib/libexif.so.12.2.0
b41a4000-b41ad000 rwxp 00020000 08:15 38836 /usr/lib/libexif.so.12.2.0
b41ad000-b41dc000 r-xp 00000000 08:15 38838 /usr/lib/liblcms.so.1.0.16
b41dc000-b41dd000 r-xp 0002e000 08:15 38838 /usr/lib/liblcms.so.1.0.16
b41dd000-b41de000 rwxp 0002f000 08:15 38838 /usr/lib/liblcms.so.1.0.16
b41de000-b41e1000 rwxp b41de000 00:00 0
b41e1000-b41e8000 r-xp 00000000 08:15 196813 /usr/lib/f-spot/libgphoto2-sharp.dll
b41e8000-b41ec000 r-xp 00000000 08:15 196240 /usr/lib/mono/gtk-sharp-2.0/libgdksharpglue-2.so
b41ec000-b41ed000 r-xp 00003000 08:15 196240 /usr/lib/mono/gtk-sharp-2.0/libgdksharpglue-2.so
b41ed000-b41ee000 rwxp 00004000 08:15 196240 /usr/lib/mono/gtk-sharp-2.0/libgdksharpglue-2.so
b41ee000-b41f0000 rwxp 00000000 00:0e 659 /dev/zero
b41f0000-b41fb000 r-xp 00000000 08:15 196812 /usr/lib/f-spot/libfspot.so.0.0.0
b41fb000-b41fc000 rwxp 0000a000 08:15 196812 /usr/lib/f-spot/libfspot.so.0.0.0
b41fc000-b4200000 rwxp b41fc000 00:00 0
b4200000-b4209000 ---p b4200000 00:00 0
b4209000-b4305000 rwxp b4209000 00:00 0
b4305000-b430e000 ---p b4305000 00:00 0
b430e000-b4436000 rwxp b430e000 00:00 0
b4436000-b4496000 rwxs 00000000 00:09 16384018 /SYSV00000000 (deleted)
b4496000-b449d000 r-xp 00000000 08:15 196239 /usr/lib/mono/gtk-sharp-2.0/libgtksharpglue-2.so
b449d000-b449e000 r-xp 00006000 08:15 196239 /usr/lib/mono/gtk-sharp-2.0/libgtksharpglue-2.so
b449e000-b449f000 rwxp 00007000 08:15 196239 /usr/lib/mono/gtk-sharp-2.0/libgtksharpglue-2.so
b449f000-b45a3000 rwxp b449f000 00:00 0
b45a3000-b4638000 r-xp 00000000 08:15 58850 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
b4638000-b463a000 r-xp 00000000 08:15 74241 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b463a000-b463b000 r-xp 00001000 08:15 74241 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b463b000-b463c000 rwxp 00002000 08:15 74241 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b463c000-b4642000 r-xs 00000000 08:15 252471 /var/cache/fontconfig/945677eb7aeaf62f1d50efc3fb3ec7d8-x86.cache-2
b4642000-b4645000 r-xs 00000000 08:15 255776 /var/cache/fontconfig/e383d7ea5fbe662a33d9b44caf393297-x86.cache-2
b4645000-b4647000 r-xs 00000000 08:15 255775 /var/cache/fontconfig/c69f04ab05004e31a6d5e715764f16d8-x86.cache-2
b4647000-b464a000 r-xs 00000000 08:15 255773 /var/cache/fontconfig/a755afe4a08bf5b97852ceb7400b47bc-x86.cache-2
b464a000-b4651000 r-xs 00000000 08:15 255772 /var/cache/fontconfig/6d41288fd70b0be22e8c3a91e032eec0-x86.cache-2
b4651000-b4654000 r-xs 00000000 08:15 255771 /var/cache/fontconfig/de156ccd2eddbdc19d37a45b8b2aac9c-x86.cache-2
b4654000-b465c000 r-xs 00000000 08:15 255770 /var/cache/fontconfig/e3de0de479f42330eadf588a55fb5bf4-x86.cache-2
b465c000-b4667000 r-xs 00000000 08:15 255769 /var/cache/fontconfig/0f34bcd4b6ee430af32735b75db7f02b-x86.cache-2
b4667000-b466e000 r-xs 00000000 08:15 255766 /var/cache/fontconfig/d52a8644073d54c13679302ca1180695-x86.cache-2
b466e000-b466f000 r-xp 00000000 08:15 74582 /usr/lib/libglade/2.0/libcanvas.so
b466f000-b4670000 r-xp 00000000 08:15 74582 /usr/lib/libglade/2.0/libcanvas.so
b4670000-b4671000 rwxp 00001000 08:15 74582 /usr/lib/libglade/2.0/libcanvas.so
b4671000-b4688000 r-xp 00000000 08:15 37374 /usr/lib/libglade-2.0.so.0.0.7
b4688000-b4689000 rwxp 00016000 08:15 37374 /usr/lib/libglade-2.0.so.0.0.7
b468a000-b468d000 r-xs 00000000 08:15 255767 /var/cache/fontconfig/de9486f0b47a4d768a594cb4198cb1c6-x86.cache-2
b468d000-b4693000 r-xs 00000000 08:15 252449 /var/cache/fontconfig/089dead882dea3570ffc31a9898cfb69-x86.cache-2
b4693000-b4696000 r-xp 00000000 08:15 72590 /usr/lib/libglade/2.0/libbonobo.so
b4696000-b4697000 r-xp 00002000 08:15 72590 /usr/lib/libglade/2.0/libbonobo.so
b4697000-b4698000 rwxp 00003000 08:15 72590 /usr/lib/libglade/2.0/libbonobo.so
b4698000-b46af000 r-xp 00000000 08:15 196304 /usr/lib/mono/gac/pango-sharp/2.12.0.0__35e10195dab3c99f/pango-sharp.dll
b46af000-b46d6000 r-xp 00000000 08:15 196815 /usr/lib/f-spot/SemWeb.dll
b46d6000-b46de000 r-xp 00000000 08:15 196369 /usr/lib/mono/gac/glade-sharp/2.12.0.0__35e10195dab3c99f/glade-sharp.dll
b46de000-b46f2000 r-xp 00000000 08:15 196555 /usr/lib/mono/gac/gtkhtml-sharp/3.16.0.0__35e10195Stacktrace:

  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_marshal_free (intptr) <0x00004>
  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_marshal_free (intptr) <0xffffffff>
  at (wrapper managed-to-native) LibGPhoto2.CameraList.gp_list_get_name (System.Runtime.InteropServices.HandleRef,int,string&) <0xffffffff>
  at LibGPhoto2.CameraList.GetName (int) <0x00068>
  at GPhotoCamera.SelectCamera (int) <0x0002f>
  at MainWindow.ImportCamera (string) <0x001a4>
  at ImportCommand.Execute () <0x0003a>
  at FSpot.Core.Import (string) <0x00037>
  at (wrapper runtime-invoke) FSpot.Core.runtime_invoke_void_string (object,intptr,intptr,intptr) <0xffffffff>
  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke (object,object[]) <0x00004>
  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke (object,object[]) <0xffffffff>
  at System.Reflection.MonoMethod.Invoke (object,System.Reflection.BindingFlags,System.Reflection.Binder,object[],System.Globalization.CultureInfo) <0x0009a>
  at System.Reflection.MethodBase.Invoke (object,object[]) <0x0001a>
  at NDesk.DBus.ExportObject.HandleMethodCall (NDesk.DBus.MethodCall) <0x000bf>
  at NDesk.DBus.Connection.HandleMethodCall (NDesk.DBus.MethodCall) <0x00372>
  at NDesk.DBus.Connection.HandleMessage (NDesk.DBus.Message) <0x00123>
  at NDesk.DBus.Connection.Iterate () <0x00023>
  at <>c__CompilerGenerated0.<>c__AnonymousMethod1 (intptr,NDesk.GLib.IOCondition,intptr) <0x00027>
  at (wrapper native-to-managed) <>c__CompilerGenerated0.<>c__AnonymousMethod1 (intptr,NDesk.GLib.IOCondition,intptr) <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0x00004>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0xffffffff>
  at Gtk.Application.Run () <0x00007>
  at Gnome.Program.Run () <0x00007>
  at FSpot.Driver.Main (string[]) <0x00cf1>
  at (wrapper runtime-invoke) FSpot.Driver.runtime_invoke_int_string[] (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

 f-spot [0x817d11e]
 [0xb7efc40c]
 /lib/tls/i686/cmov/libc.so.6(abort+0x188) [0xb7cb0228]
 /lib/tls/i686/cmov/libc.so.6 [0xb7cec0ad]
 /lib/tls/i686/cmov/libc.so.6 [0xb7cf2394]
 /lib/tls/i686/cmov/libc.so.6(cfree+0x96) [0xb7cf43f6]
 /usr/lib/libglib-2.0.so.0(g_free+0x36) [0xb7e658d6]
 [0xb771bace]
 [0xb311e93a]
 [0xb311e8b1]
 [0xb311e6a0]
 [0xb311d9d5]
 [0xb311d7f3]
 [0xb311d780]
 [0xb311d6de]
 f-spot(mono_runtime_invoke_array+0x3d3) [0x809e8b3]
 f-spot [0x80a6943]
 [0xb6ac3eed]
 [0xb6ac3b63]
 [0xb6ac3813]
 [0xb311cc88]
 [0xb311c8b3]
 [0xb6ac8d74]
 [0xb33616fc]
 [0xb33616c0]
 [0x8c28ee4]
 /usr/lib/libglib-2.0.so.0 [0xb7e944bd]
 /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8) [0xb7e5d5e8]
 /usr/lib/libglib-2.0.so.0 [0xb7e60c93]
 /usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1d2) [0xb7e611b2]
 /usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb9) [0xb66d1219]
 [0xb3361676]
 [0xb3361640]
 [0xb3361628]
 [0xb771b4f2]
 [0xb771a1c4]
 f-spot(mono_runtime_exec_main+0xf7) [0x809cb97]
 f-spot(mono_runtime_run_main+0x16b) [0x809d17b]
 f-spot(mono_main+0x60e) [0x805aebe]
 f-spot [0x805a3c2]
 /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7c99685]
 f-spot [0x805a301]

Pedro Villavicencio (pedro) wrote :

looks like a xgl issue, are you running compiz? does it happens without it? can you replicate the issue with another user? thanks.

Changed in f-spot:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

I run metacity so I don't think it's a compiz issue.

However, I just gave F-spot a try and it did not crash. However it
did give an error about not being able to connect to the camera.

Maybe this bug report has been fixed.

Pedro Villavicencio (pedro) wrote :

closing the bug then, thanks for reporting.

Changed in f-spot:
status: Incomplete → Invalid

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Matt

Learn more:
https://www.linkedin.com/e/isd/544944467/tt1_X2ET/

------------------------------------------

What is LinkedIn and why should you join?
http://learn.linkedin.com/what-is-linkedin

------
(c) 2009, LinkedIn Corporation

Jean Jordaan (jean-jordaan) wrote :

1) f-spot is running; plug in camera, click OK for "Open F-spot' in dialog that appears, f-spot crashes.

2) f-spot is not running; plug in camera, click OK for "Open F-spot' in dialog that appears, f-spot opens a dialog "F-Spot Encountered a Fatal Error"; I've attached the dump to the bug.

Looks like this is the main issue:

  An unhandled exception was thrown: Filename path must be absolute

Changed in f-spot (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers