f-spot should obey umask

Bug #201395 reported by GercoKees on 2008-03-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Low
monodevelop
Unknown
Unknown
f-spot (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

When i import files f-spot creates new folders with permissions according to my umask.
Though, the files which are copied into these folders from the usb-camera are given the wrong permissions.

For example:
with the umask set to: 002
the newly created directory's have permission: 775 (which is correct)
but the copied image-files have permission: 644 (which should be 664)

GercoKees (gercokees) wrote :

For example,
check umask:
$ umask
0002
start f-spot and import a picture: "test.jpg". In my case the file will be copied to:
~/afb/2007/05/28/
create a file:
$ touch ~/afb/2007/05/28/file
check the results:
$ ls ~/afb/2007/05/28/ -la
totaal 1392
drwxrwsr-x 2 gercokees samen 4096 2008-03-12 19:17 .
drwxrwsr-x 3 gercokees samen 4096 2008-03-12 19:16 ..
-rw-rw-r-- 1 gercokees samen 0 2008-03-12 19:17 file
-rw-r--r-- 1 gercokees samen 1410133 2008-03-12 19:16 test.jpg
gercokees@laptop:~$

notice the wrong file-permissions for the file "test.jpg" (should be rw-rw-r--)

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. What version of Ubuntu do you use?

Changed in f-spot:
importance: Undecided → Low
GercoKees (gercokees) wrote :

7.10 - feisty

GercoKees (gercokees) wrote :

oops,
7.10 - gutsy

Yann Simon (yann-simon-fr) wrote :

The bug reported here (https://bugzilla.novell.com/show_bug.cgi?id=MONO82632) looks like the same.
The bug is marked as fixed in the buzgilla from novell but the problem still exists with ubuntu hardy.

How can we check if the patch is applied in Ubuntu hardy?

Changed in f-spot:
status: Unknown → Fix Released
Changed in f-spot:
assignee: nobody → desktop-bugs
status: New → Confirmed
Daniel_SJ (daniel-jackson) wrote :

This problem still persists (8.04, newest patches per todays date).

Any chance of getting that bug fix imported? Unless some-one knows a work-around this is a pain in the but for my photo-server, as f-spot will create new files on it with the wrong permissions. It's also confusing my mom, who is the primary target of the photo server. Currently I have to manually chmod any photos she uploads through f-spot so she can edit them.

Daniel_SJ (daniel-jackson) wrote :

Just a quick question: Is this really a problem in f-spot, or is it a problem in mono? Should it be on a different package?

GercoKees (gercokees) wrote :

f-spot is written using mono. It is a problem in mono (and it is solved somewhere upstream), but shows up in f-spot.

Daniel_SJ (daniel-jackson) wrote :

Could this be related to https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/241198 ?

(And if fixing this is a quick import from Novell, is there anything stopping it from being fixed? Novell fixed it late in 2007, after all.)

Sebastien Bacher (seb128) wrote :

could you try if that's fixed in intrepid?

GercoKees (gercokees) wrote :

problem is solved in intrepid, closing.

Changed in f-spot:
status: Confirmed → Fix Released
RedCharlie (redcharlie) wrote :

It's back in Jaunty!!!

f-spot ignores both file access control lists and umask values when writing new files.

Folders are okay, it's just that all new files are created 644, which is a problem if one user imports or edits photos and another user (in same group) wants to edit the same version later.

Hi. I am using Karmic Koala-9.10 and are having problems with perms regardin F-SPOT. I share my photos from an old PC- running 9.04-mythbuntu and files are owned by me, but using group users with perm +rw (764). I use Samba sharing for my pictures (myndir).:
[myndir]
comment = myndir
path = /media/gagnadiskur/Myndir
public = yes
writable = yes
create mask = 0776
directory mask = 0776

There are 4 users on the 9.1-pc and they are all members of the group users, files have perm 774 and files 764. UMASK is set to 002. I use f-spot and use symb. link for the other users to one common location. But when any one other than the owner of the pictures edits them, then perms changes to 722??????.
But editing in Nautilus is ok.

Changed in f-spot:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.