Fspot reports error for importing Nikon D80

Bug #191316 reported by Broomer68 on 2008-02-12
Affects Status Importance Assigned to Milestone
Won't Fix
f-spot (Ubuntu)
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

The automatic importing from F-spot 0.4.1 does not work with my Nikon D80 firmware 1.10 (jan '08) This firmware enables MTP/PTP protocol and Vista compliance.
F-spot first displays a window camera selection:

Nikon DSC D80 (PTP mode) port USB:
Nikon DSC D80 (PTP mode) port USB:006,010 (last number incrementing with connection of camera)

When I choose either of these, I get:

Error connecting to camera
received error 'unspecified error' while connecting to camera.

Gthumb is able to download the images correctly with the same camera-setting (MTP/PTP) but the preference of Ubuntu is to start F-spot when connecting a camera.

Maia Everett (linneris) on 2008-02-14
Changed in f-spot:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in f-spot:
assignee: nobody → desktop-bugs
status: New → Incomplete
Broomer68 (jbezemer) wrote :

I upgraded to Intrepid yesterday, and it is still not working right, although the symptoms are slightly different.

as I connect there start 2 programs, the first is f-spot (0.4.4), which report as above mentioned, only instead of the unspecified error, I get an error like screenshot 3.

The second is a window from Nikon corp (nautilus?) where i can choose wheter or not to start fspot. (see screenshot-4)

When using the unmount-button in the nikon-window, I can use F-spot to import allright.

Broomer68 (jbezemer) wrote :

the nikon window

Pedro Villavicencio (pedro) wrote :

couldnt lock device that was fixed a few days ago, do you still have that issue? the only problem with that upload is that the download of photos from the camera is a bit slow. may you try and report back? thanks.

Broomer68 (jbezemer) wrote :

No, still not fixed (or already unfixed?) with today's f-spot update

Broomer68 (jbezemer) wrote :

Still not fixed with 8.10rc with today's updates.

With updated Nikon firmware 1.11 and camera set to PTP/MTP. (see screenshot-1)

When the camera is mounted in Mass Storage mode, F-spot is not automatically launched, but when it is started by either window (see next comment), it is able to import the pictures without unmounting.

So I think it has something to do with the implementation of the MTP/PTP Nikon window locking the USB-port.
The Mass-storage window does not lock that port, or F-spot does not require a lock or can accept a used port with a lock by another program

Broomer68 (jbezemer) wrote :

Two windows when mounted in Mass-storage mode

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Broomer68 (jbezemer) wrote :

Yes, it is still not working right in jaunty.

jaynis (kranz-jannis) wrote :

Same Bug here. Im using a Canon EOS 400D in ptp mode and f-spot fails with an "unspecific error" when I try to import pictures.

Pedro Villavicencio (pedro) wrote :

could you please get an f-spot log and attach it to the report? it would be useful for the developers to have a look into those to figure it out what's the issue, just run f-spot as: f-spot --debug &> f-spot-debug.txt try to import (aka reproduce the error) and attach the log file to the report, thanks for following up.

jaynis (kranz-jannis) wrote :

here is the f-spot log

jaynis (kranz-jannis) wrote :

Error GeneraError: LibGPhoto2.GPhotoException: Unspezifizierter Fehler

"Unspezifizierter Fehler" is german. in english it would be "unspecific error".

Broomer68 (jbezemer) wrote :

My logfile

jaynis (kranz-jannis) wrote :

I updated to Ubuntu 9.04 Beta yesterady and now everything works fine for me (Canon EOS 400D).

PlaidRadish (jeff-plaidradish) wrote :

Confirm error still exists with Kodak DX7630 in Jaunty.

Sees camera, but when I go to import from it, I get the following:

Testing gphoto path = usb:003,002
PortInfo Universal Serial Bus, usb:003,002
Error GeneraError: LibGPhoto2.GPhotoException: Unspecified error
  at LibGPhoto2.Error.CheckError (ErrorCode error) [0x00000]
  at LibGPhoto2.Camera.Init (LibGPhoto2.Context context) [0x00000]
  at GPhotoCamera.InitializeCamera () [0x00000]
  at MainWindow.ImportCamera (System.String camera_device) [0x00000]
cleanup context

anyone out there know what's up?


Sebastien Bacher (seb128) wrote :

the bug should be sent to the software writters on bugzilla.gnome.org by somebody having the issue

Changed in f-spot (Ubuntu):
status: Incomplete → New
Heinrich Münz (hmuenz) wrote :

I am having the same problem with Ubuntu Jaunty, F-Spot and my Canon EOS 1000 D. Until some weeks ago everything worked fine (I am using F-Spot since Dapper!). Then suddenly a camera icon appeared on my desktop after plugging in my camera. When I tried to import images from within F-Spot, it told me, that it could not access the device exclusively or so (sorry, but the original output is german). Now, I first have to unmount the camera before I can import images the way I used to do before.

But the most funny fact is, that this does not happen when I import images from my wife's or my daughter's account on the same computer. Then everything works fine. It just happens when I am logged in as myself. So I suppose, it might be some issue in my user settings. But I did not change anything intentionally.

sherbert (sherbert-lawwest) wrote :

Canon 40D, too: F-Spot also returns "could not lock to device" type message with Canon 40D. However, it either gets around it and starts downloading thumbs, and so on, or repeatedly clicking the Import dialogues eventually gets through to the camera.
(Wishlist, as elsewhere this page, it'd be nice to be able to skip the downloading of thumbnails :) )

Paul Crawford (psc-sat) wrote :

I have the same problem with a new Nikon D300s camera, both on my main desktop machine (Intrepid 8.10 with F-sport and with my new laptop (Dell Latitude 2100 with Jaunty 9.04). Attached is the --debug log from my desktop case, just for info.

Paul Crawford (psc-sat) wrote :

Just to add that gThumb has the same sort of problem with the D300s, giving the error message "An error occurred in the io-library ('Unspecified error'): The supplied vendor or product id (0x0,0x0) is not valid."

Paul Crawford (psc-sat) wrote :

OK, to further add to the confusion, I tried to connect my D300s to to a XP VMware machine, that resulted in it attempting to read the camera (after a few Gnome messages about being unable to lock it) and then the XP VM did the BSOD and rebooted! After that XP seemed uninterested in the camera, but I thought I would try F-spot again out of curiosity, and that time it worked!

Attached is the --debug log file (2nd run, so re-importing the same images).

After closing XP machine and camera off/on, back to the same old problem.

So there appears to be some issue with the USB initialisation perhaps? Are there any other debug/trace options to follow the USB operations to see what changed with this test?

Paul Crawford (psc-sat) wrote :

Forgot the attachment...

Pedro Villavicencio (pedro) wrote :

did somebody send this bug upstream? May you please tell us the bug number there? thanks.

Changed in f-spot (Ubuntu):
status: New → Incomplete
Paul Crawford (psc-sat) wrote :

Recently I found that my D300s "just worked". I assume this is due to some kernel patch for the USB stack, has anyone else have this experience?

Paul Crawford (psc-sat) wrote :

Nope, I was wrong, it is still there :( It might relate to the D300s configuration, going back from two memory cards to just the CF one prompted similar error messages, but re-trying the camera switch made it operate.

DrH (alan-hood) wrote :

I have this same bug with F-Spot in Ubuntu 9.10 and a Nikon Coolpix P5100, see post #32/#33 of Bug #258083.

Alex Valavanis (valavanisalex) wrote :

Hi Pedro, I've forwarded this upstream and added the link. Please feel free to check I didn't mess this up :)

Changed in f-spot (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in f-spot (Ubuntu):
status: New → Triaged
Maxxer (lorenzo-milesi) wrote :

when f-spot starts up, is the camera unmounted by gnome? or you can see it mounted in nautilus?

for the import to work the camera needs to be unmounted.
I remember a fix was made for 9.04 in f-spot-import script in order to unmount the camera on execution. I noticed it doesn't work in 9.10. could be something related to that...

Paul Crawford (psc-sat) wrote :

To add to this, the recent kernel update (I assume?) for 9.10 broke it again for my D300. It is seen as present as an MTP device, but now it only works if I connect with the XP VM first, then F-spot is OK. I am not sure if the camera appears on the desktop (i.e. mounted) but will do some more tests.

cement_head (andorjkiss) wrote :

This bug is also for me in Karmic using a Canon A75 Poweshot

Paul Crawford (psc-sat) wrote :

This seems to be the same problem as https://bugs.launchpad.net/debian/+source/f-spot/+bug/74279
What is more, it is not fixed in 10.04 and has been open for 3.5 YEARS now!

Paul Crawford (psc-sat) wrote :

Is this problem, like bug #74279, in fact due to bug #301731 in the libgphoto2 library?

Paul Crawford (psc-sat) wrote :

I posted a bug report for gphoto2 here https://sourceforge.net/tracker/?func=detail&atid=108874&aid=3004614&group_id=8874 and get the reply that the underlying reason is the gnome gvfs-gphoto2-volume-monitor.

Sure enough, if I attach the D300s I can't open it with F-spot, but on killing gvfs-gphoto2-volume-monitor it all then works as I can import photos from the PTP mode camera. However, the patch and behaviour mentioned in the gphoto2 forum is not enough to explain why this is camera-specific. Any ideas?

Paul Crawford (psc-sat) wrote :

Reading this post:
It suggests the reason for this problem is that F-spot should be using the gvfs-gphoto2-volume-monitor as its import path, not going to the libgphoto2 directly. Can anyone in the F-spot team comment?

madbiologist (me-again) wrote :

@Broomer68 - Is your Nikon D80 working now?

Broomer68 (jbezemer) wrote :

1. I am not using F-spot unless I have to. I do like Picasa more for flexible imports, image manipulation and use of directories.
2. I do have a D90 now, and that was still troubling me last time I tried. And for ease of use and greater speed, I am used to swap the SD-card, and insert it in the reader in my PC.
3. using Lucid now, this bug dates back to 2008

for what it is worth: I will test my old D80, and D90

D90: not recognized at all
D80: not recognized at all, both in MTP/PTP and in Mass-storage mode.

Wow.... surprise. I guess something is stuck with USB, altough my ebook did just function this afternoon on the same cable.
I do attach part of syslog.

Changed in f-spot:
importance: Unknown → Medium
status: Unknown → New
Changed in f-spot:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.