f-spot lost its export options

Bug #184062 reported by Dani Alonso on 2008-01-18
6
Affects Status Importance Assigned to Milestone
f-spot (Debian)
Fix Released
Unknown
f-spot (Ubuntu)
Medium
Unassigned
libflickrnet (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: f-spot

Since last update in Hardy all export options in f-spot disappeared. The Application menu shows the "Export To" option, but without the sub-menus for each one of the export targets.

Maia Everett (linneris) wrote :

Strange. It was exactly the other way round for me: the Export menu was empty in Gutsy, but the Hardy update fixed it.

Did you have this problem with 0.4.1-1, or did it only appear in 0.4.1-4ubuntu2?

Changed in f-spot:
assignee: nobody → sikon
importance: Undecided → Medium
status: New → Incomplete
Maia Everett (linneris) wrote :

Try also disabling the export extension in the extensions dialog and then re-enabling it, and report if it fixes the problem.

Dani Alonso (dalonso) wrote :

This only appeared when updating to 0.4.1-4ubuntu2. In previous versions I had all options though the flickr export made f-spot to crash everytime.

No fix in disabling and enabling again.

But running from the terminal gave this warning message:

"There's (maybe) something wrong with some of the installed extensions. You can try removing the directory addin-db-000 from ~/.gnome2/f-spot/"

I had no addin-db-000 inside f-spot directory, but adding-db-001. Nor moving this directory aside not renaming it do addin-db-000 fixed the problem. Moreover, f-spot automatically creates a new adding-db-001 directory and warns against the nonexistent addin-db-000.

No luck.

Maia Everett (linneris) wrote :

Try removing all addin* directories and the file addins-setup.config. Does it fix the problem?

Changed in f-spot:
status: Incomplete → Triaged
Maia Everett (linneris) on 2008-01-19
Changed in f-spot:
status: New → Unknown
Maia Everett (linneris) wrote :

FYI, there's a workaround in the Debian bug:

mautil -v --registry ~/.gnome2/f-spot reg-build

however, every subsequent upgrade of f-spot will likely result in the extensions becoming broken again, so it's not a real solution.

Dani Alonso (dalonso) wrote :

Matvey,

removing all addin* directories doesn't fix it. Same warning about addin-db-000 and recreation of addin-db-001 and addins-setup.config.

The workaround didn't worked at all. A lot of warnings and exceptions in the output. I'm attaching it. Here an excerpt:

...

Load exception: System.TypeLoadException: Could not load type 'FlickrRemote+Service' from assembly 'f-spot, Version=0.4.1.0, Culture=neutral'.

...

WARNING: The add-in 'FSpot.__GalleryExport,1.0' is trying to extend '/FSpot/Menus/Exports', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__GalleryExport,1.0' is trying to extend '/FSpot/Menus/Exports/Gallery', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__DefaultExporters,1.1' is trying to extend '/FSpot/Menus/Exports', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__DefaultExporters,1.1' is trying to extend '/FSpot/Menus/Exports/Flickr', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__DefaultExporters,1.1' is trying to extend '/FSpot/Menus/Exports/PicasaWeb', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__DefaultExporters,1.1' is trying to extend '/FSpot/Menus/Exports/SmugMug', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__DefaultExporters,1.1' is trying to extend '/FSpot/Menus/Exports/23hq', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__DefaultExporters,1.1' is trying to extend '/FSpot/Menus/Exports/Folder', but there isn't any add-in defining this extension point
WARNING: The add-in 'FSpot.__DefaultExporters,1.1' is trying to extend '/FSpot/Menus/Exports/CD', but there isn't any add-in defining this extension point

Maia Everett (linneris) wrote :

Thanks for the log, it has provided valuable information that will hopefully be useful in fixing the bug.

There seems to be a libflickrnet issue involved, at least partially. Judging by this:

Assembly not found: FlickrNet, Version=2.1.5.0, Culture=neutral, PublicKeyToken=2491df59efa5d132

and this:

Load exception: System.TypeLoadException: Could not load type 'FSpot.FlickrExport' from assembly 'f-spot, Version=0.4.1.0, Culture=neutral'.

What is your version of libflickrnet? There was an issue with it failing to install recently: bug #182130. It was reportedly fixed in version 25277-6build1. Although you probably have the latest version...

Dani Alonso (dalonso) wrote :

Thx for you effort Matvey.

And yes, last libflickrnet version here.

Maia Everett (linneris) wrote :

You're probably tired of all this, so of course anything I request is optional.

If you feel like providing more feedback, you could try downgrading f-spot to version 0.4.1-1. If the problem lies where I think it does, the bug should persist.

Changed in f-spot:
status: Unknown → Confirmed
Dani Alonso (dalonso) wrote :

You are right, dowgrading to gutsy version of f-spot didn't fix the bug.

By the way, I'm not tired at all, you're welcome for anything you need from me in order to fix this bug.

Maia Everett (linneris) on 2008-01-20
Changed in libflickrnet:
importance: Undecided → Medium
Maia Everett (linneris) wrote :

Upgrade F-Spot back to the Hardy version, then execute:

sudo cp /usr/lib/cli/flickrnet-2.1.5/FlickrNet.dll /usr/lib/f-spot

then rerun the mautil command, attach its output, and report if the export menu is still broken. It's not a real fix, however.

Dani Alonso (dalonso) wrote :

It worked, thx a lot.

Andrew Conkling (andrewski) wrote :

Does this have anything to do with bug #182130? If so, is this behavior fixed now?

Maia Everett (linneris) wrote :

It was filed after bug #182130 was fixed, and part of it is not related to libflickrnet (see the Debian bug). So it presumably still persists.

Maia Everett (linneris) wrote :

Dani, could you please execute

gacutil -l|grep -i flickr

and paste the output here?

Dani Alonso (dalonso) wrote :

Yes of course. This is the output:

policy.2.1.FlickrNet, Version=0.0.0.0, Culture=neutral, PublicKeyToken=2491df59efa5d132

Maia Everett (linneris) wrote :

The libflickrnet side of the bug (which is not in Debian) is clear, then. libflickrnet failed to register in the GAC on your system, causing mautil to not find it.

Here's the output on my system:

FlickrNet, Version=2.1.5.0, Culture=neutral, PublicKeyToken=2491df59efa5d132
policy.2.1.FlickrNet, Version=0.0.0.0, Culture=neutral, PublicKeyToken=2491df59efa5d132

I don't know of any reason why it could have failed to register. Can you do

sudo aptitude reinstall libflickrnet2.1.5-cil

and then execute the gacutil command again and see if it still only contains the "policy" line? If it's so, please attach the output of aptitude.

Maia Everett (linneris) wrote :

This may have something to do with the so-called "Fork workaround", which, as I can see, you applied in bug #182130.

In this case, if (and only if) libflickrnet still doesn't register in the GAC even after a reinstall, you can try the following:

sudo apt-get remove libflickrnet2.1.5-cil
sudo rm -rf /usr/share/cli-common/policies.d/libflickrnet2.1.5-cil
sudo apt-get install f-spot

(The first command will remove f-spot as well.)

And then verify with gacutil (as you did before) and report if it still fails to register.

Dani Alonso (dalonso) wrote :

Ok, after reinstall,

FlickrNet, Version=2.1.5.0, Culture=neutral, PublicKeyToken=2491df59efa5d132
policy.2.1.FlickrNet, Version=0.0.0.0, Culture=neutral, PublicKeyToken=2491df59efa5d132

Maia Everett (linneris) wrote :

Then I'll consider the libflickrnet side of the equation resolved. The loss of export functions requiring a rebuild of the mono-addins database, however, is still a bug acknowledged in Debian, so I'm leaving that as triaged.

Changed in libflickrnet:
status: New → Invalid
Maia Everett (linneris) wrote :

(By the way, since FlickrNet.dll is now in the GAC, you can delete it from /usr/lib/f-spot, and in fact I recommend it to avoid version hell in the future.

I also had this problem after a Alpha 4 install + all updates. I still had my home directory from my past install though. I fixed it by doing 'rm -rf ~/.gnome2/f-spot/addin*'.

Maia Everett (linneris) on 2008-02-26
Changed in f-spot:
assignee: sikon → nobody
Changed in f-spot:
status: Confirmed → Fix Released
Changed in f-spot:
status: Triaged → Fix Committed
Maia Everett (linneris) wrote :

Fixed in Hardy with the sync of 0.3.1-4.

Changed in f-spot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.