support custom directory structures for mass storage import dialog

Bug #182858 reported by Martin Pitt on 2008-01-14
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
F-Spot
Won't Fix
Wishlist
f-spot (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: f-spot

I keep all my photos sorted in a flat hierarchy, with lovingly named directories that describe the event (e. g. "Wedding Annet and Martin, Aug 2007"), with all the photos for this event prefixed with a number, and an optional name (if I was eager enough to name them).

F-Spot does not understand this structure when importing photos, though, but imposes the weird and deeply nested date-based structure on them, so that it destroys the layout. F-Spot should not try to own my photos, it should merely manage them! Thus the preferences dialog should allow me to select a layout, and the import dialog should have an unintrusive link to the preferences dialog to change the layout before I import photos.

The linked upstream bug has the beginnings of a patch for this.

Related branches

Changed in f-spot:
importance: Undecided → Low
status: New → Triaged
Changed in f-spot:
status: Unknown → New
Martin Pitt (pitti) on 2008-01-23
Changed in f-spot:
assignee: nobody → pitti
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.4.1-4ubuntu3

---------------
f-spot (0.4.1-4ubuntu3) hardy; urgency=low

  * Add debian/patches/importer_targetdir_selector.dpatch:
    - Add a target directory selector to the camera import dialog, so that
      people can continue to use their customized directory layout.
    - Forwarded to upstream in Gnome #511569
    - LP: #182858

 -- Martin Pitt <email address hidden> Wed, 23 Jan 2008 15:51:34 +0000

Changed in f-spot:
status: In Progress → Fix Released
Changed in f-spot:
status: Unknown → New
Duncan Lithgow (duncan-lithgow) wrote :

Is this bug about importing (reading) files on an existing system, which is where the files are to stay? No file movement?

Has this been marked as fix-released because f-stop does not require me to use their directory structure? Because the problem is still there if I want to copy and import from a camera, that's perhaps what's behind bug #195773 (upstream http://bugzilla.gnome.org/show_bug.cgi?id=329040)

Please let me know if I've understood this. Otherwise I need to make a new bug report.

Wenzhuo Zhang (wenzhuo) wrote :

In Hardy or Jaunty, f-spot still does not allow importing pictures to a custom directory. It's really a bad idea to store photos in a deeply nested date-based directory structure. Martin Pitt, can you please port your patch to the current version and submit it to upstream? Thanks!

Changed in f-spot (Ubuntu):
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

This patch was applied in hardy, and still works fine in jaunty. Thus no need to send upstream an updated patch.

What doesn't work for you in particular?

Changed in f-spot (Ubuntu):
status: In Progress → Fix Released
Wenzhuo Zhang (wenzhuo) wrote :

The import dialog (see attachment) does not provide an option to choose the target directory. I have also read Help -> Contents and f-spot Documentation web pages, but failed to find a solution. Can you please tell me how to choose the target directory when importing photos?

Duncan Lithgow (duncan-lithgow) wrote :

@Wenzhuo: please open a question at https://answers.edge.launchpad.net/ubuntu/+source/f-spot and post the link here. I will answer you there. Bugs are not the place for getting help.

Martin Pitt (pitti) wrote :

Gosh, I see. F-Spot has not one, but two different import dialogs. I never see the one you posted, since my camera uses PTP, not mass-storage. Seems the other dialog needs to be modified, too.

summary: - support custom directory structures
+ support custom directory structures for mass storage import dialog
Changed in f-spot (Ubuntu):
status: Fix Released → Triaged
Martin Pitt (pitti) on 2009-12-07
Changed in f-spot (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
Changed in f-spot:
importance: Unknown → Wishlist
Changed in f-spot:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.