F-spot crash on changing tag icon

Bug #140853 reported by Shmattie on 2007-09-19
12
Affects Status Importance Assigned to Milestone
F-Spot
Invalid
Medium
f-spot (Ubuntu)
Medium
MOTU Mono Team

Bug Description

Binary package hint: f-spot

Ubuntu 7.10
F-Spot 0.4.0

Fspot crashes consistently when I try to change the tag icon to a certain image. I am not able to change any tag icons. I don't know what other information to include so please request anything else that is needed.

Command line output

(f-spot:13819): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `pixbuf != NULL' failed
(f-spot:13819): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `src != NULL' failed
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: A null value was found where an object instance was required.
  at IconView.DrawCell (Int32 thumbnail_num, Rectangle area) [0x00000]
  at IconView.DrawAllCells (Rectangle area) [0x00000]
  at IconView.OnExposeEvent (Gdk.EventExpose args) [0x00000]
  at Gtk.Widget.exposeevent_cb (IntPtr widget, IntPtr evnt) [0x00000]

   at GLib.ExceptionManager.RaiseUnhandledException ()
   at Gtk.Widget.exposeevent_cb ()
   at Gtk.Widget.exposeevent_cb ()
   at Gtk.Dialog.gtk_dialog_run ()
   at Gtk.Dialog.gtk_dialog_run ()
   at Gtk.Dialog.Run ()
   at TagCommands+Edit.Execute ()
   at MainWindow.HandleEditSelectedTagWithTag ()
   at TagPopup+<>c__CompilerGenerated17.<>c__AnonymousMethod43 ()
   at System.MulticastDelegate.invoke_void_object_EventArgs ()
   at GLib.Signal.voidObjectCallback ()
   at GLib.Signal.voidObjectCallback ()
   at Gtk.Application.gtk_main ()
   at Gtk.Application.gtk_main ()
   at Gtk.Application.Run ()
   at Gnome.Program.Run ()
   at FSpot.Driver.Main ()

Pedro Villavicencio (pedro) wrote :

Thanks for your report will forward upstream.

Changed in f-spot:
assignee: nobody → pvillavi
importance: Undecided → Medium
status: New → Triaged
Changed in f-spot:
status: Unknown → New
Martijn Bastiaan (hmb1) wrote :
Download full text (5.9 KiB)

Same here, please see attachment. Ubuntu 7.10 Full Updated (Sat 22 Sep, 11:11 AM). Output terminal:

martijn@gutsy:~$ f-spot
Initializing Mono.Addins
Starting new FSpot server
/bin/sh: /usr/bin/esd: not found
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time

(f-spot:5214): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already attached to GtkMenuItem

(f-spot:5214): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already attached to GtkMenuItem
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Reloading
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
item changed
open uri = file:///home/martijn/Photos/1979/12/31/Zunnebel (157).jpg
open uri = file:///home/martijn/Photos/1979/12/31/Zunnebel (157).jpg
open uri = file:///home/martijn/Photos/2003/03/16/Zunnebel (265).jpg
open uri = file:///home/martijn/Photos/2003/03/16/Zunnebel (265).jpg
error checking orientation
open uri = file:///home/martijn/Photos/2004/09/04/WinHEC Leaf.jpg
open uri = file:///home/martijn/Photos/2004/09/04/WinHEC Leaf.jpg

(f-spot:5214): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
open uri = file:///home/martijn/Photos/2004/08/25/Scenic - Arboretum Musica-1.jpg
open uri = file:///home/martijn/Photos/2004/08/25/Scenic - Arboretum Musica-1.jpg
error checking orientation
open uri = file:///home/martijn/Photos/1979/12/31/Zunnebel (157).jpg
open uri = file:///home/martijn/Photos/1979/12/31/Zunnebel (157).jpg
open uri = file:///home/martijn/Photos/2002/05/20/Green Curves.jpg
open uri = file:///home/martijn/Photos/2002/05/20/Green Curves.jpg
open uri = file:///home/martijn/Photos/2003/01/02/37-1.jpg
open uri = file:///home/martijn/Photos/2003/01/02/37-1.jpg
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) AND (id IN (SELECT photo_id FROM photo_tags WHERE tag_id IN (6)) OR id IN (SELECT phot...

Read more...

Maxxer (lorenzo-milesi) wrote :

Does it happen on every tag? Or only with certain images?

What happens if you click on the image before pressing OK?

Martijn Bastiaan (hmb1) wrote :

Only the first time it doesn't happen (if F-spot automatically generates a picture). But if you want to make your custom picture it happens. On every tag yes.

> What happens if you click on the image before pressing OK?
It also crashes

Changed in f-spot:
assignee: pvillavi → mono
Christian Jung (campino2k) wrote :

Got that one, too

Maxxer (lorenzo-milesi) wrote :

if anyone wants to try, I believe this will fix.

Martijn Bastiaan (hmb1) wrote :

How to patch?

Maxxer (lorenzo-milesi) wrote :

you will need to apt-get source f-spot, patch it, repackage and reinstall.
I believe you can find a lot of resources by making a search.
If you're testing on your real f-spot db I recommend you to backup ~/.gnome2/f-spot/photos.db somewhere before starting (shouldn't be harmful, but who knows? ;) ).

Changed in f-spot:
status: New → Invalid
Maia Everett (linneris) wrote :

Upstream, this bug was marked as a duplicate of a bug fixed in 0.4.1. As 0.4.1 is now in Hardy, I'm closing it.

Changed in f-spot:
status: Triaged → Fix Released

For anyone stuck on gutsy, I've applied the above patch and built a version of the package in my PPA:

  https://launchpad.net/~martin-meltin/+archive

I've tested the i386 version and it definitely fixes the problem.

Changed in f-spot:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in f-spot:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.