export to cd does not work

Bug #134971 reported by Oxenfrogga on 2007-08-26
4
Affects Status Importance Assigned to Milestone
f-spot (Ubuntu)
Medium
Pedro Villavicencio

Bug Description

Hi everyone,

I just experienced an error with exporting my pictures to cd in f-spot 0.4.0 in xubuntu gutsy. It goes like this:

* select a photo
* go to file -> export -> export to cd; a "create cd" dialog pops up.
* click ok. The program gives an error report and stops (but it does not crash!).

This seems to happen every time. I tried different pictures, too. No change.

The error report says:
System.NullReferenceException: A null value was found where an object instance was required.
  at FSpot.CDExport.UniqueName (Gnome.Vfs.Uri path. System.String shortname) [0x00000]
  at FSpot.CDExport. Transfer () [0x00000]

Thanks for helping!
Harald

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Is this still an issue for you?

Changed in f-spot:
importance: Undecided → Medium
status: New → Incomplete
Oxenfrogga (tlatlik) wrote :

Hi Pedro,

I just updated to today's gutsy and, yes, the bug is still there. The error report is still the same ...

I could build it from source with debugging symbols if that's possible with mono (and someone gives me a hint where to find some words on how to do it).

What else do you need?

Thanks,
Harald

Pedro Villavicencio (pedro) wrote :

Still an issue? If so please forward this upstream since you're getting the bug and it's not reproducible in my environment, thanks you.

Oxenfrogga (tlatlik) wrote :

Hi Pedro,

I just tried it with todays gutsy and the problem is solved -- I don't know why exactly, but last week I installed the gnome desktop and maybe that was the fix (some hidden dependencies unknown to the apt system?).

Anyways, thanks a lot,
Harald

Pedro Villavicencio (pedro) wrote :

Thanks Oxenfrogga, will mark this as fix released for now, feel free to re open it or report a new one if you experience the same problem in the future, thanks.

Changed in f-spot:
assignee: nobody → pvillavi
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers