f-spot refuses to import, System.NullReferenceException:

Bug #133425 reported by puccaso on 2007-08-19
8
Affects Status Importance Assigned to Milestone
F-Spot
Unknown
Critical
f-spot (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: f-spot

mahir@jt-laptop:~$ f-spot --debug
** Running f-spot in Debug Mode **
** Running Mono with --debug **
Initializing Mono.Addins
Starting new FSpot server
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time

(f-spot:6898): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already attached to GtkMenuItem

(f-spot:6898): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already attached to GtkMenuItem
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Reloading
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
item changed
open uri = file:///home/mahir/Pictures/2001/2/5/dreds2.jpg
error checking orientation
open uri = file:///home/mahir/Pictures/2001/2/5/dreds2.jpg
open uri = file:///home/mahir/Pictures/2001/2/5/dreds2.jpg
open uri = file:///home/mahir/Pictures/2001/2/5/dreds2.jpg
error checking orientation

(f-spot:6898): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
open uri = file:///home/mahir/Pictures/01097_rockface_1920x1200.jpg
open uri = file:///home/mahir/Pictures/01097_rockface_1920x1200.jpg
windows - gnome-dev-harddisk - Mountpoint file:///media/windows True True Harddrive
Harddrive
cleanup context
item ImportCommand+SourceItem
Scanning /home/mahir/Pictures
Scanning /home/mahir/Pictures/2001
Scanning /home/mahir/Pictures/2001/12
Scanning /home/mahir/Pictures/2001/12/31
Scanning /home/mahir/Pictures/2001/2
Scanning /home/mahir/Pictures/2001/2/5
Scanning /home/mahir/Pictures/2002
Scanning /home/mahir/Pictures/2002/9
Scanning /home/mahir/Pictures/2002/9/26
Scanning /home/mahir/Pictures/2003
Scanning /home/mahir/Pictures/2003/7
Scanning /home/mahir/Pictures/2003/7/12
Scanning /home/mahir/Pictures/2004
Scanning /home/mahir/Pictures/2004/11
Scanning /home/mahir/Pictures/2004/11/10
Scanning /home/mahir/Pictures/2004/11/9
Scanning /home/mahir/Pictures/2004/12
Scanning /home/mahir/Pictures/2004/12/8
Scanning /home/mahir/Pictures/2004/3
Scanning /home/mahir/Pictures/2004/3/17
Scanning /home/mahir/Pictures/2004/5
Scanning /home/mahir/Pictures/2004/5/7
Scanning /home/mahir/Pictures/2004/7
Scanning /home/mahir/Pictures/2004/7/1
Scanning /home/mahir/Pictures/2004/7/2
Scanning /home/mahir/Pictures/2005
Scanning /home/mahir/Pictures/2005/1
Scanning /home/mahir/Pictures/2005/1/1
Scanning /home/mahir/Pictures/2005/11
Scanning /home/mahir/Pictures/2005/11/11
Scanning /home/mahir/Pictures/2005/11/23
Scanning /home/mahir/Pictures/2005/3
Scanning /home/mahir/Pictures/2005/3/1
Scanning /home/mahir/Pictures/2005/3/12
Scanning /home/mahir/Pictures/2005/3/4
Scanning /home/mahir/Pictures/2005/4
Scanning /home/mahir/Pictures/2005/4/23
Scanning /home/mahir/Pictures/2005/5
Scanning /home/mahir/Pictures/2005/5/16
Scanning /home/mahir/Pictures/2005/5/3
Scanning /home/mahir/Pictures/2005/6
Scanning /home/mahir/Pictures/2005/6/6
Scanning /home/mahir/Pictures/2005/9
Scanning /home/mahir/Pictures/2005/9/2
Scanning /home/mahir/Pictures/2005/9/24
Scanning /home/mahir/Pictures/2006
Scanning /home/mahir/Pictures/2006/01
Scanning /home/mahir/Pictures/2006/01/19
Scanning /home/mahir/Pictures/2006/1
Scanning /home/mahir/Pictures/2006/1/19
Scanning /home/mahir/Pictures/2006/1/6
Scanning /home/mahir/Pictures/2006/11
Scanning /home/mahir/Pictures/2006/11/5
Scanning /home/mahir/Pictures/2006/11/7
Scanning /home/mahir/Pictures/2006/12
Scanning /home/mahir/Pictures/2006/12/13
Scanning /home/mahir/Pictures/2006/12/14
Scanning /home/mahir/Pictures/2006/12/15
Scanning /home/mahir/Pictures/2006/12/17
Scanning /home/mahir/Pictures/2006/2
Scanning /home/mahir/Pictures/2006/2/21
Scanning /home/mahir/Pictures/2006/2/25
Scanning /home/mahir/Pictures/2006/3
Scanning /home/mahir/Pictures/2006/3/17
Scanning /home/mahir/Pictures/2006/3/2
Scanning /home/mahir/Pictures/2006/4
Scanning /home/mahir/Pictures/2006/4/21
Scanning /home/mahir/Pictures/2006/4/22
Scanning /home/mahir/Pictures/2006/4/23
Scanning /home/mahir/Pictures/2006/5
Scanning /home/mahir/Pictures/2006/5/21
Scanning /home/mahir/Pictures/2006/5/22
Scanning /home/mahir/Pictures/2006/5/5
Scanning /home/mahir/Pictures/2006/6
Scanning /home/mahir/Pictures/2006/6/1
Scanning /home/mahir/Pictures/2006/6/11
Scanning /home/mahir/Pictures/2006/6/14
Scanning /home/mahir/Pictures/2006/6/15
Scanning /home/mahir/Pictures/2006/6/16
Scanning /home/mahir/Pictures/2006/6/19
Scanning /home/mahir/Pictures/2006/6/22
Scanning /home/mahir/Pictures/2006/6/25
Scanning /home/mahir/Pictures/2006/6/26
Scanning /home/mahir/Pictures/2006/6/27
Scanning /home/mahir/Pictures/2006/6/28
Scanning /home/mahir/Pictures/2006/6/3
Scanning /home/mahir/Pictures/2006/6/30
Scanning /home/mahir/Pictures/2006/6/4
Scanning /home/mahir/Pictures/2006/6/6
Scanning /home/mahir/Pictures/2006/7
Scanning /home/mahir/Pictures/2006/7/17
Scanning /home/mahir/Pictures/2006/7/18
Scanning /home/mahir/Pictures/2006/7/19
Scanning /home/mahir/Pictures/2006/7/2
Scanning /home/mahir/Pictures/2006/7/3
Scanning /home/mahir/Pictures/2006/7/6
Scanning /home/mahir/Pictures/2006/8
Scanning /home/mahir/Pictures/2006/8/10
Scanning /home/mahir/Pictures/2006/8/11
Scanning /home/mahir/Pictures/2006/8/12
Scanning /home/mahir/Pictures/2006/8/14
Scanning /home/mahir/Pictures/2006/8/19
Scanning /home/mahir/Pictures/2006/8/21
Scanning /home/mahir/Pictures/2006/8/22
Scanning /home/mahir/Pictures/2006/8/23
Scanning /home/mahir/Pictures/2006/8/28
Scanning /home/mahir/Pictures/2006/8/29
Scanning /home/mahir/Pictures/2006/8/31
Scanning /home/mahir/Pictures/2006/8/4
Scanning /home/mahir/Pictures/2006/9
Scanning /home/mahir/Pictures/2006/9/1
Scanning /home/mahir/Pictures/2006/9/10
Scanning /home/mahir/Pictures/2006/9/13
Scanning /home/mahir/Pictures/2006/9/2
Scanning /home/mahir/Pictures/2006/9/27
Scanning /home/mahir/Pictures/2006/9/28
Scanning /home/mahir/Pictures/2006/9/3
Scanning /home/mahir/Pictures/2006/9/4
Scanning /home/mahir/Pictures/2006/9/6
Scanning /home/mahir/Pictures/2006/9/8
Scanning /home/mahir/Pictures/2006/9/9
Scanning /home/mahir/Pictures/2007
Scanning /home/mahir/Pictures/2007/02
Scanning /home/mahir/Pictures/2007/02/18
Scanning /home/mahir/Pictures/2007-02-16
Scanning /home/mahir/Pictures/2007-08-18 mda
Scanning /home/mahir/Pictures/Google Talk Received Images
Scanning /home/mahir/Pictures/Mahir
Scanning /home/mahir/Pictures/Mosaics
Scanning /home/mahir/Pictures/OrbSecure
Scanning /home/mahir/Pictures/QuickCam
Scanning /home/mahir/Pictures/aydinc
Scanning /home/mahir/Pictures/klkk
Scanning /home/mahir/Pictures/leaves
Scanning /home/mahir/Pictures/leaves/leaf_pictures (1)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (1)/v_plants2
Scanning /home/mahir/Pictures/leaves/leaf_pictures (1)/v_plants2/v_plants2
Scanning /home/mahir/Pictures/leaves/leaf_pictures (10)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (11)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (11)/v_plants
Scanning /home/mahir/Pictures/leaves/leaf_pictures (11)/v_plants/vplants
Scanning /home/mahir/Pictures/leaves/leaf_pictures (2)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (2)/vplants3
Scanning /home/mahir/Pictures/leaves/leaf_pictures (2)/vplants3/vplants_3
Scanning /home/mahir/Pictures/leaves/leaf_pictures (3)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (3)/v_plants4
Scanning /home/mahir/Pictures/leaves/leaf_pictures (3)/v_plants4/vplants4
Scanning /home/mahir/Pictures/leaves/leaf_pictures (4)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (4)/v_plants5
Scanning /home/mahir/Pictures/leaves/leaf_pictures (4)/v_plants5/vplants5
Scanning /home/mahir/Pictures/leaves/leaf_pictures (5)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (5)/v_plants6
Scanning /home/mahir/Pictures/leaves/leaf_pictures (5)/v_plants6/vplants6
Scanning /home/mahir/Pictures/leaves/leaf_pictures (6)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (6)/vplants7
Scanning /home/mahir/Pictures/leaves/leaf_pictures (6)/vplants7/vplants7
Scanning /home/mahir/Pictures/leaves/leaf_pictures (7)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (7)/v_plants8
Scanning /home/mahir/Pictures/leaves/leaf_pictures (7)/v_plants8/vplants8
Scanning /home/mahir/Pictures/leaves/leaf_pictures (8)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (8)/v_plants9
Scanning /home/mahir/Pictures/leaves/leaf_pictures (8)/v_plants9/vplants9
Scanning /home/mahir/Pictures/leaves/leaf_pictures (9)
Scanning /home/mahir/Pictures/leaves/leaf_pictures (9)/v_plants10
Scanning /home/mahir/Pictures/leaves/leaf_pictures (9)/v_plants10/background
Scanning /home/mahir/Pictures/leaves/leaf_pictures (9)/v_plants10/vplants10
Scanning /home/mahir/Pictures/mda
Scanning /home/mahir/Pictures/mda/2007-03-09 mda
Scanning /home/mahir/Pictures/mda/2007-04-27 mobile
Scanning /home/mahir/Pictures/mda/2007-06-07 mda
Scanning /home/mahir/Pictures/mda/2007-06-20 mahir mda
Scanning /home/mahir/Pictures/mda/2007-06-20 mda mahir
Scanning /home/mahir/Pictures/mda/2007-07-03 mda
Scanning /home/mahir/Pictures/mda/2007-07-17 mahir mda july
Scanning /home/mahir/Pictures/mda/2007-08-13 mda
Scanning /home/mahir/Pictures/ying
item changed
open uri = file:///home/mahir/Pictures/.arab.gif
item changed
open uri = file:///home/mahir/Pictures/.arab.gif
open uri = file:///home/mahir/Pictures/02590024.JPG
open uri = file:///home/mahir/Pictures/02590024.JPG
Error importing /home/mahir/Pictures/02590024.JPG
System.NullReferenceException: A null value was found where an object instance was required.
  at FSpot.Xmp.XmpTagsImporter.ProcessStore (FSpot.MetadataStore store, .Photo photo) [0x00000]
  at FSpot.Xmp.XmpTagsImporter.Import (.Photo photo, System.String path, System.String orig_path) [0x00000]
  at FileImportBackend.Step (.Photo& photo, Gdk.Pixbuf& thumbnail, System.Int32& count) [0x00000]
Could not import file
Stopping
mahir@jt-laptop:~$

ProblemType: Bug
Architecture: i386
Date: Sun Aug 19 05:22:18 2007
DistroRelease: Ubuntu 7.10
NonfreeKernelModules: fglrx
Package: f-spot 0.4.0-0ubuntu1
PackageArchitecture: i386
SourcePackage: f-spot
Uname: Linux jt-laptop.mahir 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux

puccaso (mahir) wrote :
Andy Choens (andy-choens) wrote :
Download full text (3.8 KiB)

I would like to confirm this on an installed version of Tribe 5.

f-spot --debug
** Running f-spot in Debug Mode **
** Running Mono with --debug **
Initializing Mono.Addins
Starting new FSpot server
/bin/sh: /usr/bin/esd: not found
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time

(f-spot:26241): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already attached to GtkMenuItem

(f-spot:26241): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already attached to GtkMenuItem
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
Reloading
Query: SELECT photos.id, photos.time, photos.directory_path, photos.name, photos.description, photos.roll_id, photos.default_version_id FROM photos WHERE photos.id NOT IN (SELECT photo_id FROM photo_tags WHERE tag_id = 2) ORDER BY photos.time
item changed

(f-spot:26241): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
item ImportCommand+SourceItem
Scanning /home/andy/weird
item changed
open uri = file:///home/andy/weird/PICT2196.jpg
cleanup context
open uri = file:///home/andy/weird/PICT2196.jpg
open uri = file:///home/andy/Photos/2007/01/02/PICT2196.jpg
Error importing /home/andy/weird/PICT2196.jpg
System.NullReferenceException: A null value was found where an object instance was required.
  at FSpot.Xmp.XmpTagsImporter.ProcessStore (FSpot.MetadataStore store, .Photo photo) [0x00000]
  at FSpot.Xmp.XmpTagsImporter.Import (.Photo photo, System.String path, System.String orig_path) [0x00000]
  at FileImportBackend.Step (.Photo& photo, Gdk.Pixbuf& thumbnail, System.Int32& count) [0x00000]
Could not import file
Stopping

(f-spot:26241): GLib-GObject-WARNING **: unable to set property `text' of type `gchararray' from value of type `GtkSharpValue'

(f-spot:26241): GLib-GObject-WARNING **: unable to set property `text' of type `gchararray' from value of type `GtkSharpValue'

(f-spot:26241): GLib-GObject-WARNING **: unable to set property `text' of type `gchararray' from value of type `GtkSharpValue'

(f-spot:26241): GLib-GObject-WARNING **: unable to set property `text' of type `gchararray' from value of type `GtkSharpValue'

I looked on the F-Spot forum and I do not see any reference to this bu...

Read more...

Changed in f-spot:
status: Unknown → New

This was fixed upstream, but post 0.4.0 release.

Note to packager: Andrew, f-spot trunk only contains bugfixes now, and I'll branch it on monday to keep a 0.4.0-stable branch. Feel free to pick anything from there.

Changed in f-spot:
status: New → Invalid
LEVIS Cyril (atlas95) wrote :

Same error since version 0.4.0, so i can't use it :)
Important error.

i conceed,

the error has been fixed amongst the SVN.
i am using happily

thank you open source mentality of fixing bugs and errors :)
via victoria linux!

Franck (alci) wrote :

I can confirm the bug is still present with version 0.4.0-0ubuntu1 of the package.
It will import some photos but fail on others with "A null value was found where an object instance was required" error message.

puccaso (mahir) wrote :

have you compiled via svn? or r you using the ubuntu version in universe?
the svn works fine for me..

darren (darrenm) wrote :

Yep. Fixed in SVN. Any chance of getting this merged?

Changed in f-spot:
importance: Undecided → Medium
status: New → Fix Committed
Reed Riley (reedriley) wrote :

Is there any progress on getting the fix merged? It's one of the few issues that's blocking me from migrating all of my data over to Gutsy Gibbon.

Andrew Mitchell (ajmitch) wrote :

0.4.0-0ubuntu2 has been uploaded with this fix.

Changed in f-spot:
status: Fix Committed → Fix Released
Changed in f-spot:
importance: Unknown → Critical
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.