f-spot zoom in fullscreen mode does'nt work correctly with compiz turned on

Bug #130085 reported by Alexander2007 on 2007-08-03
48
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Medium
compiz (Ubuntu)
Low
Unassigned
f-spot (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: f-spot

F-Spot zoom in fullscreen mode does'nt work.
To reproduce:
*Turn on Compiz
*Open F-Spot
*Click "Fullscreen"
*Zoom in on the displayed photo and try to drag it by keeping your hand on the left mouse button and moving the mouse.

The picture also becomes distorted (lines etc. appear through the photo)

Termial displays:

alexander@alexander-desktop:~$ f-spot
Starting new FSpot server

(f-spot:8372): libglade-WARNING **: unknown attribute `comment' for <property>.
Reloading
item changed
open uri = file:///home/alexander/Photos/2007/08/01/MountainSunset.jpg
open uri = file:///home/alexander/Photos/2007/08/01/MountainSunset.jpg
item changed
open uri = file:///home/alexander/Photos/2007/08/01/MountainSunset.jpg
open uri = file:///home/alexander/Photos/2007/08/01/MountainSunset.jpg
alexander@alexander-desktop:~$

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This is reproducible in gutsy and the upstream have a bug open for fill this kind of reports the bug number is : http://bugzilla.gnome.org/show_bug.cgi?id=361031 ; I'm posting your comments there right now, if you have further opinions please post them there. Thanks in advance.

Changed in f-spot:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in f-spot:
status: Unknown → Confirmed
Milan Bouchet-Valat (nalimilan) wrote :

Is there a chance we get in Gutsy the patches that have just been proposed upstream? (look at the Bugzilla report) This would be great!

Petar Vasić (p-vasic) wrote :

Setting the status to confirmed, because it's confirmed in the upstream.

Changed in f-spot:
status: Triaged → Confirmed
Maia Everett (linneris) on 2008-01-19
Changed in f-spot:
status: Confirmed → Triaged
Changed in f-spot:
status: Confirmed → Fix Released
Changed in f-spot:
status: Triaged → Fix Committed
Changed in f-spot:
status: Fix Committed → Triaged
Basilio Kublik (sourcercito) wrote :

Hi there
you report this bug some time ago and hans't been any activity on it, i was wondering if this is still an issue for you.

Thanks in adavance

Changed in compiz:
importance: Undecided → Low
status: New → Incomplete
Shaun Crampton (fasaxc) wrote :

This is still a problem in Gutsy on my mum's computer. She's non-technical and Hardy is not ready for her yet.

Milan Bouchet-Valat (nalimilan) wrote :

AFAIK, this bug has been fixed in Hardy. Shaun, could you confirm it is when you upgrade to Hardy (not before it is released)?

Shaun Crampton (fasaxc) wrote :

Will do.

braweheart (braweheart) wrote :

I can confirm this bug. Running Hardy AMD64 kernel 2.6.24-17-generic.
Acer laptop with mobility Radeon X700, restricted driver enabled.
F-Spot version installed 0.4.2-1ubuntu3 (hardy)

braweheart (braweheart) wrote :

Apologies, disregard my previous post. Zoom in fullscreen with Compiz enabled works fine. I was looking for a bug regarding slideshow with Fspot and Compiz enabled and was linked here.

Please excuse me

Neal McBurnett (nealmcb) wrote :

Works for me in hardy, and seems to be working for others also. Marking "Fix Released" for Ubuntu....

Changed in f-spot:
status: Triaged → Fix Released

And what about braweheart? He says he still experience this bug. Could you update F-Spot to the latest version 4.3 and test it again?

Changed in compiz:
status: Incomplete → Invalid
braweheart (braweheart) wrote :

Sorry for not responinding sooner, I've been busy, and without internetconnetcion home :-/

However, as of today I experience no bugs i Fspot whatsoever. Slideshow works fine, as do zoom in fullscreen. Compiz turned on :-)

Changed in f-spot:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.