F-Spot puts photos in Photos folder not Pictures folder

Bug #127315 reported by asjdfwejqrfjcvm msz34rq33
144
This bug affects 13 people
Affects Status Importance Assigned to Milestone
F-Spot
Won't Fix
Wishlist
One Hundred Papercuts
High
Andrew
f-spot (Ubuntu)
Low
Iain Lane

Bug Description

Binary package hint: f-spot

In Gutsy, a Pictures folder is automatically created at install. However, when a user imports photos from a camera in F-Spot it puts them in a Photos folder.
There is no need for two picture folders and F-Spot should be modified to put pictures in the Pictures folder instead.

Thanks
asjdfwejqrfjcvm msz34rq33

Related branches

Revision history for this message
Dean Sas (dsas) wrote :

Thanks for your bug, it's been forwarded upstream to the f-spot developers at http://bugzilla.gnome.org/show_bug.cgi?id=459338

Changed in f-spot:
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
asjdfwejqrfjcvm msz34rq33 (write3me) wrote :

Great thanks

Changed in f-spot:
status: Unknown → New
Revision history for this message
Dean Sas (dsas) wrote :

bug 134926 outlines the slightly more interesting case of f-spot users with a non-english desktop.

Revision history for this message
Julien Olivier (julo) wrote :

I think part of the problem comes from the fact that F-Spot organizes photos in the ~/Photos directory. It's not really a user directory, as users can't move photos around inside this directory without breaking F-Spot's database. Whereas the ~/Pictures directory is the place where users should put there pictures, and be free to move/remove them at will without breaking anything.

So, I think that:
 - whether F-Spot should use a hidden folder to store the photos it imports (to avoid users from playing with the files, and ending up breaking F-Spot's database). For example, it could be ~/.f-spot/photos.
 - or F-Spot should behave the same way Rhythmbox does, which means that it should be able to automatically import any new photo copied into the ~/Pictures folder, remove pictures from its database that have been removed from ~/Pictures, and automatically copy every file it imports into the ~/Pictures folder. This way, the ~/Pictures folders would be a user-manageable folder and would still work with F-Spot.

Revision history for this message
asjdfwejqrfjcvm msz34rq33 (write3me) wrote :

I think that the second option would be better.
My main problem with this is, when you first import your pictures, it makes a second copy of them on your hard drive which can take up quite a lot of space.

Revision history for this message
Sean Hodges (seanhodges) wrote :

Instead of copying the files, perhaps it should symlink them in it's index?

AFAIK there's no overhead to using symlinks; and it would easily be able to identify and action on missing photos as the symlink will be broken.

I guess the problem there is platform compatibility, although straight copying could be the fallback on systems without symlink support...

Revision history for this message
Jean Levasseur (levasseur.jean) wrote :

You can fire up f-spot with -b and -p switches, assigning them some other paths to place photos. For example:
$ f-spot -b /media/multimedia/Photos -p /media/multimedia/Photos

will put photos to /media/multimedia/Photos and use it as a base directory, outside of the ~ directory.

Revision history for this message
DanielDeboer (scatterfingers-gmail) wrote :

I just noticed this as well. I dislike having two places for pictures, so I changed the default directory in F-Spot's options to a hidden folder inside ~/Pictures. Although this is by no means ideal.

Revision history for this message
Ariel Ai (ariel-aigroup) wrote :

This also kills transfers of AVI files and must be killed at the console ?? only one attachment? This appears to be a system for getting monkeys to increment bug numbers. I'll try to do something about that.

Revision history for this message
Ariel Ai (ariel-aigroup) wrote :

Would you like to learn more about recursion?

Revision history for this message
Ariel Ai (ariel-aigroup) wrote :

This is Pluto Ai for ariel@ariel.

Revision history for this message
Ariel Ai (ariel-aigroup) wrote :

Is busy being paralyzed.
Even if you copy the entire contents to DCIM folder.
this was on another machine so until u get cut and paste working between different machines/users I can't give you more data.

Revision history for this message
Ariel Ai (ariel-aigroup) wrote :

The other machine (Pluto), is clever enough to create a non=existant folder for ANY USER.

Revision history for this message
Michael Monreal (mimox) wrote :

I just found that on a fresh ubuntu installation I get this error message when I first open the preferences in f-spot (having canceled the initial import dialog). Has anyone checked if f-spot actually creates ~/Photos/ if it needs it?

Revision history for this message
Michael Monreal (mimox) wrote :
Changed in f-spot:
assignee: nobody → desktop-bugs
status: Confirmed → Triaged
Revision history for this message
Caroline Ford (secretlondon) wrote :

This is still present in intrepid. If ~/photos isn't present (which it isn't in a new install) f-spot sticks all your imported photos into ~. This is really annoying.

Revision history for this message
Caroline Ford (secretlondon) wrote :

Is it possible for us just to make ~/Photos when we install as a dirty hack?

Revision history for this message
asjdfwejqrfjcvm msz34rq33 (write3me) wrote :

Perhaps, but I think the current folder setup was created to follow set guidelines.
I am surprised that it is taking F-Spot so long to fix what should be a simple problem.

Revision history for this message
Ralf Nieuwenhuijsen (ralf-nieuwenhuijsen) wrote :

Wow. A hard-coded photos folder.

Cultural imperalism at its finest.

Please remove f-spot from Ubuntu main. It clearly doesn't follow guidelines.
At least not when it comes to respecting languages and culture.

Revision history for this message
Charles P. Collins IV (thought-engineer) wrote :

I think that mimicing Rhythmbox is a good way to handle it.

I agree with Ralf, as this is a serious "Low" priority bug. Ubuntu sets up a default "Pictures" directory and then the default photo manager does not use it but defaults to copying pictures to another directory. This is very confusing to new users.

Revision history for this message
Giulio Canevari (giulio-canevari) wrote :

Also for me is very annoying for new users that are trying ubuntu ( after 5 minutes or so most people find this bug, and someone could think "damn, ubuntu isn't yet ready for normal desktop usage" ) and not only.

Revision history for this message
Paul Natsuo Kishimoto (khaeru) wrote :

"asjdfwejqrfjcvm msz34rq33", Ralf, Giulio, etc.: Note that the bug had been forwarded upstream and there is a patch available (about 6 months old at this point). Some trivial search reveals a list of maintainers for F-Spot at http://f-spot.org/Get_Involved . Perhaps it would be helpful to send them *polite* e-mail reminders to review the patch, or to send *polite* requests to people on the Ubuntu Bugs Team.

I highly doubt this problem is intended as "cultural imperialism." Occam's Razor indicates that it is only sloppy programming. Wild accusations tend to make upstream developers reluctant to fix problems.

Revision history for this message
Giovanni Mellini (merlos) wrote :

I noticed this really annoying bug Today.
It's incredible that f-spot don't allow the user to change the Image directory, considering that you can do this from command line

f-spot -p ~/Immagini

I use the Italian localization on 8.10 and I remember that with older versions this was allowed with the GUI.

I hope this will fixed asap

Giovanni

Changed in f-spot:
status: New → Confirmed
Martin Albisetti (beuno)
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → High
milestone: none → round-4
Revision history for this message
Andrew (and471) wrote :

The current status of this in karmic is that F-Spot now allows you to select the photos folder in the preferences dialog, however it is currently set to the home directory by default (which is worse than the photos folder :-] ).

I shall work on a debdiff to set it by default to the Pictures folder.

Changed in hundredpapercuts:
status: Triaged → In Progress
Revision history for this message
Andrew (and471) wrote :

Dammit f-spot is just confusing when it comes to settings it's preferences, leaving this for someone who knows more about it

Changed in hundredpapercuts:
status: In Progress → Confirmed
Vish (vish)
Changed in hundredpapercuts:
status: Confirmed → Triaged
Revision history for this message
Andrew (and471) wrote :

Oh just found it! It was in gconf (silly me) I shall build a debdiff for this. However this will also involve me building a gconf-schema for f-spot so I can set the default value easier (not such a bas thing though, considering it is missing a schema at the moment)

Setting to in progress (sorry about this status changing mac_v :-] )

Changed in hundredpapercuts:
status: Triaged → In Progress
Revision history for this message
Andrew (and471) wrote :

I have the fix now, just waiting for it to build on launchpad and then I shall test it in a karmic virtual image (ie. whether it works, whether it translates correctly etc.)

Revision history for this message
Andrew (and471) wrote :

Okay attached is the debdiff that solves this bug.

What the patch does if when F-Spot finds that the 'f-spot/import/storage_path' gconf string has not been set yet (basically the first time the user uses the application) it will check:

Does the directory 'XDG_PICTURES_DIR/Photos' exist?

(this all translates, so in Spanish this would be Imágenes/Fotos)

If it does not, then F-Spot will create the directory, if it does, then it continues. Finally F-Spot will set the default storage path for the users Photos to be:

'XDG_PICTURES_DIR/Photos'

I have tested this patch thoroughly and it builds + works perfectly on Karmic. The patch also fixes a few debian packaging things.

I am subscribing Ubuntu Main Sponsors

Changed in f-spot (Ubuntu):
status: Triaged → In Progress
Changed in hundredpapercuts:
assignee: nobody → rugby471 (rugby471)
Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

Hey, Rugby, can you please confirm with upstream that they will pursue the same folder naming strategy? I worry because using Pictures/Photos is a lot like using Music/Songs to store your song files -- it seems redundant and not entirely clear the folders are named that way. It would be a shame for upstream to go with using just the Pictures folder, or Pictures/F-Spot, and then we'd have to continue carrying your patch, and apply it to a codebase that is moving towards complex XDG userdirs support.

Revision history for this message
Andrew (and471) wrote :

On the upstream bug report, many of the people were saying they wanted it in Pictures/Photos as users may want to keep backgrounds etc. separate, in all the patches at that upstream bug, the directory was Pictures/Photos They also said the Pictures/F-Spot was definitely not what they wanted.

Another reason to do it Pictures/Photos is that F-Spot starts putting folders like 2009 etc. in the folder, which would not mix well with things such as backgrounds that cannot have a date. Also if you look at F-Spot's tag line, 'photo management software' you can see what it is designed for.

I appreciate the concern you have, however this definitely seems the way upstream also wants to go.

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote : Re: [Bug 127315] Re: F-Spot puts photos in Photos folder not Pictures folder

Ok, great, just making sure we're all on the same page.

Revision history for this message
Andrew (and471) wrote :

Cool, now we just have to wait for the upload :-)

Revision history for this message
Julian Alarcon (julian-alarcon) wrote :

Good point... Pictures are different of Photos (or Images).

Maybe, the right thing to do is to make two different folders, one for Graphics, and another for Photographs

Revision history for this message
Andrew (and471) wrote :

@Julian

all F-Spot is concerned with is photos, which is why it creates pictures/photos

Andrew (and471)
Changed in f-spot:
status: Confirmed → In Progress
Revision history for this message
Andrew (and471) wrote :

Ian Lane is working on getting this into the f-spot package in karmic

Changed in f-spot (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Iain Lane (laney)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package f-spot - 0.6.1.1-0ubuntu1

---------------
f-spot (0.6.1.1-0ubuntu1) karmic; urgency=low

  * Sync on debian with updated requirement to build on karmic
  * debian/control, debian/rules:
    - use a gnome-screensaver build-depends rather than a rules workaround

  [ Iain Lane ]
  * New Upstream Version 0.6.1.1 (LP: #418936)
    - some files were missing from the tarball
    - fix SendEmail for thunderbird3beta
  * New Upstream Version 0.6.1.0
    - fix some crashers
    - reduce the both the package size and installed size by a few Megs
    - works on gtk+ > 2.17
    - load .pcx files
    - extendable slideshow
    - ~30 bugs fixed
      + screensaver too fast (LP: #387656)
      + crash with ArgumentNullException when deleting a photo (LP: #290654)
      + Should remember "copy photos to Photos folder" setting (LP: #270238)
      + Crash when opening settings dialog (Closes: #531301)
    - updated translations
  * debian/patches/debian_link-system-flickrnet.patch,
    debian/patches/debian_link-system-gnome-keyring.patch
    debian/patches/debian_link-system-mono-addins.patch
    debian/patches/ubuntu_nofuse_fix_photo_import.patch: Update to apply cleanly
  * debian/patches/ubuntu_xdg-photo-dir.patch: Add new patch from Andrew
    Higginson, slightly modified, to default to update the user's default
    directory to XDG_PICTURES_DIR/Photos (localised) as the location to import
    pictures. Only applies to new users; existing users will see no change.
    (LP: #127315)
  * debian/rules: Remove leftover CDBS variables
  * debian/rules: Move f-spot-screensaver to /usr/lib/xscreensaver so it
    actually works. Previously it was installed in /usr/libexec and so was not
    found by gnome-screensaver. (Closes: #544204)
  * debian/control, debian_link-system-flickrnet.patch: Update flickrnet
    dependency to new ABI (Closes: #543803)
  * debian/control: Increase Standards-Version to 3.8.3, no changes required
  * debian/copyright: Update bundled library locations, point to versioned GPL
    and update FSF address

 -- Sebastien Bacher <email address hidden> Tue, 01 Sep 2009 21:37:53 +0200

Changed in f-spot (Ubuntu):
status: In Progress → Fix Released
Andrew (and471)
Changed in hundredpapercuts:
status: In Progress → Fix Released
Revision history for this message
Pascal de Bruijn (pmjdebruijn) wrote :

Since XDG can rename paths, and F-Spot stores absolute paths, this is actually a pretty poor idea... Doing this right, requires pretty invasive work in F-Spot.

The current patch (tested with 0.6.1.5) even seems to put photo's in ~/Pictures/Photos/<year>/... instead of ~/Pictures/<year>/... when no location has been explicitly set.

Revision history for this message
Iain Lane (laney) wrote :

Hiya,

We're shipping this patch now. Please, unless there is a problem with
it (explicitly *not* the operational behaviour --- that is intentional), try to
keep discussion to the upstream bug now.

On Wed, Nov 25, 2009 at 05:13:23PM -0000, Pascal de Bruijn wrote:
>Since XDG can rename paths, and F-Spot stores absolute paths, this is
>actually a pretty poor idea... Doing this right, requires pretty
>invasive work in F-Spot.

Yes, this has been discussed upstream. This behaviour happens even
without our patch, so there is no regression over upstream behaviour
by shipping it.

>The current patch (tested with 0.6.1.5) even seems to put photo's in
>~/Pictures/Photos/<year>/... instead of ~/Pictures/<year>/... when no
>location has been explicitly set.

That's right. We just change the base directory.

Regards,
Iain

Revision history for this message
Pascal de Bruijn (pmjdebruijn) wrote :

>>The current patch (tested with 0.6.1.5) even seems to put photo's in
>>~/Pictures/Photos/<year>/... instead of ~/Pictures/<year>/... when no
>>location has been explicitly set.
>
>That's right. We just change the base directory.

Heh, you do realize this is really really really broken behavior?

Revision history for this message
Caroline Ford (secretlondon) wrote :

Can you explain?

Sent from a mobile device.

On 25 Apr 2010, at 12:06, Pascal de Bruijn <email address hidden> wrote:

>>> The current patch (tested with 0.6.1.5) even seems to put photo's in
>>> ~/Pictures/Photos/<year>/... instead of ~/Pictures/<year>/... when
>>> no
>>> location has been explicitly set.
>>
>> That's right. We just change the base directory.
>
> Heh, you do realize this is really really really broken behavior?
>
> --
> F-Spot puts photos in Photos folder not Pictures folder
> https://bugs.launchpad.net/bugs/127315
> You received this bug notification because you are a direct subscriber
> of the bug.

Changed in f-spot:
status: In Progress → Confirmed
Revision history for this message
Nick Brown (nickbroon) wrote :

https://bugs.launchpad.net/ubuntu/+source/f-spot/+bug/182852
details what is wrong.
F-spot should be using ~/Pictures not ~/Pictures/Photos
(that is it should be using the XDG directory)

Changed in f-spot:
importance: Unknown → Wishlist
Changed in f-spot:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.