getGenre() API call prints "boo" on the console

Bug #1067039 reported by Paul Ortyl on 2012-10-15
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
eyed3 (Debian)
Fix Released
Unknown
eyed3 (Ubuntu)
Low
Unassigned

Bug Description

It looks like there is some debugging code left in the library in tag.py that writes "boo" to the console for certain conditions.

Solution: remove the offending line and/or use python logging interface for this kind of messages, some verbosity would not hurt either.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: python-eyed3 0.6.18-1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Mon Oct 15 21:37:37 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
PackageArchitecture: all
SourcePackage: eyed3
UpgradeStatus: Upgraded to quantal on 2012-09-22 (23 days ago)

Paul Ortyl (ortylp) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eyed3 (Ubuntu):
status: New → Confirmed
Joseph Nahmias (joe-nahmias) wrote :

The attachment "eyeD3_boo.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in eyed3 (Ubuntu):
importance: Undecided → Low
tags: added: bitesize
Changed in eyed3 (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in eyed3 (Debian):
status: Unknown → New
Changed in eyed3 (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.