No video mode large enough

Bug #194531 reported by Diti Torterat
6
Affects Status Importance Assigned to Milestone
Extreme Tux Racer
Undecided
Unassigned
extremetuxracer (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

I'm trying to run Extreme Tux Racer on my little Asus EeePC 701, which has a resolution of 800×480. I get nothing graphically, and this error message if I try to run it from the terminal:

[BEGIN]
Extreme TuxRacer SVN Development -- http://www.extremetuxracer.com
(c) 2007 The ETRacer team
(c) 2004-2005 The PPRacer team
(c) 1999-2001 Jasmin F. Patry<email address hidden>
ETRacer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

*** etracer error: Couldn't initialize video: No video mode large enough for 800x600 (Success)
[END]

Should I uninstall it or can you make this game compatible on little resolutions, for making me and my friends happy?

Thank you.

Revision history for this message
Steven Bell (botsnlinux) wrote :

This should be fixable. Try editing the ~/.etracer/options file, and change the x_resolution and y_resolution options to 800 and 480. If that doesn't help, I may be able to add that configuration to the code.

Revision history for this message
Diti Torterat (diti) wrote :

It worked with this configuration. However I didn't could launch the real game to test because the snow in the menu makes my EeePC very slow, even in 1- bits mode.
I don't know with this is so slow because this PC is able to run Tremulous perfectly whereas simple snow makes it slow...

Thank you.

Revision history for this message
Diti Torterat (diti) wrote :

(Sorry, replace “1- bits mode” by “16-bits mode” and “I don't know with” by “I don't know why”).

Revision history for this message
Christian Picon (cpicon92) wrote :

You can disable menu snow in the same config file. By the way, doesn't the eeePC come with planet penguin racer? How does it run?

Revision history for this message
Diti Torterat (diti) wrote :

Hello,

Without falling snow in the menu, the game starts correctly. But E.T.Racer runs /almost/ nice in game ;p ! Even after the deactivation of all non-needed options, and the video depth set to 16 bits, I have an average FPS of... 4.5 ^^" .

If you want, I'll test the older versions (Tux Racer?) in order to verify if newer versions needs better configuration (I think so because Nexuiz, Tremulous and other 3D games runs correctly - but Flash games doesn't.

By the way, EeePC with the default Xandros distribution (I'm on eeeXubuntu) comes with Planet Penguin racer, yes. I don't want to reinstall Xandros, so I'll ask to a friend of mine for testing it.
http://www.honeypothack.com/eee/

You can contact me by email or Jabber if you want me to help you to make EeePC more supported.

Revision history for this message
Christian Picon (cpicon92) wrote :

That would be great, we'd like to eventually replace PlanetPenguin Racer on the eeePC, so being compatible would help.

Revision history for this message
Diti Torterat (diti) wrote :

It seems that the version of Xandros which has been released doesn't come with PlanetPenguin Racer...
“Nope, all that I can play is Mr Potato and Solitaire x)”

Revision history for this message
frederyk (frederyk) wrote :

If you install ppracer per synaptic (xandros-repo) it comes automaticly in the menu games.
If you change the option file you can get about 14fps, what means it is playable (with lower quality (option-file)). Extremetuxracer isn't playable at all.

Revision history for this message
Michael Terry (mterry) wrote :

Dell Mini netbooks ship with ppracer, and they use the attached patch. Perhaps a similar patch could be applied directly? Maybe change 576 default to 480 to support tinier devices like the eeePC.

Michael Terry (mterry)
tags: added: oem
Michael Terry (mterry)
tags: added: oem-services
removed: oem
papukaija (papukaija)
tags: added: patch
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

So I confirm this bug, because the fix says that it is a reproduceable bug.

Changed in extremetuxracer (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers