Please remove ext2resize from intrepid: ext2resize tools incorrectly detect RAID stride

Bug #256669 reported by Ross Becker on 2008-08-10
6
Affects Status Importance Assigned to Milestone
ext2resize (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ext2resize

ext2online & ext2prepare both detected my RAID stride incorrectly. I have an ext3 filesystem on an LVM device created on top of an mdadm RAID5. The ext3 filesystem was created with a stride of 16, as the RAID blocksize (and PV block size) is 64k.

After adding a new drive to the RAID set, I grew the logical volume, then attempted to expand the filesystem on it.

Both ext2online & ext2prepare gave the following error:
This is odd, the RAID stride is not constant at -1009!
This is odd, the RAID stride is negative (-1009)!
Using a RAID stride value of 0

Clearly a stride of -1009 is unlikely.

I ended up taking the filesystem offline and using ext2resize to grow it, as ext2resize accepts a parameter to set the stride (-S, though it's not documented in the man page or usage message, it showed up in a changelog I found with google)

Steve Langasek (vorlon) wrote :

I believe this package should be removed from Ubuntu and blacklisted. The Debian package has had a release-critical bug on it (Debian bug #400797) since April; it has not seen an upload in Debian for two years; it will not be releasing with Lenny; and it is widely regarded by the upstream ext3 community as unsupported. (The supported resize method is resize2fs, in the core e2fsprogs package.)

Please remove this package from intrepid.

Changed in ext2resize:
status: New → Confirmed
Steve Kowalik (stevenk) wrote :

2008-10-10 05:59:37 INFO Removing candidates:
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid amd64
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid hppa
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid i386
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid ia64
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid lpia
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid powerpc
2008-10-10 05:59:37 INFO ext2resize 1.1.19-9 in intrepid sparc
2008-10-10 05:59:37 INFO Removed-by: Steve Kowalik
2008-10-10 05:59:37 INFO Comment: Requested by RM, unmaintained, buggy, broken, LP #256669
2008-10-10 05:59:37 INFO 8 packages successfully removed.

Changed in ext2resize:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers