Ubuntu needs to upgrade to expat 2

Bug #133808 reported by Richie Ward on 2007-08-21
4
Affects Status Importance Assigned to Milestone
expat (Debian)
Fix Released
Unknown
expat (Ubuntu)
Wishlist
Unassigned

Bug Description

Ubuntu is stuck with expat 1.95 which was released 3 years ago, ubuntu needs to consider upgrading to at least expat 2.

expat 1.95 causes problems with kid template's also, example of this is <p py:for="num in bottles"> it cant handle the py:for properly as it does not understand colons which is valid in xml standards.

Vincent Legout (vlegout) on 2007-08-21
Changed in expat:
importance: Undecided → Wishlist
Eric Butler (codebutler) wrote :

Assigning to ubuntu-core-dev (package maintainer).

Has anyone looked into this? Could someone provide information on how folks could help kick this off (Create packages, testing, etc.)?

Thanks.

Changed in expat:
assignee: nobody → ubuntu-core-dev
Daniel Holbach (dholbach) wrote :

Please don't assign bugs to the ubuntu-core-dev team.

Changed in expat:
assignee: ubuntu-core-dev → nobody
Changed in expat:
status: Unknown → New
Richie Ward (richies) wrote :

I take what I said about kid template's back.. that was my own fault (missing xml schema). But updating would be a nice idea at some point.

Matthias Klose (doko) wrote :

expat (2.0.1-0ubuntu1) hardy; urgency=low

  * New upstream version. LP: #133808.
  * Remove the old libexpat.so.0 symlink; this bug predates Ubuntu (was
    fixed in version 1.95.5-1).
  * Drop the extra build files in bcb5/.

 -- Matthias Klose <email address hidden> Wed, 05 Dec 2007 17:37:50 +0100

Changed in expat:
status: New → Fix Released
Changed in expat:
status: New → Fix Committed
Changed in expat:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.