Deleting "Mail Reader" crashes the computer

Bug #1783764 reported by Benitron on 2018-07-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
exo
Fix Released
Critical
exo (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, thanks for the amazing job !

there is "Mail Reader" on the Xubuntu 18.04 (brand new installed)

If you delete it from the software list (with Software / in the "Intalled" tag and remove "Mail Reader"), then when you reboot, the computer cannot access anymore to the desktop...and you have to re-install it all.

I tried it 4 times on 2 different computers.

I did try to do the same with "Web Browser", but they seem to use some similar components.

Description: Ubuntu 18.04.1 LTS
Release: 18.04
xfce 4-12

Benitron (benlarcher-1) wrote :

I just tested removing the "Web Browser" and the same thing is happening.

Hi, thanks for the amazing job !

there is "Mail Reader" or "Web Browser" on the Xubuntu 18.04 (brand new installed)

If you delete it from the software list (with Software / in the "Intalled" tag and remove "Mail Reader"), then when you reboot, the computer cannot access anymore to the desktop...and you have to re-install it all.

I tried it 4 times on 2 different computers.

I did try to do the same with "Web Browser", but they seem to use some similar components.

Description: Xubuntu 18.04.1 LTS
Release: 18.04
xfce 4-12

Uninstalling the exo wrapper "Mail Reader" does indeed remove essential packages:

Start-Date: 2018-08-12 10:16:20
Commandline: packagekit role='remove-packages'
Requested-By: xubuntu (999)
Remove: thunar-media-tags-plugin:amd64 (0.2.1-1), exo-utils:amd64 (0.12.2-0ubuntu0.18.04.1), xfce4-mailwatch-plugin:amd64 (1.2.0-2ubuntu2), xfce4-cpugraph-plugin:amd64 (1.0.5-1build1), xfce4-panel:amd64 (4.12.2-1ubuntu1), thunar-volman:amd64 (0.8.1-2), thunar-archive-plugin:amd64 (0.3.1-4), xfce4-terminal:amd64 (0.8.7.3-0ubuntu1), xubuntu-core:amd64 (2.225), thunar:amd64 (1.6.15-0ubuntu1), xfdesktop4:amd64 (4.12.3-4ubuntu2), xfce4-notes-plugin:amd64 (1.8.1-1), xfce4-quicklauncher-plugin:amd64 (1.9.4-11build1), xfce4-verve-plugin:amd64 (1.1.0-1), xfce4-weather-plugin:amd64 (0.8.10-1), xubuntu-desktop:amd64 (2.225), xfce4-places-plugin:amd64 (1.7.0-3)
End-Date: 2018-08-12 10:16:24

affects: xfce4-panel (Ubuntu) → xubuntu-meta (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in exo:
importance: Unknown → Critical
status: Unknown → Confirmed
In , Gitbot (gitbot) wrote :

Sean Davis referenced this bugreport in commit ace928e207a4ada02c57e956c675e6d97bd75cf5

Add X-AppStream-Ignore=True to hide exo launchers from GNOME Software (bug #14588)

https://git.xfce.org/xfce/exo/commit?id=ace928e207a4ada02c57e956c675e6d97bd75cf5

With the above commit, the Exo launchers should no longer be displayed in GNOME Software. This change does require an appdata refresh, so the below note from Jeremy Bicha applies once an update is packaged in Debian/Ubuntu.

"note that appstream.ubuntu.com hasn't been updating its metadata recently so you'll have to wait until that works again for your change to take effect"

Sean Davis (bluesabre) on 2018-08-31
affects: xubuntu-meta (Ubuntu) → exo (Ubuntu)
Changed in exo:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.