[SRU] Non-english live-cd: some programs are in English although their name is in Non-english, and vice-versa

Bug #1308533 reported by Pierre Equoy on 2014-04-16
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
exo (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]
Exo's desktop files are not translated in trusty amd64. This can be fixed by a rebuild (tested in ppa).

[Test Case]
Check exo-util's .desktop files for translations, only 3 are in trusty amd64, with many more in the i386 version.

[Regression potential]
Low
The only way this will regress is if an dependency of exo has been modified in trusty to the point it would break exo.

[Original Description]

Test done using VirtualBox 4.2.16 and the Xubuntu ISO found here:

http://iso.qa.ubuntu.com/qatracker/milestones/314/builds/66872/downloads

After selecting French and "Essayer Xubuntu" (Try Xubuntu), Xubuntu starts with the interface mostly in French.

However, some programs are listed in English in the XFCE main menu:
- Web Browser
- File Manager
- Terminal Emulator
- Contribute to Xubuntu
- Xubuntu Website

However:
- Web Browser launches Firefox in French (OK)
- File Manager launches Thunar in French (OK)
- Terminal Emulator launches the Terminal in French (OK)
- Contribute to Xubuntu and Xubuntu Website launch an English website (which is kind of OK)

But some other programs are named in French in the menu, but launch an English version of the software:
- Client de messagerie (e-mail client) launches Thunderbird in English (Not OK)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xubuntu-desktop 2.180
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CasperVersion: 1.340
CurrentDesktop: XFCE
Date: Wed Apr 16 13:06:42 2014
LiveMediaBuild: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: xubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Pierre Equoy (pieq) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1308533

tags: added: iso-testing
affects: xubuntu-meta (Ubuntu) → exo (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in exo (Ubuntu):
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Jackson Doak (noskcaj) on 2014-08-22
summary: - French live-cd: some programs are in English although their name is in
- French, and vice-versa
+ Non-english live-cd: some programs are in English although their name is
+ in Non-english, and vice-versa

The first three issues are in exo, and can be fixed by a rebuild.
The website needs work to be translated, see lp:797600
Thunderbird is a separate issue (the same for all the other packages listed in the chinese bug)

Jackson Doak (noskcaj) wrote :

When testing this, was thunderbird's language pack installed? e.g. thunderbird-locale-fr

Jackson Doak (noskcaj) wrote :
description: updated
summary: - Non-english live-cd: some programs are in English although their name is
- in Non-english, and vice-versa
+ [SRU] Non-english live-cd: some programs are in English although their
+ name is in Non-english, and vice-versa
tags: added: patch
Jackson Doak (noskcaj) on 2014-08-30
affects: xubuntu-default-settings (Ubuntu) → ubuntu
no longer affects: ubuntu

Hello Pierre, or anyone else affected,

Accepted exo into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/exo/0.10.2-3ubuntu1.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in exo (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Jackson Doak (noskcaj) wrote :

That has fixed the bug, thanks.

Jackson Doak (noskcaj) on 2014-09-06
Changed in exo (Ubuntu):
status: Confirmed → Fix Committed
Mathew Hodson (mathew-hodson) wrote :

Marking verification-done based on comment #9.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package exo - 0.10.2-3ubuntu1.14.04.1

---------------
exo (0.10.2-3ubuntu1.14.04.1) trusty; urgency=medium

  * Force rebuild (LP: #1308533)
 -- Sean Davis <email address hidden> Wed, 03 Sep 2014 06:22:05 -0400

Changed in exo (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for exo has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: xubuntu

Fixed in utopic and vivid.

Changed in exo (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches