Update to exiv2 version 0.26

Bug #1715931 reported by Rik Mills on 2017-09-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
exiv2 (Debian)
Fix Released
Unknown
exiv2 (Ubuntu)
Wishlist
Unassigned

Bug Description

0.26 was released in April

http://www.exiv2.org/whatsnew.html

"This release contains a large collection of new features, new lenses and bugfixes across all areas of Exiv2. "

Presumably debian stretch freeze interfered with a prompter update

Currently in debian exp here:

https://packages.debian.org/experimental/exiv2

I was hoping to to get a new feature release of the very popular Digikam (5.7.0) into artful under a FFE, but that has bumped the minimum exiv2 build depend from 0.25 -> 0.26.

If due to rdeps etc an update in artful turns out not to be possible, I would like to target this for early in 18.04 LTS cycle.

Rik Mills (rikmills) on 2017-09-08
summary: - Update to evi2 version 0.26
+ Update to eviv2 version 0.26
summary: - Update to eviv2 version 0.26
+ Update to exiv2 version 0.26
tags: added: upgrade-software-version
Jeremy Bicha (jbicha) on 2017-10-07
Changed in exiv2 (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Simon Quigley (tsimonq2) wrote :

Bump, was anything done with this?

Rik Mills (rikmills) wrote :

Seems not

Jeremy Bicha (jbicha) wrote :

At this point, this would require a Feature Freeze Exception to be considered for Ubuntu 18.04 LTS.

https://wiki.ubuntu.com/FreezeExceptionProcess

You would need to be sure that you would be able to complete the transition:
https://people.canonical.com/~ubuntu-archive/transitions/html/exiv2.html

Also, why don't you ask the Debian maintainer why this was uploaded to experimental but not unstable yet?

no longer affects: exiv2 (Ubuntu Bionic)
Ari (ari-reads) wrote :

Exiv2 0.25 as used by ubuntu 18.04 and the upcoming 18.10 is really obsolete and this brings all kinds of annoying problems with darktable - inability to recognize lenses and so on.

Even the current package in 18.10 is obsolete.

Sebastien Bacher (seb128) wrote :

The update is still in Debian/experimental and require a transition
https://release.debian.org/transitions/html/auto-exiv2.html
Unsure if it's worth trying to do in Ubuntu before Debian though

tags: added: version-blocked
Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

Several of those issues are fixed at https://github.com/Exiv2/exiv2 but it's going to be a bit of work to handle all of that in Debian or Ubuntu.

Ari (ari-reads) wrote :

Thanks Jeremy. It's a bit challenging for anyone doing photography work with recent hardware. Key apps like darktable and digicam rely on this library and ubuntu/debian are way behind. Last year's fedora had 0.26.

Flatpaks could help, I tried darktable's and it includes an updated exiv2, but it has a huge drawback, OpenCL doesnt work with flatpaks (or snaps) yet, so its useless in my case (my photography workstation is built specifically for photo editing with opencl)

I guess there is no choice but to try and build exiv2 manually and hope the system doesnt break :)

Changed in exiv2 (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.