exim4: option "local_scan_path" unknown

Bug #13356 reported by Debian Bug Importer on 2005-02-28
10
Affects Status Importance Assigned to Milestone
exim4 (Debian)
Fix Released
Unknown
exim4 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #297282 http://bugs.debian.org/297282

severity #297282 serious
tags #297282 sid
thanks

Justification: Makes, in the maintainer's opinion, the package
unsuitable for release.

On Mon, Feb 28, 2005 at 01:56:05PM +0100, Andrej KOLESNIKOV wrote:
> Since the last upgrade exim4 broke sa-exim. The dlopen_localscan patch
> seems to stop working.

Ouch. The dlopen functionality was patched in, and somehow that patch
must have gotten lost in the process. This loss of functionality is
unacceptable. I am therefore upgrading the bug severity to serious,
making the bug RC.

I can investigate on Tuesday afternoon the earliest.

> I had to disable "local_scan_path" entry in exim4 config file for now.

I would like to suggest downgrading to 4.44-2 from testing.

Greetings
Marc

--
-----------------------------------------------------------------------------
Marc Haber | "I don't trust Computers. They | Mailadresse im Header
Mannheim, Germany | lose things." Winona Ryder | Fon: *49 621 72739834
Nordisch by Nature | How to make an American Quilt | Fax: *49 621 72739835

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #297282 http://bugs.debian.org/297282

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Mon, 28 Feb 2005 13:56:05 +0100
From: Andrej KOLESNIKOV <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: exim4: option "local_scan_path" unknown

Package: exim4
Version: 4.50-2
Severity: important

Since the last upgrade exim4 broke sa-exim. The dlopen_localscan patch
seems to stop working. During upgrade I got these messages:

Exim configuration error in line 24 of /var/lib/exim4/config.autogenerated.tmp:
  main option "local_scan_path" unknown
Invalid new configfile /var/lib/exim4/config.autogenerated.tmp
not installing /var/lib/exim4/config.autogenerated.tmp to
/var/lib/exim4/config.autogenerated

I had to disable "local_scan_path" entry in exim4 config file for now.

Andrej

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.10
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages exim4 depends on:
ii exim4-base 4.50-2 support files for all exim MTA (v4
ii exim4-daemon-heavy 4.50-2 exim MTA (v4) daemon with extended

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 28 Feb 2005 14:30:31 +0100
From: Marc Haber <email address hidden>
To: Andrej KOLESNIKOV <email address hidden>, <email address hidden>
Cc: Marc Haber <email address hidden>
Subject: Re: exim4: option "local_scan_path" unknown

severity #297282 serious
tags #297282 sid
thanks

Justification: Makes, in the maintainer's opinion, the package
unsuitable for release.

On Mon, Feb 28, 2005 at 01:56:05PM +0100, Andrej KOLESNIKOV wrote:
> Since the last upgrade exim4 broke sa-exim. The dlopen_localscan patch
> seems to stop working.

Ouch. The dlopen functionality was patched in, and somehow that patch
must have gotten lost in the process. This loss of functionality is
unacceptable. I am therefore upgrading the bug severity to serious,
making the bug RC.

I can investigate on Tuesday afternoon the earliest.

> I had to disable "local_scan_path" entry in exim4 config file for now.

I would like to suggest downgrading to 4.44-2 from testing.

Greetings
Marc

--
-----------------------------------------------------------------------------
Marc Haber | "I don't trust Computers. They | Mailadresse im Header
Mannheim, Germany | lose things." Winona Ryder | Fon: *49 621 72739834
Nordisch by Nature | How to make an American Quilt | Fax: *49 621 72739835

Matt Zimmerman (mdz) wrote :

     exim4 | 4.34-10 | http://us.archive.ubuntu.com hoary/main Sources

tags #297282 sid confirmed pending
thanks

On Mon, Feb 28, 2005 at 02:30:31PM +0100, Marc Haber wrote:
> Ouch. The dlopen functionality was patched in, and somehow that patch
> must have gotten lost in the process.

4.50-3 will have the dlopen patch enabled in both -daemon-light and
-daemon-heavy. The fix is committed to svn.

Greetings
Marc

--
-----------------------------------------------------------------------------
Marc Haber | "I don't trust Computers. They | Mailadresse im Header
Mannheim, Germany | lose things." Winona Ryder | Fon: *49 621 72739834
Nordisch by Nature | How to make an American Quilt | Fax: *49 621 72739835

Download full text (3.4 KiB)

Source: exim4
Source-Version: 4.50-3

We believe that the bug you reported is fixed in the latest version of
exim4, which is due to be installed in the Debian FTP archive:

exim4-base_4.50-3_i386.deb
  to pool/main/e/exim4/exim4-base_4.50-3_i386.deb
exim4-config_4.50-3_all.deb
  to pool/main/e/exim4/exim4-config_4.50-3_all.deb
exim4-daemon-heavy_4.50-3_i386.deb
  to pool/main/e/exim4/exim4-daemon-heavy_4.50-3_i386.deb
exim4-daemon-light_4.50-3_i386.deb
  to pool/main/e/exim4/exim4-daemon-light_4.50-3_i386.deb
exim4_4.50-3.diff.gz
  to pool/main/e/exim4/exim4_4.50-3.diff.gz
exim4_4.50-3.dsc
  to pool/main/e/exim4/exim4_4.50-3.dsc
exim4_4.50-3_all.deb
  to pool/main/e/exim4/exim4_4.50-3_all.deb
eximon4_4.50-3_i386.deb
  to pool/main/e/exim4/eximon4_4.50-3_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Marc Haber <email address hidden> (supplier of updated exim4 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 1 Mar 2005 06:45:26 +0000
Source: exim4
Binary: eximon4 exim4-daemon-custom exim4-daemon-heavy exim4-base exim4 exim4-daemon-light exim4-config
Architecture: source i386 all
Version: 4.50-3
Distribution: unstable
Urgency: low
Maintainer: Exim4 Maintainers <email address hidden>
Changed-By: Marc Haber <email address hidden>
Description:
 exim4 - metapackage to ease exim MTA (v4) installation
 exim4-base - support files for all exim MTA (v4) packages
 exim4-config - configuration for the exim MTA (v4)
 exim4-daemon-heavy - exim MTA (v4) daemon with extended features, including exiscan-ac
 exim4-daemon-light - lightweight exim MTA (v4) daemon
 eximon4 - monitor application for the exim MTA (v4) (X11 interface)
Closes: 297282 297501
Changes:
 exim4 (4.50-3) unstable; urgency=low
 .
   * actually enable dlopen patch, show this in package descriptions.
     Thanks to Andrej KOLESNIKOV. (mh) Closes: #297282
   * Have exim4-config conflict with -daemon (<<4.50), as we use
     submission/sender_retain which is not supported by earlier daemons.
     Thanks to Echo Nolan. (mh) Closes: #297501
Files:
 385c60b2a5990123e8ec06d410e9c5c5 1057 mail important exim4_4.50-3.dsc
 18e84b6b091e5d0ec01985d0d66bee97 477050 mail important exim4_4.50-3.diff.gz
 e6b2337ac44078edad758825c770b984 810044 mail important exim4-base_4.50-3_i386.deb
 5494dc413d8786d366b89556202e3bbd 366268 mail important exim4-daemon-light_4.50-3_i386.deb
 53c282eeecf4ce774c66dbb7a5161852 75570 mail optional eximon4_4.50-3_i386.deb
 eadbcdf3470f93586c1942bfe664ea91 416642 mail optional exim4-daemon-heavy_4.50-3_i386.deb
 d6f55989d5aa25c4023d120ab6cf1d6d 223164 mail important exim4-config_4.50-3_all.deb
 eb15c2bbc47863a0a82b8bbe71766cce ...

Read more...

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 1 Mar 2005 07:45:18 +0100
From: Marc Haber <email address hidden>
To: Andrej KOLESNIKOV <email address hidden>, <email address hidden>
Subject: Re: Re: exim4: option "local_scan_path" unknown

tags #297282 sid confirmed pending
thanks

On Mon, Feb 28, 2005 at 02:30:31PM +0100, Marc Haber wrote:
> Ouch. The dlopen functionality was patched in, and somehow that patch
> must have gotten lost in the process.

4.50-3 will have the dlopen patch enabled in both -daemon-light and
-daemon-heavy. The fix is committed to svn.

Greetings
Marc

--
-----------------------------------------------------------------------------
Marc Haber | "I don't trust Computers. They | Mailadresse im Header
Mannheim, Germany | lose things." Winona Ryder | Fon: *49 621 72739834
Nordisch by Nature | How to make an American Quilt | Fax: *49 621 72739835

Debian Bug Importer (debzilla) wrote :
Download full text (3.6 KiB)

Message-Id: <email address hidden>
Date: Tue, 01 Mar 2005 02:17:16 -0500
From: Marc Haber <email address hidden>
To: <email address hidden>
Subject: Bug#297282: fixed in exim4 4.50-3

Source: exim4
Source-Version: 4.50-3

We believe that the bug you reported is fixed in the latest version of
exim4, which is due to be installed in the Debian FTP archive:

exim4-base_4.50-3_i386.deb
  to pool/main/e/exim4/exim4-base_4.50-3_i386.deb
exim4-config_4.50-3_all.deb
  to pool/main/e/exim4/exim4-config_4.50-3_all.deb
exim4-daemon-heavy_4.50-3_i386.deb
  to pool/main/e/exim4/exim4-daemon-heavy_4.50-3_i386.deb
exim4-daemon-light_4.50-3_i386.deb
  to pool/main/e/exim4/exim4-daemon-light_4.50-3_i386.deb
exim4_4.50-3.diff.gz
  to pool/main/e/exim4/exim4_4.50-3.diff.gz
exim4_4.50-3.dsc
  to pool/main/e/exim4/exim4_4.50-3.dsc
exim4_4.50-3_all.deb
  to pool/main/e/exim4/exim4_4.50-3_all.deb
eximon4_4.50-3_i386.deb
  to pool/main/e/exim4/eximon4_4.50-3_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Marc Haber <email address hidden> (supplier of updated exim4 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 1 Mar 2005 06:45:26 +0000
Source: exim4
Binary: eximon4 exim4-daemon-custom exim4-daemon-heavy exim4-base exim4 exim4-daemon-light exim4-config
Architecture: source i386 all
Version: 4.50-3
Distribution: unstable
Urgency: low
Maintainer: Exim4 Maintainers <email address hidden>
Changed-By: Marc Haber <email address hidden>
Description:
 exim4 - metapackage to ease exim MTA (v4) installation
 exim4-base - support files for all exim MTA (v4) packages
 exim4-config - configuration for the exim MTA (v4)
 exim4-daemon-heavy - exim MTA (v4) daemon with extended features, including exiscan-ac
 exim4-daemon-light - lightweight exim MTA (v4) daemon
 eximon4 - monitor application for the exim MTA (v4) (X11 interface)
Closes: 297282 297501
Changes:
 exim4 (4.50-3) unstable; urgency=low
 .
   * actually enable dlopen patch, show this in package descriptions.
     Thanks to Andrej KOLESNIKOV. (mh) Closes: #297282
   * Have exim4-config conflict with -daemon (<<4.50), as we use
     submission/sender_retain which is not supported by earlier daemons.
     Thanks to Echo Nolan. (mh) Closes: #297501
Files:
 385c60b2a5990123e8ec06d410e9c5c5 1057 mail important exim4_4.50-3.dsc
 18e84b6b091e5d0ec01985d0d66bee97 477050 mail important exim4_4.50-3.diff.gz
 e6b2337ac44078edad758825c770b984 810044 mail important exim4-base_4.50-3_i386.deb
 5494dc413d8786d366b89556202e3bbd 366268 mail important exim4-daemon-light_4.50-3_i386.deb
 53c282eeecf4ce774c66dbb7a5161852 75570 mail optional eximon4_4.50-3_...

Read more...

# BTS control bot commands
package exim4
tags 297541 + confirmed sid
# severities must match for the merge to succeed
severity 297541 serious
close 297541
merge 297541 297282
thanks

On Tuesday, March 01, 2005 11:20 AM, Jonathan Wheelhouse
<email address hidden> wrote:

> Package: exim4
> Version: 4.50-2
> Severity: grave
> Justification: renders package unusable
[...]
> 2005-03-01 22:04:51 Exim configuration error in line 83 of
> /var/lib/exim4/config.autogenerated.tmp: main option
> "local_scan_path" unknown

Hi,

This was fixed in 4.50-3, which is currently available from
http://incoming.debian.org/ and should hit unstable overnight.

Merging with the previous report, and closing as fixed packages are
available.

Regards,

Adam

Debian Bug Importer (debzilla) wrote :

Message-ID: <0b8401c51e5c$96c22ea0$eb00010a@andromeda>
Date: Tue, 1 Mar 2005 12:45:46 -0000
From: "Adam D. Barratt" <email address hidden>
To: "Jonathan Wheelhouse" <email address hidden>,
 <email address hidden>
Subject: Re: Bug#297541: exim4: main option "local_scan_path" unknown; Invalid new configfile

# BTS control bot commands
package exim4
tags 297541 + confirmed sid
# severities must match for the merge to succeed
severity 297541 serious
close 297541
merge 297541 297282
thanks

On Tuesday, March 01, 2005 11:20 AM, Jonathan Wheelhouse
<email address hidden> wrote:

> Package: exim4
> Version: 4.50-2
> Severity: grave
> Justification: renders package unusable
[...]
> 2005-03-01 22:04:51 Exim configuration error in line 83 of
> /var/lib/exim4/config.autogenerated.tmp: main option
> "local_scan_path" unknown

Hi,

This was fixed in 4.50-3, which is currently available from
http://incoming.debian.org/ and should hit unstable overnight.

Merging with the previous report, and closing as fixed packages are
available.

Regards,

Adam

Debian Bug Importer (debzilla) wrote :

*** Bug 13393 has been marked as a duplicate of this bug. ***

Changed in exim4:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.