Live media"Examples" desktop item translations depended on having the PO files

Bug #441986 reported by Timo Jyrinki on 2009-10-04
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
langpack-o-matic
Undecided
Unassigned
example-content (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: example-content

Hi. I realized that the "Examples" icon on the desktop when running live-CD depended on having the translations inside package when the language packs haven't yet been installed. example-content 38 removed the few PO files that were included. Since the "Install Ubuntu 9.10" above it is correctly translated, it would be a little more coherent to have also Examples translated (although eg. the menus anyway are not translated).

The solution for this would be to export all translations from https://translations.launchpad.net/ubuntu/karmic/+source/example-content/+pots/example-content and include them into source package. The translations are less than kilobyte each. This exception is done also eg. for xdg-user-dirs, the ubiquity icon etc.

Related branches

Adi Roiban (adiroiban) wrote :

I don't know exactly where we should fix this problem, but like Timo said we need to ship the example-content mo files in the Live-CD and have "Examples" translated on the desktop icon, as we already have "Install Ubuntu"

Changed in ubuntu-translations:
status: New → Confirmed
Changed in example-content (Ubuntu):
status: New → Invalid
Changed in langpack-o-matic:
status: New → Confirmed
status: Confirmed → New

I agree, and the mo files of example-content only have 2 strings, it
is acceptable to add them to CD by default. It will be better for
users to see "Examples" translated because the content is a window for
users to get a good first impression of our distro.

@Arne:
What's your opinion? Do you mind adding example-content mo files which only contain two strings to the CD?

Arne Goetje (arnegoetje) wrote :

@Aron:
I'm fine with that. But the translations need to be added to the package itself, so I don't understand why Adi marked the bug in example-content to be invalid and assigned it to langpack-o-matic...

Adi Roiban (adiroiban) wrote :

example-content is in main, so I was thinking that if we try to upload example-content, langpack-o-matic will strip them.

Maybe the bug is not in langpack-o-matic, but in the script that builds binary packages.

Changed in example-content (Ubuntu):
status: Invalid → New
Changed in langpack-o-matic:
status: New → Invalid

Is this still an issue? Please respond if you still experience this bug.

Changed in example-content (Ubuntu):
status: New → Incomplete
Changed in ubuntu-translations:
status: Confirmed → Incomplete
Changed in example-content (Ubuntu):
status: Incomplete → New
Gabor Kelemen (kelemeng) on 2011-09-14
Changed in ubuntu-translations:
status: Incomplete → Triaged
importance: Undecided → High
Changed in example-content (Ubuntu):
importance: Undecided → High
Changed in example-content (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package example-content - 46

---------------
example-content (46) precise; urgency=low

  * Updated translations, thanks Gabor Kelemen (lp: #441986)
  * debian/rules:
    - don't strip the translation by setting NO_PKG_MANGLE=1, this way
      the liveCD icons is translated
 -- Sebastien Bacher <email address hidden> Mon, 16 Apr 2012 18:28:38 +0200

Changed in example-content (Ubuntu):
status: Fix Committed → Fix Released
Gabor Kelemen (kelemeng) wrote :

Hm, I'm just wondering... was that NO_PKG_MANGLE=1 necessary? My understanding was that the .desktop file is stripped from translations by dh_translations (which is not used by e-c, so we are good), while the .mo files are removed from the package by pkgbinarymangler (which might come handy wrt to the CD-size limit).
I may be wrong, but don't want to be blamed for OVERSIZED CD's :).

Martin Pitt (pitti) wrote :

Yes, Gabor is correct. With NO_PKG_MANGLE we'll lose the possibility of translating e-c in Launchpad, and it's not necessary for inline translations in .desktop files.

David Planella (dpm) wrote :

Could someone please confirm whether:

a) the bug has been fixed
b) the issue in comment #8 has been addressed

Changed in ubuntu-translations:
status: Triaged → Incomplete
importance: High → Medium
Changed in ubuntu-translations:
status: Incomplete → New
summary: - Live CD "Examples" desktop item translations depended on having the PO
+ Live media"Examples" desktop item translations depended on having the PO
files
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/441986

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers