Impossible to delete files from examples folder

Bug #272099 reported by Wouter Stomp on 2008-09-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
example-content (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: example-content

When running from the live cd, it is impossible to remove individual files from the examples folder, it gives you 2(!) subsequent error messages. Oddly enough it is no problem at all to delete the complete examples folder. That doesn't make sense.

This is probably because the examples folder is actually a symlink to the actual examples folder somewhere else. Yet this gives very strange results in behaviour to the user. I think a solution for this would be to make a real examples folder on the users desktop containing symlinks to the example files.

-Zeus- (matthew-momjian) wrote :

That's correct, because it's a symlink, you can't remove the actual files because they're owned by root. invalidated.

Changed in example-content:
status: New → Invalid

Yes, that is exactly the technical cause of this bug. That is why I suggested making a real directory instead with individual symlinks for all the files.

Changed in example-content:
status: Invalid → New
-Zeus- (matthew-momjian) wrote :

That is a feature; if we were to make it not a symlink, we'd probably get bug reports about why we're not conserving space. resason stands; bug closed.

-Zeus- (matthew-momjian) wrote :

you can still delete the files, just you need to use sudo.

Changed in example-content:
status: New → Invalid

A directory and a few symlinks take up virtually no space, so that is no good reason not to do this. And you shouldn't need sudo to delete anything that is anywhere within your home directory, so reopening.

Changed in example-content:
status: Invalid → New
Daniel Holbach (dholbach) wrote :

You can delete the symlink, then purge the package. What's wrong with that approach?

I know you can do that, but most people don't know anything about packages or purging them and neither should they. Any content in the home directory should be under the control of the user and they should not need some developer specified way to delete certain files.

The solution I proposed in the first comment is easy and doesn't seem to have any negative consequences as far as I can see, so why not implement that?

Endolith (endolith) wrote :

You can delete the "Examples" symlink as a user, so what's the problem?

The problem is that the individual files, which appear within the users home directory, appear to be readonly and impossible to delete. The user should be in control of the files that appear within his home directory. And that you can't delete individual files but you can delete the whole folder doesn't make sense at all if you don't know the technical reasons for that.

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers