Add ogv (video) and oga (audio) as recognized extension for Ogg Theora and Ogg Vorbis, respectively

Bug #201291 reported by Fabián Rodríguez on 2008-03-12
46
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Medium
Daniel Hahler
audacity (Ubuntu)
Undecided
Unassigned
cheese (Ubuntu)
Undecided
Unassigned
example-content (Ubuntu)
Low
Unassigned
ffmpeg2theora (Ubuntu)
Undecided
Unassigned
mime-support (Ubuntu)
High
James Westby
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

From wikipedia:

"The term ‘Ogg’ is commonly used to refer to audio file format Ogg Vorbis, that is, Vorbis-encoded audio in the Ogg container. Previously, the .ogg file extension was used for any content distributed within Ogg, but as of 2007, the Xiph.Org Foundation requests that .ogg be used only for Vorbis due to backwards-compatibility concerns. The Xiph.Org Foundation decided to create a new set of file extensions and media types to describe different types of content such as .oga for audio, .ogv for video (including Theora), and .ogx for applications."
- http://en.wikipedia.org/wiki/Ogg

Original reference on xiph.org:
http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions

Most importantly, see this page for different patches related to adding
http://wiki.xiph.org/index.php/MIME-Migration

See IETF draft:
http://www.ietf.org/internet-drafts/draft-goncalves-rfc3534bis-01.txt

Other bugs about support for these extensions in specific applications should be linked / referenced in this bug.

Ryan Prior (ryanprior) wrote :

Following the upstream conventions should be important for us.

Fabián Rodríguez (magicfab) wrote :

Ryan: care to be more specific ?

Fabián Rodríguez (magicfab) wrote :

Nanley, posting a link without context of what you want / mean is not very helpful. What did you want to contribute to the bug by posting that ?

Daniel Hahler (blueyed) wrote :

I'm setting milestone ubuntu-8.04, but I fear this may become difficult to achieve until then.
Which packages need to get changed to recognize those (new) extensions? I could imagine kubuntu-defaultsettings is the one for Kubuntu, but I'm not sure.

Shirish Agarwal (shirishag75) wrote :

Fabian,
       From what I understand of the post/link that Nanley posted is that .ogg format confuses both people as well as computer & either doesn't have any idea if a given file is an audio file or an video file or an application file.

Hence to make it easier for users & computers Xiph came up with .oga (for audio) , .ogv for video & so on & so forth. So ubuntu should use the patches so all the apps. know when they come across those mime-types. Also would ensure take-up of the mime-types as well.

This is what u'r driving at as well, isn't it ?

Steve Langasek (vorlon) wrote :

Reassigning to the mime-support package, which contains /etc/mime.types and (I believe) is the common source for mapping extensions to mime types.

James Westby (james-w) wrote :

Hi,

I have prepared two patches for this bug, but I'm not
really happy with either of them. The first I attach here
changes the mime types to be those specified by
Xiph here.

  http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions

My problem with this patch is that it changes
the mime type off .ogg, and adds a bunch of other
mime types, so I think that we also need to upload
changes so that audio/ogg etc. have the correct
applications run. It may also be that some applications
also have to be fixed.

James Westby (james-w) wrote :

(sorry for the break, need to attach two things)

The second patch is the naive solution that just
associates the .oga etc. extensions with application/ogg,
which is what .ogg was associated with before.

However I think this makes it difficult to move forward
in such a way that we can set one application to
handle .oga and another for .ogv.

On balance I think the first is the correct thing to
do, but we will need some way of working out what
else needs to be fixed. Can anyone produce a list
of what needs to be fixed, or tell me a way to
produce one?

Thanks,

James

Changed in mime-support:
assignee: nobody → james-w
status: Confirmed → In Progress

On Fri, Mar 28, 2008 at 06:56:18PM -0000, James Westby wrote:

> I have prepared two patches for this bug, but I'm not
> really happy with either of them. The first I attach here
> changes the mime types to be those specified by
> Xiph here.

> http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions

> My problem with this patch is that it changes
> the mime type off .ogg, and adds a bunch of other
> mime types, so I think that we also need to upload
> changes so that audio/ogg etc. have the correct
> applications run. It may also be that some applications
> also have to be fixed.

Why change the mime type associated with .ogg, instead of just adding the
new mappings for .ogv and .oga?

IMHO, redefining the associated mime type for .ogg is out of scope for this
bug (and an inappropriate change post-beta), and just adding MIME mappings
for the new extensions should be sufficient.

On Sat, 2008-03-29 at 00:58 +0000, Steve Langasek wrote:
> On Fri, Mar 28, 2008 at 06:56:18PM -0000, James Westby wrote:
>
> > I have prepared two patches for this bug, but I'm not
> > really happy with either of them. The first I attach here
> > changes the mime types to be those specified by
> > Xiph here.
>
> > http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions
>
> > My problem with this patch is that it changes
> > the mime type off .ogg, and adds a bunch of other
> > mime types, so I think that we also need to upload
> > changes so that audio/ogg etc. have the correct
> > applications run. It may also be that some applications
> > also have to be fixed.
>
> Why change the mime type associated with .ogg, instead of just adding the
> new mappings for .ogv and .oga?

Well, that's what Xiph now says the mapping should be.

>
> IMHO, redefining the associated mime type for .ogg is out of scope for this
> bug (and an inappropriate change post-beta), and just adding MIME mappings
> for the new extensions should be sufficient.
>

I agree that's its not really a good idea.

Will keeping the original mapping lead to any headaches for us down the
line?

Thanks,

James

James Westby (james-w) wrote :

Hi,

Attached is the diff that keeps .ogg as application/ogg and
just adds the other ones specified by Xiph.

Should we revisit this just after Hardy and transition fully,
to give applications a time to update?

I'll subscribe the sponsors once Steve has had a chance
to look at it.

Thanks,

James

Hi James,

On Mon, Mar 31, 2008 at 10:20:52AM -0000, James Westby wrote:
> Attached is the diff that keeps .ogg as application/ogg and
> just adds the other ones specified by Xiph.

> Should we revisit this just after Hardy and transition fully,
> to give applications a time to update?

I think we have the same problem here of changing the associated mime type
at a point where mime-aware apps may not have an opportunity to catch up?:

@@ -386,7 +386,6 @@
 application/x-dvi dvi
 application/x-httpd-eruby rhtml
 application/x-executable
-application/x-flac flac
 application/x-font pfa pfb gsf pcf pcf.Z
 application/x-freemind mm
 application/x-futuresplash spl
@@ -467,6 +466,7 @@
 audio/32kadpcm
 audio/3gpp
 audio/basic au snd
+audio/flac flac
 audio/g.722.1
 audio/l16
 audio/midi mid midi kar

So I think it's better to omit this change as well and continue using
application/x-flac, rather than unsettle the mapping in the name of
standards.

> I'll subscribe the sponsors once Steve has had a chance
> to look at it.

I'd assumed that I would be sponsoring this directly once we reached a
conclusion, FWIW. :)

Steve Langasek (vorlon) wrote :

BTW,

On Sat, Mar 29, 2008 at 01:12:20AM -0000, James Westby wrote:

> Will keeping the original mapping lead to any headaches for us down the
> line?

No, it won't; we can change the mapping at any point in the future once
we're comfortable that the applications involved recognize the new mime
type (or that they will before the next release), and leaving the mapping
for those extensions as they are now keeps us consistent with previous
releases (i.e.: the transition requirements are the same whenever we make
the change).

James Westby (james-w) wrote :

Hi,

Thanks for catching flac, attached is a version that keeps this
the same.

Testing it shows that the new mimetypes are registered, but
I have no mailcap entries on my system for them, and soo "see"
doesn't do anything with them.

Should I add an entry to my todo list to update this package again
shortly after hardy, to give plenty of time for applications to catch up?

Thanks,

James

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mime-support - 3.39-1ubuntu1

---------------
mime-support (3.39-1ubuntu1) hardy; urgency=low

  * Change the mimetypes for Ogg and flac to those specified by
    Xiph at
    http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions
    (LP: #201291)
    - The only difference is that we keep .ogg as application/ogg,
      and .flac as application/x-flac rather than moving them to
      audio/ogg and audio/flac respectively to not break current
      applications. We may want to reconsider this once we are
      past Hardy.
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- James Westby <email address hidden> Mon, 31 Mar 2008 11:17:27 +0100

Changed in mime-support:
status: In Progress → Fix Released
Daniel Hahler (blueyed) wrote :

I'll add the relevant mime types to amaroks desktop files.

Changed in amarok:
assignee: nobody → blueyed
status: New → In Progress
Daniel Hahler (blueyed) wrote :

The patch for amarok has been added to bug 103227:
   * debian/patches/kubuntu_09_audio_mimetypes.diff:
     - Add mimetypes audio/flac and audio/ogg (LP: #201291)

Changed in amarok:
importance: Undecided → Medium
status: In Progress → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:1.4.9.1-0ubuntu2

---------------
amarok (2:1.4.9.1-0ubuntu2) hardy; urgency=low

  [ Daniel Hahler]
  * debian/patches/kubuntu_08_add_lastfm_recommended_radio.diff:
    Add lastfm recommended radio station (LP: #103227)
  * debian/patches/kubuntu_09_audio_mimetypes.diff:
    - Add mimetypes audio/flac and audio/ogg (LP: #201291)

  [ Harald Sitter ]
  * Unbreak manual media device configuration by enhancing
    kubuntu_08_luks_device_detection.diff (LP: #207704)

 -- Harald Sitter <email address hidden> Sat, 12 Apr 2008 13:47:12 +0200

Changed in amarok:
status: Triaged → Fix Released
Fabián Rodríguez (magicfab) wrote :

Reopening this as other affected packages still generate ogg files.

When adding ffmpeg2theora in "Also Affects" LP's own bug tracker is not recognized. I meant to link bug #201473 .

Fabián Rodríguez (magicfab) wrote :

Rhythmbox is also affected by this. I've filed a new bug (# 241973).

Fabián Rodríguez (magicfab) wrote :

Cheese is also affected by this, I've filed bug # 201291 .

Sebastien Bacher (seb128) wrote :

no need to have a rhythmbox bug there since an another one has been opened

Changed in rhythmbox:
importance: Undecided → Low
status: New → Invalid
Fabián Rodríguez (magicfab) wrote :

Correct, the Rhythmbox bug is Bug # 241973 . It auto-expired today, commented there to re-open it.

Oibaf (oibaf) wrote :

This is fixed since ffmpeg2theora-0.21-0.1 (intrepid.)

Changed in ffmpeg2theora:
status: New → Fix Released
Hew (hew) wrote :

Tested with cheese 2.24.0-0ubuntu1 and it's now producing .ogv files.

Changed in cheese:
status: New → Fix Released
Hew (hew) on 2008-09-26
Changed in example-content:
importance: Undecided → Low
status: New → Triaged
Daniel Holbach (dholbach) wrote :

Fixed in bzr. Will be uploaded shortly.

Changed in example-content:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package example-content - 33

---------------
example-content (33) intrepid; urgency=low

  * case_ubuntu_johnshopkins_v2.pdf: renamed file. It should be "Johns
    Hopkins". (LP: #243517)
  * oo-about-these-files.odt: "it's" -> "its". (LP: #223393)
  * oo-about-these-files.odt: removed reference to non-existing Edubuntu logo.
    (LP: #218842)
  * ubunt Sax.ogg: dropped.
  * UbuntuFreeCultureShowcase/patas_de_trapo.oga,
    UbuntuFreeCultureShowcase/StopMotionUbuntu.ogv: renamed to match new Ogg
    file name format. (LP: #201291)

 -- Daniel Holbach <email address hidden> Tue, 07 Oct 2008 08:41:53 +0200

Changed in example-content:
status: Fix Committed → Fix Released
khink (kees-fmf) wrote :

Could it be that this fix has not made it into the current package 2:1.4.10-0ubuntu3 for Intrepid?
Please see https://bugs.launchpad.net/ubuntu/+source/amarok/+bug/292562 for details.

Siegfried Gevatter (rainct) wrote :

Adding a bug task for Audacity, as it complains if you save something as ".ogm", telling you that the correct extension is ".ogg".

Harald Sitter (apachelogger) wrote :

Well. OGM != OGG OR OGA anyway ;-)

2008/11/2 Harald Sitter <email address hidden>:
> Well. OGM != OGG OR OGA anyway ;-)

Oops, sorry. But anyway, the same happens with .oga :).

Jeldert (jeldert) wrote :

Audacity 1.3.5 gives a warning when opening an .oga file. It says:

"Audacity had to make a guess at the type of file. The Audio may be bogus.
If the audio is bogus, try renaming the file so that it has the correct extension before opening it."

Also, when saving Audacity complains that Ogg Vorbis files normally end in .ogg.

Please note that the first warning (bogus audio) does not occur with Audacity 1.3.6, but the second warning is still present.

Changed in audacity:
status: New → Confirmed
Javier Jardón (jjardon) wrote :

Kubuntu 8.10 with KDE 4.2beta2 (4.1.85)

Not icon for ogv files in Dolphin. If I change the extension to ogg, the correct icon appear.

ricardisimo (ricardisimo) wrote :

I also get this:

"Audacity had to make a guess at the type of file. The Audio may be bogus.
If the audio is bogus, try renaming the file so that it has the correct extension before opening it."

... but only with flac files that I generated from m4as with soundconverter. I believe I also tagged them all with EasyTag, so conceivably the flac tags are confusing Audacity. No problem with flac files ripped directly from my CDs, by the way.

Is there any test I can perform for you? Thanks for everything that you do.

Benjamin Drung (bdrung) wrote :

The bug is fixed in audacity 1.3.9-3. It can open .oga files. It is correct, that Audacity complains that Ogg Vorbis files normally end in .ogg on saving. According to [1] it is recommend to use .ogg for Vorbis: "Vorbis and Speex may use .oga, but it is not the prefered method of distributing these files because of backwards-compatibility issues. "

[1] http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions#.ogg_-_audio.2Fogg

Changed in audacity (Ubuntu):
status: Confirmed → Fix Released
Lars Noodén (larsnooden) wrote :

This bug is still present in Karmic Koala.

$ apt-cache policy amarok
amarok:
  Installed: 2:2.2.0-0ubuntu2
  Candidate: 2:2.2.0-0ubuntu2
  Version table:
 *** 2:2.2.0-0ubuntu2 0
        500 http://fi.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"

Lars Noodén (larsnooden) wrote :

Grabbing this video,
http://people.xiph.org/~greg/video/ytcompare/bbb_theora_325kbit.html

it plays ok in vlc but not in amarok:

$ amarok bbb_theora_325kbit.ogv
Amarok is already running!
kmimetype filetype guessing failed for /home/foo/Documents/bbb_theora_325kbit.ogv

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers