Exaile doen't start after last upgrade

Bug #714484 reported by Nikolay Morozov on 2011-02-07
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Exaile
Fix Released
Critical
Johannes Sasongko
exaile (Debian)
Fix Released
Unknown
exaile (Ubuntu)
High
Andrew Starr-Bochicchio
Natty
High
Andrew Starr-Bochicchio

Bug Description

Binary package hint: exaile

Clear instalation of Xubutu 11.04 alpha, Update-manager install all upgrades and then try to start exaile after splash screen it crashes.

Console Log

/usr/share/themes/MurrinaBlu/gtk-2.0/gtkrc:86: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/MurrinaBlu/gtk-2.0/gtkrc:134: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/MurrinaBlu/gtk-2.0/gtkrc:187: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/MurrinaBlu/gtk-2.0/gtkrc:243: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/MurrinaBlu/gtk-2.0/gtkrc:288: Murrine configuration option "gradients" is no longer supported and will be ignored.
INFO : Loading Exaile 0.3.2.0...
INFO : Loading settings...
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
INFO : Loading plugins...
Traceback (most recent call last):
  File "/usr/lib/exaile/xl/plugins.py", line 124, in enable_plugin
    plugin.enable(self.exaile)
  File "/usr/share/exaile/plugins/lyricwiki/__init__.py", line 23, in enable
    raise NotImplementedError('BeautifulSoup is not available.')
NotImplementedError: BeautifulSoup is not available.
WARNING : Unable to enable plugin lyricwiki
INFO : Loading collection...
INFO : Loading devices...
INFO : Loading interface...
INFO : Loading main window...
INFO : Connecting main window events...
INFO : Loading panels...
INFO : Connecting panel events...
Traceback (most recent call last):
  File "/usr/lib/exaile/exaile.py", line 52, in <module>
    main()
  File "/usr/lib/exaile/exaile.py", line 49, in main
    exaile = main.Exaile()
  File "/usr/lib/exaile/xl/main.py", line 96, in __init__
    self.__init()
  File "/usr/lib/exaile/xl/main.py", line 220, in __init
    self.gui = xlgui.Main(self)
  File "/usr/lib/exaile/xlgui/__init__.py", line 124, in __init__
    self.main._connect_panel_events()
  File "/usr/lib/exaile/xlgui/main.py", line 927, in _connect_panel_events
    panel.connect('append-items', lambda panel, items, sort=sort:
TypeError: <PlaylistsPanel object at 0x9d66b1c (xlgui+panel+playlists+PlaylistsPanel at 0x9cc9890)>: unknown signal name: append-items

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: exaile 0.3.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
Uname: Linux 2.6.38-2-generic i686
Architecture: i386
Date: Mon Feb 7 13:06:07 2011
EcryptfsInUse: Yes
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110201.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: exaile

Nikolay Morozov (nmorozov) wrote :
NGAGE13 (ngage13) wrote :

I have this bug in Ubuntu 11.04(GNOME).

Gillen Daniel (gillen-dan) wrote :

Same issue here. Fresh Xubuntu 11.04 amd64 alpha2 install with latest updates (until 09.02.2011).

Johannes Sasongko (sjohannes) wrote :

I don't know if this is an upstream bug, but I'm reporting there as well to get it looked at before 0.3.2.1.

Changed in exaile:
importance: Undecided → Critical
milestone: none → 0.3.2.1
status: New → Triaged
status: Triaged → New
Changed in exaile (Ubuntu):
importance: Undecided → High
status: New → Confirmed

I just reproduced this with rev 3793 of lp:exaile. The traceback is essentially the same, some line numbers have changed:

Traceback (most recent call last):
  File "/home/andrew/usr/lib/exaile/exaile.py", line 61, in <module>
    main()
  File "/home/andrew/usr/lib/exaile/exaile.py", line 58, in main
    exaile = main.Exaile()
  File "/home/andrew/usr/lib/exaile/xl/main.py", line 118, in __init__
    self.__init()
  File "/home/andrew/usr/lib/exaile/xl/main.py", line 248, in __init
    self.gui = xlgui.Main(self)
  File "/home/andrew/usr/lib/exaile/xlgui/__init__.py", line 115, in __init__
    self.main._connect_panel_events()
  File "/home/andrew/usr/lib/exaile/xlgui/main.py", line 294, in _connect_panel_events
    panel.connect('append-items', lambda panel, items, sort=sort:
TypeError: <PlaylistsPanel object at 0xaa3939c (xlgui+panel+playlists+PlaylistsPanel at 0xabcf390)>: unknown signal name: append-items

Changed in exaile:
status: New → Confirmed
Johannes Sasongko (sjohannes) wrote :

I'm not getting this bug in ArchLinux (0.3.2 and trunk), and reportedly it's fine in Fedora as well (0.3.2). Yesterday I tried stock Ubuntu Netbook and it worked (trunk).

So... not sure; issue with the specific PyGObject version maybe? Are you able to downgrade pygobject to see if that's the problem?

Versions in natty:

python-gobject:
  Installed: 2.27.0+git20110131-0ubuntu6
  Candidate: 2.27.0+git20110131-0ubuntu6

python:
  Installed: 2.7.1-0ubuntu5
  Candidate: 2.7.1-0ubuntu5

reacocard (reacocard) wrote :

For reference, the current arch versions (which do NOT reproduce the problem) are:

pygobject: 2.26.0-2
python2: 2.7.1-4

So it seems possible this is a bug in the prerelease version of (py)gobject that natty is using.

fidencio (fidencio) wrote :

I can't reproduce on Fedora and I'm using:

pygobject: 2.21.5-3
python2: 2.7.8

As Aren said, probably this is a bug in prerelease version of (py)gobject.

--
Fabiano Fidêncio

Johannes Sasongko (sjohannes) wrote :

I suspect this has something to do with how we implement the PlaylistsPanel class: it inherits from 2 GObject classes, and the append-items signal comes from the second parent.

IIRC GObject itself doesn't support multiple inheritance, so I'm absolutely confused why this works/worked.

I'm attaching a test case that can be used to check if this is indeed the problem. If it is, we'll have to ask the (Py)GObject people whether it's intended. Can anyone on natty run this and see whether you get an error (it prints "OK" if everything works)?

On Thu, Feb 10, 2011 at 2:03 PM, Johannes Sasongko <email address hidden> wrote:
> I'm attaching a test case that can be used to check if this is indeed
> the problem. If it is, we'll have to ask the (Py)GObject people whether
> it's intended. Can anyone on natty run this and see whether you get an
> error (it prints "OK" if everything works)?

On Maverick:

$ python gobject-multi-inherit.py
OK

On Natty:

$ python gobject-multi-inherit.py
Traceback (most recent call last):
  File "gobject-multi-inherit.py", line 15, in <module>
    c.connect('b', lambda *x: None)
TypeError: <C object at 0xb754989c (__main__+C at 0x8834200)>: unknown
signal name: b

Johannes Sasongko (sjohannes) wrote :

I'm posting a question in the PyGTK mailing list, asking whether the error is expected.
http://www.daa.com.au/pipermail/pygtk/2011-February/019394.html

Johannes Sasongko (sjohannes) wrote :

So far no responses in the pygtk list.

Andrew / others, can you test the 2 new attached files (#2 and #3) on natty? They are slightly modified versions of the previous attachment; just want to see if one of them can be used as a workaround.

Johannes Sasongko (sjohannes) wrote :
Book 'em Dano (heymrdjd) wrote :
Download full text (4.6 KiB)

Exaile is not working for me after a fresh install of Xubuntu Natty Alpha 2; here's some debug info:

15:27:05,412:INFO : Loading Exaile 0.3.2.0... (xl.main)
15:27:05,413:INFO : Loading settings... (xl.main)
15:27:05,524:DEBUG : Provider tags registered for service covers (xl.providers)
15:27:05,524:DEBUG : Provider localfile registered for service covers (xl.providers)
15:27:05,532:DEBUG : Normal playback engine selected. (xl.player)
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
15:27:05,725:DEBUG : Provider tracknumber registered for service tag_formatting (xl.providers)
15:27:05,726:DEBUG : Provider discnumber registered for service tag_formatting (xl.providers)
15:27:05,726:DEBUG : Provider artist registered for service tag_formatting (xl.providers)
15:27:05,726:DEBUG : Provider __length registered for service tag_formatting (xl.providers)
15:27:05,727:DEBUG : Provider __rating registered for service tag_formatting (xl.providers)
15:27:05,727:DEBUG : Provider __last_played registered for service tag_formatting (xl.providers)
15:27:05,727:DEBUG : Provider filename registered for service tag_formatting (xl.providers)
15:27:05,875:DEBUG : ~/.exaile/music.db did not exist, old exaile version not detected (migration_200907100931)
15:27:05,877:DEBUG : Will not migrate and overwrite data. (migration_200907100931)
15:27:05,879:INFO : Loading plugins... (xl.main)
15:27:05,885:DEBUG : Loaded plugin shoutcast (xl.plugins)
15:27:05,886:DEBUG : Loaded plugin lastfmcovers (xl.plugins)
15:27:05,888:DEBUG : Provider lastfm registered for service dynamic_playlists (xl.providers)
15:27:05,889:DEBUG : Loaded plugin lastfmdynamic (xl.plugins)
15:27:05,890:DEBUG : Loaded plugin xkeys (xl.plugins)
Traceback (most recent call last):
  File "/usr/lib/exaile/xl/plugins.py", line 124, in enable_plugin
    plugin.enable(self.exaile)
  File "/usr/share/exaile/plugins/lyricwiki/__init__.py", line 23, in enable
    raise NotImplementedError('BeautifulSoup is not available.')
NotImplementedError: BeautifulSoup is not available.
15:27:05,929:WARNING : Unable to enable plugin lyricwiki (xl.plugins)
15:27:05,930:DEBUG : Exception caught!
Traceback (most recent call last):
  File "/usr/lib/exaile/xl/plugins.py", line 124, in enable_plugin
    plugin.enable(self.exaile)
  File "/usr/share/exaile/plugins/lyricwiki/__init__.py", line 23, in enable
    raise NotImplementedError('BeautifulSoup is not available.')
NotImplementedError: BeautifulSoup is not available.
 (xl.plugins)
15:27:05,944:DEBUG : Provider cd registered for service hal (xl.providers)
15:27:05,945:DEBUG : Loaded plugin cd (xl.plugins)
15:27:05,947:DEBUG : Provider rgvolume registered for service stream_element (xl.providers)
15:27:05,947:DEBUG : Provider rglimiter registered for service stream_element (xl.providers)
15:27:05,948:DEBUG : Loaded plugin replaygain (xl.plugins)
15:27:05,958:DEBUG : Loaded plugin notifyosd (xl.plugins)
15:27:05,959:INFO : Loading collection... (xl.main)
15:27:05,983:INFO : Loading devices... (xl.main)
15:27:05,985:DEBUG : Provider __local registered for service lyrics (xl.providers)
15:27:05,985:IN...

Read more...

tags: added: apport-collected

Architecture: i386
DistroRelease: Ubuntu 11.04
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110210)
Package: exaile 0.3.2.0-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Tags: natty
Uname: Linux 2.6.38-3-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

apport information

Gillen Daniel (gillen-dan) wrote :

Tested on natty:

$ python gobject-multi-inherit-2.py
Traceback (most recent call last):
  File "gobject-multi-inherit-2.py", line 14, in <module>
    c.connect('b', lambda *x: None)
TypeError: <C object at 0xcd15f0 (__main__+C at 0xd1f440)>: unknown signal name: b

------

$ python gobject-multi-inherit-3.py
OK

On natty:

$ apt-cache policy python-gobject
python-gobject:
  Installed: 2.27.0+git20110131-0ubuntu6
  Candidate: 2.27.0+git20110131-0ubuntu6
  Version table:
 *** 2.27.0+git20110131-0ubuntu6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

$ python gobject-multi-inherit-3.py
OK

Johannes Sasongko (sjohannes) wrote :

Thanks everyone who tested. I've committed something resembling #3, but please check if it works. The patch is at http://bazaar.launchpad.net/~exaile-devel/exaile/0.3.2.x/diff/3452

By the way, this is the last bug blocking 0.3.2.1. Once we get a confirmation of the fix, we should be good for a release.

Changed in exaile:
assignee: nobody → Johannes Sasongko (sjohannes)
status: Confirmed → Fix Committed
Gillen Daniel (gillen-dan) wrote :

The patch you supplied works for me on natty. Thx

reacocard (reacocard) on 2011-02-13
Changed in exaile:
status: Fix Committed → Fix Released
Changed in exaile (Ubuntu Natty):
status: Confirmed → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package exaile - 0.3.2.1-0buntu1

---------------
exaile (0.3.2.1-0buntu1) natty; urgency=low

  * New upstream release (LP: #714484, LP: #630221).
  * Drop debian/patches/jamendo_plugin_fix.diff,
    fixed upstream.
  * debian/patches/10_ubuntu_defaults.diff:
   - Don't enable shoutcast plugin.
  * debian/exaile.install: Don't install shoutcast plugin.
 -- Andrew Starr-Bochicchio <email address hidden> Sun, 13 Feb 2011 12:33:27 -0500

Changed in exaile (Ubuntu Natty):
status: In Progress → Fix Released
Changed in exaile (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.