Ubuntu

closing last playlist tab makes it unable to display any playlist again

Reported by Wit Wilinski on 2007-07-04
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exaile
Undecided
Adam Olsen
exaile (Ubuntu)
Low
Unassigned

Bug Description

I encountered a problem, where the current playlist (queue of tracks to be played) disappears and does not appear again. I managed to close the tab with last playlist, then - even after exaile restart - playlist on the right side of the window would not appear (there was empty space instead of playlist widget).

This could have something to do with writing translated(!) colum names for column widths to configuration file [i'm using exaile with pl_PL locales].

I got back to a useful state after removing all translated lines from configuration file, though that might not be the right reason...

Wit Wilinski (wit-wilinski) wrote :

After searching through exaile Trac system, looks that the reason is:
http://www.exaile.org/trac/ticket/631

William Grant (wgrant) on 2007-07-05
Changed in exaile:
importance: Undecided → Low
status: New → Confirmed
luca dep (makaai) wrote :

sorry,I didn't undestand how you've checked the problem...I encountered the same bug.

Wit Wilinski (wit-wilinski) wrote :

This bug has been fixed in SVN, debs available here: http://syzygy42.tuxfamily.org/dists/feisty/exaile-svn/

Christian Reis (kiko) on 2007-07-26
Changed in exaile:
importance: Undecided → Unknown
status: New → Unknown
Changed in exaile:
status: Unknown → New
Adam Olsen (arolsen) on 2007-08-28
Changed in exaile:
assignee: nobody → arolsen
importance: Unknown → Critical
status: New → Fix Committed
Farliec (farliec) wrote :

I encountered the same bug with 0.2.10 Ubuntu version.
I think I tried to change columns place, and the playlist disapeared.
I haven't test the SVN version 'cause the link given by Wit is dead.

Laryllan (laryllan) wrote :

I can confirm this bug using Ubuntu Exaile version 0.2.11.1.

Christian Reis (kiko) wrote :

I know there was an existing Exaile bug in Trac for this, but since Exaile moved to Launchpad I have been unable to find out what bug that is. If someone can find it and either duplicate or set the status correctly, I'd appreciate that.

Changed in exaile:
status: New → Fix Released
Przemysław Kulczycki (azrael) wrote :

I think it's bug 172318 - playlist empty when adding songs.
This bug is present on Hardy and it's importance should be raised because it makes Exaile unusable. Installing Exaile 0.2.13 fixed the problem. Probably this version should be backported to Hardy.

InsClusoe (insclusoe) wrote :

Hi,
If this is still needed, I have the time to do it but don't quite know what exactly needs to be done. I saw the chain of bugs that have been listed on launchpad and that didn't help me much either.

Am new but am ready to do it with some guidance. A changelog at least to help me backport.

Thanks.

Steve Dodier-Lazaro (sidi) wrote :

You have to be a MOTU and do a SRU if you want to backport, InsClusoe.

InsClusoe (insclusoe) wrote :

Steve, Thanks for your comment.

I don't understand the process listed here https://wiki.ubuntu.com/StableReleaseUpdates and https://help.ubuntu.com/community/UbuntuBackports

I can make the changes and give it to a MOTU/exaile developer. They can take it from there if interested. It probably depends on how many users are on Hardy and want to install a backport rather than upgrade to 0.2.14 which is noticeably better. I just thought this is probably a good opportunity to get acquainted with the code.

InsClusoe (insclusoe) wrote :

I can possibly put it on PPA.

I think you should check Exaile's PPA. If they don't have 0.2.14 for Hardy
I'm sure they'll be happy to have it packaged.

Changed in exaile (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers