stuck retrieving emails from IMAP

Bug #880657 reported by ausboffin on 2011-10-24
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

Evolution starts fine, collects email messages. On subsequent checking of server get stuck i "fetching mail", I am unable to cancel this nor able to close evolution. Other accounts on POP servers not affected

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: evolution 3.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Mon Oct 24 16:48:20 2011
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: evolution
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (9 days ago)

ausboffin (sdanaesthesia) wrote :

Could you please try changing the account used to the IMAP+ protocol instead of IMAP, to see if this helps? Thanks.

Changed in evolution (Ubuntu):
status: New → Incomplete
summary: - Evolution crashes following startup, only affecting IMAP Server.
+ stuck retrieving emails from IMAP

Thanks,

Will change settings to IMAP+.
Will observe and report if problem returns.

All the best,

Steve
On Tue, 2011-10-25 at 01:25 +0000, Mathieu Trudel-Lapierre wrote:
> Could you please try changing the account used to the IMAP+ protocol
> instead of IMAP, to see if this helps? Thanks.
>
> ** Changed in: evolution (Ubuntu)
> Status: New => Incomplete
>
> ** Summary changed:
>
> - Evolution crashes following startup, only affecting IMAP Server.
> + stuck retrieving emails from IMAP
>

Launchpad Janitor (janitor) wrote :

[Expired for evolution (Ubuntu) because there has been no activity for 60 days.]

Changed in evolution (Ubuntu):
status: Incomplete → Expired
Koopee (koopee1234) wrote :

I'm experiencing the same problem. Did this IMAP+ thing help?

Changed in evolution (Ubuntu):
status: Expired → New
Koopee (koopee1234) wrote :

Seems that changing IMAP+ have corrected the problem. Thanks Mathieu!

Koopee (koopee1234) wrote :

Using IMAP+. Fetching mails still freezes.

Changed in evolution (Ubuntu):
status: New → Confirmed
Wdw-leo (wdw-leo) wrote :

Same problem here.

apinunt (apinunt) wrote :

Same here too, beginning after an upgrade which changed Evolution to version 3.6.2

I have about 8 different email accounts and found that the numerous "fetching mail" and "retrieving POP summary" notifications at the bottom of the screen which keep me from viewing my mail can be eliminated by clicking on the "Send/Receive" down arrow, and pointing, but not clicking on any of the choices it provides. All the "fetching mail" and/or "retrieving POP summary" messages then disappear and I can then view my emails, and I can retrieve new emails by using "Send/Receive" and clicking on each account individually. The accounts are set up with a staggered interval of time between downloads in an attempt to not try and access them simultaneously.

My Yahoo account is and always has been set to IMAP+.

Ditto for me, problems as described above

Worse yet, it's crashing evolution. When this "retrieving POP Summary" is grinding away, I am totally locked out of Evolution.
I try to cancel the operation - no dice.
Also, I log into a terminal and try to kill evolution - no dice as well, except that, after about 5 - 10 minutes the kill command
takes effect.

apinunt (apinunt) wrote :

I've had to stop retrieving email automatically, and manually request the retrieval of each account one at a time to avoid locking up the email retrieval, but evolution still crashes randomly and requires restarting.

JL (ozrattler) wrote :

Installed Mint15_64 and Evolution 3.6.4 and similar problem. Evolution will get stuck trying to retrieve an email. Killing process does not resolve the problem as the empty window persists - by that I mean the emails, icons and other functions disappear but the overall window persists.

Only way I clear it is to log out and back in from the Mint session completely. It is though related to IMAP and a similar problem occurs with sync of calendars.

Apologies, but I do not see how to swap protocol to IMAP+ = could be me missing it as it is late.............

Thanks!

Julien Olivier (julo) wrote :

This problem appeared for me on Ubuntu Trusty with a GMail account created using Gnome Online Accounts. The same account worked flawlessly on previous version of Evolution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers