clock applet does not load evolution calendars

Bug #84554 reported by Áron Sisak on 2007-02-11
12
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-applets

My calendars defined in Evolution are shown properly when clicking on the clock applet.
However, if I double-click on a date Evolution does not start (as earlier).

Áron Sisak (asisak) on 2007-02-11
Changed in gnome-applets:
importance: Undecided → Low
status: Unconfirmed → Needs Info
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use?

Changed in gnome-applets:
assignee: nobody → desktop-bugs
Revision history for this message
Áron Sisak (asisak) wrote :

Oh, sorry. Using Ubuntu Feisty x86, gnome-applets 2.17.1-0ubuntu5, evolution 2.9.6-0ubuntu1

Revision history for this message
Sebastien Bacher (seb128) wrote :

"evolution calendar:///?startdate=..." doesn't work correctly neither, that's an evolution bug and I've forwarded it upstream: http://bugzilla.gnome.org/show_bug.cgi?id=407104

Changed in gnome-panel:
status: Needs Info → Confirmed
Changed in evolution:
status: Unknown → Unconfirmed
Revision history for this message
Gert Kulyk (gkulyk) wrote :

What is very interesting, if you uncheck in gconf "apps/evolution/shell/skip_warning_dialog" evolution will come up (not with the calendar-component, but will come up). If this option is set, clicking twice on date results in evolution beeing started, but with no gui, it seems (at least there is a process running).

Revision history for this message
Gert Kulyk (gkulyk) wrote :

calendar:/// uri seems not to be recognized by new evolution version. Something seems to be wrong with the GNOME_Evolution_Calendar.server-file. Removing the following:

<oaf_attribute name="evolution:uri_schemas" type="stringv">
   <item value="calendar"/>
</oaf_attribute>

and restarting bonobo-activation-server makes the clock-panel-applet open the calendar again (and evolution calendar:// - magic on command-line also works again).

Revision history for this message
Sebastien Bacher (seb128) wrote :

This upload fixes the bug:

 evolution (2.10.1-0ubuntu2) feisty; urgency=low
 .
   * debian/patches/90_list_arabic_encoding.patch:
     - change by Martin J�rgens to list arabic encoding (Ubuntu: #82322)
   * debian/patches/91_revert_uri_change.patch:
     - revert the change that broke the command line calendar opening
       (Ubuntu: #84554)

Changed in evolution:
status: Confirmed → Fix Released
Changed in evolution:
status: Unconfirmed → Confirmed
Changed in evolution:
status: Confirmed → Fix Released
Changed in evolution:
status: Fix Released → Confirmed
Changed in evolution:
status: Confirmed → Fix Released
Changed in evolution:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.