Bogofilter plugin doesn't work with bogofilter-sqlite

Bug #81581 reported by Mariano Draghi on 2007-01-26
4
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

I'm not sure if this should be reported as an Evolution bug or a bogofilter one. I installed bogofilter in my laptop (with a fresh install of Edgy) in order to use it with Evolution. I don't know exactly how, I ended up with bogofilter-sqlite, the sqlite version, whose binary is /usr/bin/bogofilter-sqlite.

I spent hours trying to find out why on earth Evolution was ignoring bogofilter altogether (i.e., mi ~/.bogofilter/wordlist.db won't be touched even when I marked mail as junk manually), until I found out running Evolution from the command line that it was expecting to find "/usr/bin/bogofilter".

I made a link from bogofilter-sqlite to bogofilter and everything seems to work, but:
 - Evolution should inform with an alert, warning or something that a regular user can see that a file is not being found, instead of failing silently;
 - Either Evolution's bogofilter plugin should be smarter about which program to run (i.e., it should know that bogofilter-sqlite exists), or if bogofilter-sqlite is meant to be a replacement for bogofilter, the installer should create the corresponding link (actually, I can do "man bogofilter" but not "man bogofilter-sqlite" for instance, so it seems that not putting a link from bogofilter-sqlite to bogofilter is a bug anyway)

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Mariano Draghi (chaghi) wrote :

I tried to reproduce this issue with Gutsy Bibbon Tribe 5 LiveCD.

The issue regarding bogofilter vs. bogofilter-sqlite is resolved: I enabled the Universe repository, installed bogofilter-sqlite, uninstalled bogofilter, and checked that the proper binary is created in /usr/bin/bogofilter, and that Evolution still works.

Anyway, the Evolution junk filtering in Gutsy is totally broken (at least from the LiveCD). Trying to test this specific issue, I was bitten by these bugs:

 * Gutsy installs bogofilter by default. In Evolution, under Edit -> Preferences -> Plugins, BOTH bogofilter AND spamassassin are enabled by default, even though spamassassin is not installed (see bug #950337)

 * Even if bogofilter is enabled in the Plugins menu, the junk filter won't work until the user go to Edit -> Preferences -> Mail Preferences -> Junk tab, and selects a "Default junk plugin". I think this is an Ubuntu specific issue (see #127530). It's not very clear the double configuration (both Plugins AND Preferences) needed to get the junk filter working.

 * Even if there's no Default junk plugin selected in the preferences, Evolution lets the user mark messages as junk / not-junk, which is totally silly because it's not "learning".

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

I believe this bug is fixed in Hardy:
- Bogofilter is installed by default and is used as junk plugin
- spamassassin is available as a plugin but not installed as a package, which is not an issue since Evolution tells you when you want to change the default junk plugin that binaries are missing

Please confirm it is closed, so I can mark the bug as Fix released. There are still bugs about junk filtering, so it would be good to clean things up around this. Thanks!

Revision history for this message
Mariano Draghi (chaghi) wrote :

I can confirm that the bug is fixed in Hardy.

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

Thanks.

Changed in evolution:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers