No new mail in evolution imap

Bug #81524 reported by Ruben Vermeersch on 2007-01-25
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
High
evolution (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Starting two days ago (Jan 23), I don't see any new mails on my IMAP account in evolution. Opening the account with mutt or horde does show the new mails. Obviously, this reduces the usefulness of evolution's mailing component to zero.

This is on Ubuntu Feisty.

evolution 2.9.6-0ubuntu1
evolution-data-server 1.9.6.1-0ubuntu1

Ruben Vermeersch (ruben) on 2007-01-25
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → High
status: Unconfirmed → Confirmed
Changed in evolution:
status: Unknown → Confirmed
Ondřej Surý (ondrej) wrote :
Download full text (3.8 KiB)

I can confirm that.

My IMAP server is Cyrus 2.2 (both of them).

I tried removing and adding account in Evolution, tried creating new local account to start with empty Evolution settings. Nothing helped.

Thunderbird is just fine.

What I was able to get from CAMEL_VERBOSE_DEBUG is that sometimes it gets some error message (See last line), but I am not sure if it's connected to bad SELECT command processing.

sending : B00113 SELECT Done
received: * FLAGS (\Answered \Flagged \Draft \Deleted \Seen Junk $Label1 $Label2 $Label3 $Label4 $Label5 NonJunk)
received: * OK [PERMANENTFLAGS (\Answered \Flagged \Draft \Deleted \Seen Junk $Label1 $Label2 $Label3 $Label4 $Label5 NonJunk \*)]
received: * 337 EXISTS
received: * 0 RECENT
received: * OK [UIDVALIDITY 1129058136]
received: * OK [UIDNEXT 339]
received: B00113 OK [READ-WRITE] Completed
sending : B00114 FETCH 335 UID
received: * 335 FETCH (UID 336)
received: B00114 OK Completed (0.000 sec)
sending : B00115 UID FETCH 337:* (FLAGS RFC822.SIZE INTERNALDATE BODY.PEEK[HEADER.FIELDS (DATE FROM TO CC SUBJECT REFERENCES IN-REPLY-TO MESSAGE-ID MIME-VERSION CONTENT-TYPE X-MAILING-LIST X-LOOP LIST-ID LIST-POST MAILING-LIST ORIGINATOR X-LIST SENDER RETURN-PATH X-BEENTHERE )])
received: B00115 BAD Invalid field-name in UID Fetch BODY.PEEK[HEADER.FIELDS

***
INBOX "SELECT" command runs just fine:

Thread b1c03b90 >
CamelStore('imap://ondrej%<email address hidden>/;offline_sync;check_all;command=ssh%20-C%20-l%20%25u%20%25h%20exec%20/usr/sbin/imapd;use_ssl=always;use_lsub'):get_folder('INBOX', 0) = 0x8500600
< b1c03b90 >
sending : B00116 SELECT INBOX
received: * FLAGS (\Answered \Flagged \Draft \Deleted \Seen NonJunk $MDNSent Junk $Label1 $Label2 $Label3 $Label4 $Label5 $Forwarded)
received: * OK [PERMANENTFLAGS (\Answered \Flagged \Draft \Deleted \Seen NonJunk $MDNSent Junk $Label1 $Label2 $Label3 $Label4 $Label5 $Forwarded \*)]
received: * 9351 EXISTS
received: * 0 RECENT
received: * OK [UNSEEN 9351]
received: * OK [UIDVALIDITY 1129057094]
received: * OK [UIDNEXT 39368]
received: B00116 OK [READ-WRITE] Completed

*** Now it fetches UID ofselected message ***

sending : B00117 FETCH 9296 UID
received: * 9296 FETCH (UID 39212)
received: B00117 OK Completed (0.000 sec)

*** Now it tries to fetch some parts of that message ***

sending : B00118 UID FETCH 39213:* (FLAGS RFC822.SIZE INTERNALDATE BODY.PEEK[HEADER.FIELDS (DATE FROM TO CC SUBJECT REFERENCES IN-REPLY-TO MESSAGE-ID MIME-VERSION CONTENT-TYPE X-MAILING-LIST X-LOOP LIST-ID LIST-POST MAILING-LIST ORIGINATOR X-LIST SENDER RETURN-PATH X-BEENTHERE )])
received: B00118 BAD Invalid field-name in UID Fetch BODY.PEEK[HEADER.FIELDS
Thread b1c03b90 >

*** Finaly it get message from cache ***

CamelFolder:get_message('INBOX', '39181') =
class: CamelMimeMessage
mime-type: multipart/mixed; boundary="----_=_NextPart_001_01C73ED8.F9E37517"
content class: CamelMultipart
content mime-type: multipart/mixed; boundary="----_=_NextPart_001_01C73ED8.F9E37517"
  class: CamelMimePart
  mime-type: multipart/alternative; boundary="----_=_NextPart_002_01C73ED8.F9E37517"
  content class: CamelMultipart
  content mime-type: multipart/alternative; boundary="----_=_N...

Read more...

Sebastien Bacher (seb128) wrote :

does using the option to get all the mails header from the imap account configuration option dialog make it work correctly for you?

Ondřej Surý (ondrej) wrote :

It does (just read bug in upstream bugzilla).

On Mon, 2007-01-29 at 13:10 +0000, Sebastien Bacher wrote:
> does using the option to get all the mails header from the imap account
> configuration option dialog make it work correctly for you?

As Ondřej pointed out, that does seem to solve the problem (just to
confirm).

I did seem to have to restart Evolution, however, before seeing new
emails again. That may not have been necessary; perhaps I just didn't
wait long enough...

Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in evolution:
status: Confirmed → Fix Committed
Changed in evolution:
status: Confirmed → In Progress
Nathaniel McCallum (nmccallum) wrote :

This is only partially fixed upstream. I am still having the problem. CAMEL_VERBOSE_DEBUG gives me this:
sending : A00033 SELECT INBOX
received: * 1353 EXISTS
received: * 0 RECENT
received: * OK [UIDVALIDITY 1157468607] UID validity status
received: * OK [UIDNEXT 5098] Predicted next UID
received: * FLAGS (Junk $Label1 $Label2 $Label3 $Label4 $Label5 $Forwarded NonJunk $MDNSent \Answered \Flagged \Deleted \Draft \Seen)
received: * OK [PERMANENTFLAGS (Junk $Label1 $Label2 $Label3 $Label4 $Label5 $Forwarded NonJunk $MDNSent \* \Answered \Flagged \Deleted \Draft \Seen)] Permanent flags
received: * OK [UNSEEN 15] first unseen message in /var/spool/mail/num
received: A00033 OK [READ-WRITE] SELECT completed
sending : A00034 UID FETCH 1:* (FLAGS RFC822.SIZE INTERNALDATE BODY.PEEK[HEADER.FIELDS (DATE FROM TO CC SUBJECT REFERENCES IN-REPLY-TO MESSAGE-ID MIME-VERSION CONTENT-TYPE X-MAILING-LIST X-LOOP LIST-ID LIST-POST MAILING-LIST ORIGINATOR X-LIST SENDER RETURN-PATH X-BEENTHERE )])
received: A00034 BAD Syntax error in header fields

I don't know what the mail server is, but it does work in every other mail client.

Sebastien Bacher (seb128) wrote :

Nathaniel, did you try the upstream SVN or packages patched? If you still have the problem with those could you comment on the ustream bug?

Nathaniel McCallum (nmccallum) wrote :

I looked through the SVN log and nothing has changed since the last patch. I commented on upstream.

celil (dzhelil-r) wrote :

I can confirm the bug is still present.

Sebastien Bacher (seb128) wrote :

Do you still have that problem with GNOME 2.17.91 and herd4?

Laurent (laurent-goujon) wrote :

Seems problem is gone. I just activated again option to only fetch main headers and I'm now able to see all my mails and get the new ones.

Ruben Vermeersch (ruben) wrote :

Still happens with the following:

evolution 2.9.91-0ubuntu1
evolution-data-server 1.9.91-0ubuntu1

Ruben Vermeersch (ruben) wrote :

Oh no, this is a different bug. Seems to work for me. Sorry about that!

Sebastien Bacher (seb128) wrote :

thank you for the update, marking fixed then

Changed in evolution:
status: Fix Committed → Fix Released
Changed in evolution:
status: In Progress → Fix Released
Daniel Hladek (dhladek) wrote :

It look like that this bug has appeared again or evolution 2.22.1 on ubuntu 8.10.
It is not able to display new messages for one of my accounts. There are no error messages. The account works fine with other clients. The other one on gmail works correctly.

allartk (allartk) wrote :

I'm experiencing the same on ubuntu 8.10.

Just go to another folder and go back displays the new messages, but that is very annoying.

Changed in evolution:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.