Evolution - "Error while Refreshing folder" - IMAP password issue

Bug #813772 reported by Ray Nichols on 2011-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

After booting my computer I encounter, for more than half the time, a message from Evolution that a single IMAP+ account cannot be read with:

Error while storing folder 'INBOX'....
Error while Refreshing folder 'INBOX'....

This seems to be an issue with Evolution reading my password properly. It reads like Bug #183136 but the workaround in that report - message #40 - about deleting folders.db didn't help.

If I check my passwords in:
System / Preferences / Passwords and Encryption keys (Seahorse)
they are fine.

I've found as a workaround I can:
- Delete the single password in Seahorse
- In Evolution use menu: File / Forget Passwords - but this forgets everything which I find time consuming to re-instate

However, Evolution can take hours to ask you for your password again. I can't force it to do this sooner. Eventually a dialog box pops up asking you. After that IMAP folders start working again.

Anyone know a better workaround or a fix?

My details:

$ lsb_release -rc
Release: 10.10
Codename: maverick

Evolution version: 2.30.2

Package:

$ dpkg -l evolution
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===========================================-===========================================-======================================================================================================
ii evolution 2.30.3-1ubuntu7.3 groupware suite with mail client and organizer

Ray Nichols (ray-rdnichols) wrote :

I believe my error was down to an IMAP server problem. I thing resetting the password was just a way to encourage Evolution to re-try the connection.

I'd recommend anyone encountering this error to try the connection with Thunderbird which can present a more informative message. In my case it was about the number of connections to the IMAP server being exceeded.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers