Evolution can't open some local address books

Bug #787684 reported by Mickael Vedrine on 2011-05-24
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: evolution

Some of my local address books can't be opened. The error message is :

"Unable to open address book

This address book cannot be opened. This either means that
an incorrect URL was entered, or the server is unreachable.

Detailed error; Invalid source"

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: evolution 2.32.2-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
CheckboxSubmission: 1cf592f419e1561b4122217c1967344a
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Tue May 24 18:54:14 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/evolution
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
UpgradeStatus: Upgraded to natty on 2011-05-24 (0 days ago)

David Duffin (davidduffin21645) wrote :

I have same problem. Appeared couple of months ago, and can't fix it. Have tried unstalling and reinstalling evolution - no good

Changed in evolution (Ubuntu):
status: New → Confirmed
Stefano Bagnatica (thepisu) wrote :

If can help, I have this problem and this is my GCONF configuration in /apps/evolution/addressbook, name = sources, 3° value:

<?xml version="1.0"?>
<group uid="1271941921.2531.16@cvs28" name="Su questo computer" base_uri="local:" readonly="no"><source uid="1271941921.2531.25@cvs28" name="Personale" relative_uri="system"><properties><property name="use-in-contacts-calendar" value="0"/><property name="completion" value="true"/><property name="remember_password" value="false"/><property name="default" value="true"/></properties></source><source uid="1295625049.3850.8@cvs28" name="AbleTech" uri="file:///home/sbagnatica/.evolution/addressbook/local/1295625049.3850.8@cvs28" relative_uri="1295625049.3850.8@cvs28"><properties><property name="use-in-contacts-calendar" value="0"/><property name="completion" value="true"/><property name="default" value="true"/></properties></source></group>

The address book "Personale", that have "system" relative_uri, works correcty, and I get "Invalid source" opening address book "AbleTech", with relative_uri 1295625049.3850.8@cvs28.

I see that the "uri" is wrong, because now the addressbook is in .local/share/evolution/addressbook, but I have also tried correcting this URI in GCONF, but the error stays there. I tried opening the addressbook.db.summary files, and they seems ok.

I cannot also delete that address book... I think I'll delele the not working book from GCONF, and recreate manually.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers