[natty] evolution does not work with proxy

Bug #722875 reported by Marco Biscaro on 2011-02-21
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: evolution

When using evolution with a network proxy configured (on gnome-network-properties), it simple does not work.

Running wireshark, I can see that evolution is sending some strange data through the proxy. Please, see attached file.
---
Architecture: i386
DistroRelease: Ubuntu 11.04
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110101)
Package: evolution 2.32.2-0ubuntu7
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=pt_BR:pt_PT:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Tags: natty running-unity
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: Upgraded to natty on 2011-03-25 (43 days ago)
UserGroups: admin plugdev vboxusers

PS: the file is on libpcap format.

Hi,

It would be good if you could further comment on what you find strange about what is going on, and exactly what doesn't work. Is sending email or receiving email failing, or both?

From what I can see the traffic in the capture file looks coherent with using a proxy on port 8080, the only packet seen outside of that port and between these two systems is for 174.129.241.144, which happens to be related to Amazon EC2. Were you using Amazon EC2 in some way at the time?

Since we don't know enough for now to tell what is wrong, I'm setting this to Incomplete.

Changed in evolution (Ubuntu):
status: New → Incomplete

Mathieu, when I open Evolution, the status bar show "Connecting to imap.gmail.com..." and stays this way forever.

In my case, Evolution should NOT use proxy (on Squid, the email ports are blocked, but on iptables they aren't).

I can't receive or send mails when the proxy is defined on gnome-network-properties (even when I set "Direct connection" on Evolution).

Changed in evolution (Ubuntu):
status: Incomplete → New

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 722875

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Gabriele Del Prete (gdelprete) wrote :

I can testify I'm experiencing the same problem. If I set Gnome Proxy to "Use for all protocols" then Evolution stays stuck and is unable to download or send email from IMAP. If I set Gnome Proxy not to use the same proxy for all protocols, but copy the setting for each protocol (HTTP, HTTPS, FTP), then Evolution suddenly reacts and:
- ask me to accept the certificate (if the IMAP connection is set to use TLS or SSL)
- download folders and mails successfully.

apport information

tags: added: apport-collected natty running-unity
description: updated

Marking bug as confirmed, per comment #6.

Changed in evolution (Ubuntu):
status: New → Confirmed
Noel Shelton (noel-noelshelton) wrote :

I suspect this is the same as bug 773908 https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/773908. No resolution, but it seems that if you start Evolution with the gnome proxy settings set to Direct Connect, then change the proxy settings back after Evolution starts, it continues to work and the apps that need the prosy setting work as well. This has worked for me. Since I run Evolution 24/7, the only time I need to play this trick on Evolution is after booting. Hopes this helps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers