Ubuntu

Can't provide password for account capplet although it asks me to

Reported by Muelli on 2011-02-13
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evolution
Expired
Medium
Mago
Undecided
Unassigned
evolution (Ubuntu)
High
Rodrigo Moya
Natty
High
Rodrigo Moya

Bug Description

Binary package hint: evolution

I wanted to set up my email account, but I failed because the Evolution account capplet wants me to enter my password but doesn't provide any input method...

ProblemType: BugDistroRelease: Ubuntu 11.04
Package: evolution 2.32.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
Architecture: amd64
Date: Sun Feb 13 03:25:01 2011InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201.2)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bashSourcePackage: evolution

STEP TO REPRODUCE:
Got to System -> Preferences -> Email Settings OR
execute evolution-settings

WORKAROUND:
Go through new account wizard by launching Evolution

tags: removed: running-unity
Changed in evolution (Ubuntu):
importance: Undecided → High
status: New → Triaged
description: updated
summary: - Can't provide password for account capplet althought it asks me to
+ Can't provide password for account capplet although it asks me to
description: updated
Martin Pitt (pitti) wrote :

Rodrigo, can you please check if this still happens on the current version, and if so, forward this upstream? Can you please evaluate what it would take to fix this? Perhaps it's just a hidden widget (there is some blank space in the dialog). If you don't have time, please assign to canonical-desktop-team. Thanks!

Changed in evolution (Ubuntu Natty):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Changed in evolution (Ubuntu Natty):
status: Triaged → In Progress

This also happens to me with version 2.32.2 and Natty. I found a way to setup my account by opening Evolution Calendar instead of Mail, that brings the older (First Time) account setup manager.

Rodrigo Moya (rodrigo-moya) wrote :

Also applies to upstream version (https://bugzilla.gnome.org/show_bug.cgi?id=644560), so doing a fix there that I will backport

Rodrigo Moya (rodrigo-moya) wrote :

Upstream code is ok, the culprit is a patch we have on the Ubuntu package, so proposing a branch with that patch removed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.32.2-0ubuntu4

---------------
evolution (2.32.2-0ubuntu4) natty; urgency=low

  * debian/patches/95-git-04-express_acount_setup_5a25840.patch:
    - Remove unneeded patch that was getting the wrong widget (LP: #717971)
 -- Rodrigo Moya <email address hidden> Wed, 23 Mar 2011 16:21:36 +0100

Changed in evolution (Ubuntu Natty):
status: In Progress → Fix Released
Changed in evolution:
importance: Unknown → Medium
status: Unknown → Incomplete
jo (bapjo75) wrote :

This also affects me I recently updated to ubuntu 11.04 beta 1 from ubuntu 10.10. this was happening in alpha 3 also. so i reinstalled 10.10. please help as i thought this bug would have been solved hence installed the beta 1 but it is still there

Rodrigo Moya (rodrigo-moya) wrote :

jo, what version of evolution do you have (run 'dpkg -l evolution' on a terminal). The version containing the fix is 2.32.2-0ubuntu4

jo (bapjo75) wrote :

Hi Rodrigo,

the out put of command: dpkg -l evolution is

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii evolution 2.32.2-0ubuntu groupware suite with mail client and organiz

jo (bapjo75) wrote :
Download full text (4.0 KiB)

when i run evolution from command prompt following is the output: just in case if this gives you any clue

****************************************************************************************************

root@RDL:/home/j0053# evolution

(evolution:21914): GLib-GObject-WARNING **: g_object_get_property: object class `EShellSettings' has no property named `cal-primary-calendar'

(evolution:21914): GLib-GObject-WARNING **: g_object_set_property: object class `EShellSettings' has no property named `cal-primary-calendar'

(evolution:21914): evolution-mail-WARNING **: unable to open /root/.config/evolution/mail/gtkrc-mail-fonts

(evolution:21914): evolution-mail-WARNING **: unable to open /root/.config/evolution/mail/gtkrc-mail-fonts

(evolution:21914): evolution-mail-WARNING **: unable to open /root/.config/evolution/mail/gtkrc-mail-fonts

(evolution:21914): evolution-mail-WARNING **: unable to open /root/.config/evolution/mail/gtkrc-mail-fonts

(evolution:21914): evolution-mail-WARNING **: unable to open /root/.config/evolution/mail/gtkrc-mail-fonts

(evolution:21914): evolution-mail-WARNING **: unable to open /root/.config/evolution/mail/gtkrc-mail-fonts

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(evolution:21914): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
root@RDL:/home/j0053# exit
exit
j0053@RDL:~$ evolution

(evolution:21940): Gtk-CRITICAL **: IA__gtk_icon_info_get_filename: assertion `icon_info != NULL' failed

(evolution:21940): Gtk-CRITICAL **: IA__gtk_icon_info_free: assertion `icon_info != NULL' failed

(evolution:21940): Gtk-CRITICAL **: IA__gtk_icon_info_get_filename: assertion `icon_info != NULL' failed

(evolution:21940): Gtk-CRITICAL **: IA__gtk_icon_info_free: assertion `icon_info != NULL' failed

(evolution:21940): e-table-WARNING **: Icon 'stock_mail-unread-multiple' not present in theme

(evolution:21940): e-table-WARNING **: Icon 'stock_mail-open-multiple' not present in theme

(evolution:21940): e-table-WARNING **: Icon 'stock_mail-flag-for-followup' not present in theme

(evolution:21940): e-table-WARNING **: Icon 'stock_mail-flag-for-followup-done' not present in theme

(evolution:21940): e-table-WARNING **: Icon 'stock_score-lowest' not present in theme

(evolution:21940): e-table-WARNING **: Icon 'stock_score-lower' not present in theme

(evolution:21940): e-table-WARNING **: Icon 'stock_score-low' not present in theme

(evolution:21940): e-table-WARNING **...

Read more...

jo (bapjo75) wrote :

yesterday my evolution gout upgraded
when i use the same command
dpkg -l evolution
the output is:
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii evolution 2.32.2-0ubuntu groupware suite with mail client and organiz

I am still not able to receive or send mails through evolution.
the main problem seems to be that the pop up window of authentication is not apearing and hence finally i get message of connection timed out
I am against a proxy on lan connection in my office. i am using POP server for receiving and smtp for sending
both servers need authentication password with same email id
in smtp configuration i am using pop before smtp option, once i tried login also but nothing worked. Please help me resolve the issue.
I tried reinstalling evolution from synaptic but nothing worked as yet.
As this is my mail handler for office mail its becoming too inconvinient to always use mail through my website as it has limited quota.

jo,

If you open a guest session and try to run evolution and connect to your email, does it work? If so, it may indicate there's a problem with the configuration files for evolution in your home directory.

I think it's worth trying to switch the theme to use a different icon set too, given the numerous errors about missing icons.

Rodrigo Moya (rodrigo-moya) wrote :

Also, jo, you shouldn't be using root user for your X session. It's for security, so please create a user and use that. Also, it seems from your comments that you're using 10.10, which AFAIK doesn't have the fix for this, and also, your last comment, it seems your problem is a separate issue than the original bug. That is, you're saying you're never getting asked for a password because you get a timeout, so since you're using a proxy, make sure the proxy settings are correctly entered in Evolution's preferences.

But if the problem you're mentioning is not about the evolution-settings process this bug refers to, please file a separate bug

jo (bapjo75) wrote :

Thank you for many suggestions,
I am using a user session and not root, my mistake that i sent you the output of dpkg -l evolution from SU mode.
I have tried with change in theme, it has resolved a lot of icon errors.
About version my output at command prompt shows
j0053@RDL:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu Natty (development branch)"
j0053@RDL:~$

I tried changing locally the proxy setting in evolution from system config setting to manual proxy settings it is also not helping out.
Can you please guide me on configuration files for evolution in home directory.
Its still not working nowfollowing command shows as below

 j0053@RDL:~$ dpkg -l evolution
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii evolution 2.32.2-0ubuntu groupware suite with mail client and organiz
j0053@RDL:~$

jo (bapjo75) wrote :

even in guest session it does not fetch mail till date, can anyone help, what problem it can be, i tried reinstalling evolution including gnome

Rodrigo Moya (rodrigo-moya) wrote :

jo, can you file a separate bug for your issue? It's not related to this bug report. But it really looks to me to be a proxy problem, so make sure your proxy settings are correct

Changed in evolution:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.