Inbox folder on IMAP disappears spontaneously

Bug #671977 reported by Daniel Wagenaar on 2010-11-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

In Evolution 2.30.3, my "Inbox" folder on an IMAP server disappears spontaneously, even for a newly created local user. Deselecting and reselecting the folder in Subscriptions temporarily fixes the problem, but the Inbox does disappear again at an apparently arbitrary later time.

1. Release: Ubuntu 10.10.
2. Package: Evolution 2.30.3-1ubuntu7.
3. Expectation: I expect the "Inbox" folder to be listed along with the other folders on my IMAP account.
4. What happened: The "Inbox" folder is not listed.

This problem does not occur on all IMAP accounts. Notably, at least one dovecot server seems to be unaffected.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.3-1ubuntu7
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Sat Nov 6 14:53:26 2010
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/zsh
 LANG=en_US.utf8
SourcePackage: evolution

Daniel Wagenaar (dawagenaar) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you try if using imap+ solves your issue?

Changed in evolution (Ubuntu):
importance: Undecided → Low
Changed in evolution (Ubuntu):
status: New → Incomplete

On Mon, 2010-11-08 at 10:18 +0000, Sebastien Bacher wrote:
> thank you for your bug report, could you try if using imap+ solves your
> issue?

It does not solve it. With imap+, the Inbox folder's icon does not
disappear, but its contents are not there: Evolution says "There are no
messages in this folder." Clicking "Send/Receive" or restarting
evolution does not help.

It may be worth noting that this issue has been seen in other distros
too:

http://bugs.gentoo.org/show_bug.cgi?id=325289
https://bugzilla.gnome.org/show_bug.cgi?id=620728
https://bugzilla.redhat.com/show_bug.cgi?id=603146

Daniel Wagenaar (dawagenaar) wrote :

Today my INBOX disappeared again, this time there was an error message at the same time:

    Cannot write offline journal for folder 'INBOX': No such file or directory

I ran evolution with CAMEL_DEBUG=all, and I am attaching a portion of the resulting log file.

Note that the reported error and the disappearance of the INBOX coincided in time, but I have no direct evidence for a causal connection between the two events.

Of course, I would be happy to perform any further tests that might help solve this bug.

Ok... A strange solution, but seems to work as a temporarily workaround for at least one IMAP server here... Maybe this points to a problem with Evo's socket buffering or some type of timing/race condition???

On the configuration screen for the account with the original IMAP plugin, enable the "Command to connect to server" option. For the command, pipe Evolution's input and output to and from Netcat:

Command:
nc <server name or IP> 143

This has ONLY been tested with TLS auth on my infrastructure here, but has triaged the issue reliably on impacted systems.

+1 on a bug fix being issued, or 2.32 being made available in the backports repo (2.32 fixes this issue, among others).

ridgerunner7 (ridgerunner7) wrote :

I have the same behavior same configuration. I also upgraded from lucid. Not sure why this was "incomplete" especially since its occurring on other distros as well.

Changed in evolution (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

could anyone try to reproduce the issue with evolution 2.32 from this ppa https://launchpad.net/~mathieu-tl/+archive/build-tests

The bug seems to be fixed in the Evolution 2.32 build from PPA https://launchpad.net/~mathieu-tl/+archive/build-tests on my system. Tested against Citadel 7.85 IMAP.

ridgerunner7 (ridgerunner7) wrote :

did:
added your ppa
apt-get update
apt-get upgrade
resulting error:
Errors were encountered while processing:
 /var/cache/apt/archives/libcamel1.2-19_2.32.0-0ubuntu1~mtrudel~bt2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

looking up further in the install log there was:
Selecting previously deselected package libcamel1.2-19.
Unpacking libcamel1.2-19 (from .../libcamel1.2-19_2.32.0-0ubuntu1~mtrudel~bt2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libcamel1.2-19_2.32.0-0ubuntu1~mtrudel~bt2_amd64.deb (--unpack):
 trying to overwrite '/usr/share/lintian/overrides/libcamel1.2-14', which is also in package libcamel1.2-14 2.30.3-2ubuntu2
dpkg-deb: subprocess paste killed by signal (Broken pipe)

tried:
apt-get -f install
same errors result

tried:
apt-get remove libcamel1.2-14

results in:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 evolution : Depends: libcamel1.2-19 (>= 2.32) but it is not going to be installed
 evolution-data-server : Depends: libcamel1.2-19 (>= 2.32.0) but it is not going to be installed
 evolution-exchange : Depends: libcamel1.2-19 (>= 2.32) but it is not going to be installed
 evolution-plugins : Depends: libcamel1.2-19 (>= 2.32) but it is not going to be installed
 libebook1.2-9 : Depends: libcamel1.2-19 (>= 2.32) but it is not going to be installed
 libedataserverui1.2-8 : Depends: libcamel1.2-19 e(>= 2.32) but it is not going to be installed

tried:
deleting the cached pkg, libcamel1.2-19
apt-get -f install libcamel1.2-19

recommendations?

Omer Akram (om26er) wrote :

ridgerunner7, disable the ppa and do sudo apt-get update and do the following(there might be little typos)

$ sudo apt-get install evolution/maverick evolution-common/maverick evolution-data-server/maverick evolution-exchange/maverick evolution-plugins/maverick libebook1.2-9/maverick libedataserverui1.2-8/maverick evolution-indicator/maverick libebackend1.2-0/maverick libebook1.2-9/maverick libecal1.2-7/maverick libedata-book1.2-2/maverick libedata-cal1.2-7/maverick libedataserver1.2-13/maverick libedataserverui1.2-8/maverick libegroupwise1.2-13/maverick libevolution/maverick libgtkhtml-editor-common/maverick libgtkhtml-editor0/maverick libgtkhtml3.14-19/maverick

            *and anyone else I recommend not to use the ppa.*

ridgerunner7 (ridgerunner7) wrote :

btw, you missed one pkg: evolution-data-server-common
down-graded fine after adding that last pkg. I'm willing to try again when you find the typos.

Jörg Frings-Fürst (jff-de) wrote :

Bug from 2010. Version not longer supportet.
Change status to Invalid (see gnome-bugs)

Changed in evolution (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.